Failed to start D-Bus after system update

My system is halted at startup, after system update.
I’m getting some error messages, that I think, are all related to the first one that is:

Failed to start D-Bus System Message Bus

I’ve tried the following, with no success:

  • Switched to fallback kernel grab option and got the same messages.
  • CTRL+ALT+F2 didn’t work
  • “manjaro-chroot -a” and then “pacman-mirrors --fasttrack 5 && pacman -Syyu” on live ISO resulted: “there is nothing to do”
  • “sudo journalctl -b0 -p4” resulted with “-- No entries --”

SSH was rejected so I’ve problem with attaching large logs here. I’ve looked at similar post in this forum, but didn’t manage to find a solution.

The kernel version is: 5.15.146-1MANJARO x64

Is there a fix for my system?

Try this… :point_down:

sudo pacman -Syu dbus-broker-units

I had the (almost) same issue: Stable update 2024-01-13: dbus-broker-units has broken Light Display Manager

Solved by removing dbus-broker-units and install dbus-daemon-units.

I’ve go the errors, listed in the following photo link:

Looks like your mirror list and possibly your file list are corrupted. You’ve got too many failed downloads and the error messages also state that your dbus-broker-units package is corrupted. It could all have been caused by an intermittent network connection at your end.

I would advise booting up from the live USB and first checking your filesystem integrity, just so as to exclude that from being the cause of the corrupted package. Do not mount the filesystem yet at this point, but run a full fsck on it. Then, if everything checks out okay, mount and manjaro-chroot into your system, roll back your most recent backup from before the update, and try the update process again, as follows… :point_down:

pacman-mirrors -f && pacman -Fy && pacman -Syyu

Thanks D.Dave and Aragorn!
Switching to dbus-daemon-units worked, But as Aragorn noticed I had a lot of package integrity errors.
I’ve tried reinstalling and refreshing keys to solve PGP signature error in order to install dbus-daemon-units. The problem was solved, when I’ve adjusted the live ISO clock…
Now the system is working.


This post was flagged by the community and is temporarily hidden.