Failed to load kernel modules, I was trying to set up virtual machine when this massacre happened

I was making virtual machine using the virtual box, of opensuse. I had installed a new kernel linux59-rt because the linux59 was not supported by the virtual box.

This is not where the problem came, I did not remove the old kernel.
I was following the manjaro wiki and for some reason sudo vboxreload was not working.
I booted again and changed the kernel to the linux59-rt and then I ran this command

sudo mod something when the screen got stuck, I had to turn off using the power button and when I started again I got cannot load kernel modules.

[manjaro ~]# lsblk 
loop0    7:0    0  27.5M  1 loop /run/miso/sfs/livefs
loop1    7:1    0 620.5M  1 loop /run/miso/sfs/mhwdfs
loop2    7:2    0   1.7G  1 loop /run/miso/sfs/desktopfs
loop3    7:3    0 667.8M  1 loop /run/miso/sfs/rootfs
sda      8:0    0 931.5G  0 disk 
├─sda1   8:1    0 627.5G  0 part 
├─sda2   8:2    0     4G  0 part 
└─sda3   8:3    0   300G  0 part 
sdb      8:16   1  15.1G  0 disk /run/miso/bootmnt
├─sdb1   8:17   1     3G  0 part 
└─sdb2   8:18   1     4M  0 part 
sr0     11:0    1  1024M  0 rom  
[manjaro ~]# 

Hi @zuuks666,

  1. I’ve been there as well, but there is hardly any reason to switch off your computer like that. And apparently it includes system freezes. Please see [HowTo] reboot / turn off your frozen computer: REISUB/REISUO for more information.
  2. Kernel version 5.9 is EOL. I don’t know about the RT version, though. However, I highly doubt an RT version is necessary as I have a normal kernel version, always have, and virtualbox worked fine when I used it.
  3. More information will be needed if someone is to help, so please see How to provide good information
1 Like

What module have you installed? Please post the output of:

pacman -Q | grep -e linux -e virtualbox

EDIT: if you can’t boot, then boot from a live iso and chroot into the installed system.