Failed to launch linuxqq

installed from AUR store, only return error message box after launch
i have tried every version exists in the store, almost reports the same error :cry:

The packages you can build using script from AUR is unsupported.

Which error message?

No screenshots - please - just the textual output

Have you tried running from terminal?

thanks for reply, i’d like to show you but it seems i can’t insert images in my reply, so it’s basically
{“message”:"node-loader:\nError:libcfitsio.so.10: (bunch of garbled symbol)}

When you build from AUR it is recommended to use testing or unstable branch to avoid weird problems - library incompatibilities.

The reason being that unstable is equivalent to Arch stable and AUR expects Arch package level.

sudo pacman-mirrors -aS unstable && sudo pacman -Syyu

I doubt that will help anything. If you look at the comments of the package in AUR and you’re able to understand Chinese you will see that it is a) outdated, and b) most likely has the issue you have already reported: AUR (en) - linuxqq So you may want to use flatpak or official appimage instead to avoid dependency issues as electron apps can be very picky: Linux QQ

1 Like

thanks, i will try the newer one

For the verification - I tried building the package linuxqq and I was able to launch the app from terminal.

My system is running KDE Plasma on unstable branch.

There is some warnings but those does not prevent the app from starting

 $ linuxqq

(process:25752): VIPS-WARNING **: 07:51:28.109: unable to load "/usr/lib/vips-modules-8.14/vips-openslide.so" -- libopenslide.so.0: cannot open shared object file: No such file or directory

(process:25752): GModule-CRITICAL **: 07:51:28.109: g_module_make_resident: assertion 'module != NULL' failed
[25798:0328/075129.522435:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 1 times!
[25798:0328/075132.193244:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 2 times!
[25798:0328/075138.739993:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 3 times!
Initial load

image

Excellent, however in this case the messenger is barley maintained in the AUR so using the official appimage published by the software company is the more recommended way here. Also there is no need to switch branches on Manjaro as Appimages contain all the dependencies in the bundle: How to Use AppImage in Linux [Complete Guide] The mentioned Appimage Launcher in the tutorial can be installed via: pamac install appimagelauncher It also tries to keep the managed applications up to date if possible.

:laughing:thanks, i just launched AppImage version successfully, but indeed, it’s better to update my system since i haven’t use this for a while

just launched AppImage version successfully, thanks for helping :smiling_face:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.