Failed Manjaro and Windows dual boot

New user here (also new to Linux).
Here’s my system information:

  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=60d6f1f5-536f-4620-ac5d-8e31bd908748 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: HP product: HP ENVY Laptop 15t-ep000 v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 878F v: 18.33 serial: <filter> UEFI: AMI v: F.06 
  date: 01/18/2021 
  ID-1: BAT0 charge: 71.3 Wh (86.2%) condition: 82.7/82.7 Wh (100.0%) 
  volts: 12.4 min: 11.6 model: HP Primary type: Li-ion serial: <filter> 
  status: Discharging cycles: 26 
  RAM: total: 31.13 GiB used: 2.34 GiB (7.5%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i7-10750H bits: 64 type: MT MCP 
  arch: Comet Lake family: 6 model-id: A5 (165) stepping: 2 microcode: EA 
  cache: L2: 12 MiB bogomips: 62431 
  Speed: 900 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 900 2: 901 3: 900 
  4: 900 5: 900 6: 901 7: 900 8: 900 9: 901 10: 900 11: 901 12: 900 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc 
  cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms 
  est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida intel_pt invpcid 
  invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr 
  nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge 
  pku pln pni popcnt pse pse36 pts rdrand rdseed rdtscp rep_good sdbg sep smap 
  smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow 
  tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave 
  xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Hewlett-Packard 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9bc4 class-ID: 0300 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Hewlett-Packard 
  driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1f95 class-ID: 0300 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa display-ID: :0.0 
  screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.2 
  direct render: Yes 
  Device-1: Intel Comet Lake PCH cAVS vendor: Hewlett-Packard 
  driver: sof-audio-pci-intel-cnl 
  alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 
  chip-ID: 8086:06c8 class-ID: 0401 
  Device-2: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.37 running: yes 
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel 
  port: 4000 bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 1-14:3 chip-ID: 8087:0026 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 4060 bus-ID: 00:17.0 chip-ID: 8086.282a rev: class-ID: 0104 
  Device-1: md127 maj-min: 9:127 type: mdraid level: N/A status: inactive 
  size: N/A 
  Info: report: N/A blocks: 2944 chunk-size: N/A 
  Components: Online: N/A Spare: 
  0: nvme0n1 maj-min: 259:7 size: 27.25 GiB state: S 
  Local Storage: total: 504.19 GiB used: 10.23 GiB (2.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:7 vendor: Intel model: HBRPEKNX0202AHO 
  size: 27.25 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 type: SSD serial: <filter> rev: HPS3 temp: 26.9 C 
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Intel model: HBRPEKNX0202AH 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s 
  lanes: 2 type: SSD serial: <filter> rev: HPS2 temp: 25.9 C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 40.21 GiB size: 39.28 GiB (97.69%) used: 10.17 GiB (25.9%) 
  fs: ext4 dev: /dev/nvme1n1p6 maj-min: 259:6 label: N/A 
  uuid: 60d6f1f5-536f-4620-ac5d-8e31bd908748 
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) 
  used: 62.3 MiB (24.3%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1 
  label: SYSTEM uuid: B458-9AFA 
  Alert: No swap data was found. 
  ID-1: /dev/nvme1n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-2: /dev/nvme1n1p3 maj-min: 259:3 size: 404.69 GiB fs: ntfs label: Windows 
  uuid: 30B810FEB810C46E 
  ID-3: /dev/nvme1n1p4 maj-min: 259:4 size: 527 MiB fs: ntfs 
  label: Windows RE tools uuid: CA80AF1480AF05D3 
  ID-4: /dev/nvme1n1p5 maj-min: 259:5 size: 23.44 GiB fs: <superuser required> 
  label: N/A uuid: N/A 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-9:2 info: Elan Micro ELAN:ARM-M4 type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 04f3:0c4c class-ID: 0000 
  Device-2: 1-14:3 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026 
  class-ID: e001 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 32.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 323 Uptime: 13m wakeups: 1327 Init: systemd v: 249 
  tool: systemctl Compilers: gcc: N/A Packages: 1048 pacman: 1041 lib: 301 
  flatpak: 0 snap: 7 Shell: Bash v: 5.1.8 running-in: xfce4-terminal 
  inxi: 3.3.06 

I was running Windows on my HP Envy 15t laptop (came pre-installed) and decided to dual-boot Windows and Manjaro because I didn’t want to run either on a virtual machine. Possibly a bad decision. I’ll explain my situation.

What happened:
My C drive had BitLocker encryption enabled and Manjaro wouldn’t install with that, so first I had to disable that. No problems there.
In the meantime I also manually created a ~30 GB partition for Manjaro on the same drive (my laptop has only one drive). Worked fine as well.
Then I burned the XFCE version of the ISO to a USB drive. Also no problems.
I inserted the drive into my laptop and restarted it using advanced options, which allowed me to boot from said USB drive.

Up until now, everything was working fine.

But when I tried to boot from the USB, Windows said it wasn’t possible. I was forced to continue back to Windows.
Some digging around on the internet and Linux installation guides told me that I had to disable secure boot first. So I did that by going to BIOS and disabling it from there. Worked as expected. I could still boot Windows so I figured there was no harm in continuing.

So I tried booting from the USB again, and this time it worked, launching Manjaro and its installer. Tried installing Manjaro in that partitioned space. It gave me a warning, saying that it only supported EFX file formats or something like that. Don’t remember exactly. But it let me continue, so I did, because the guides I was reading did the same thing.
This was probably where it all went wrong.

Manjaro failed to install.
No problem, I thought, and restarted my laptop. However, upon booting, Windows started trying to perform automatic repairs and diagnosing my device. Unfortunately, it couldn’t do any sort of repairs, so I was stuck with 2 options: shut down the laptop, or re-try booting from the USB.

I chose the latter.

This time, though, I let Manjaro create the partition in the disk itself, which worked fine. It also managed to install properly, which was a saving grace, because otherwise my laptop would be pretty much unusable.

The present:
Although Manjaro has installed properly and is working just fine, there is one major problem: in the file system (/), it tells me I have only ~27 GB of space remaining. I can also navigate to a “Windows” directory (in “Devices”, along with “File System”), which seems to contain all of my files from the Windows installation. This one has ~240 GB of space remaining.
I don’t know if I can (or should) use that directory. Is it even safe to read and write files from there? Or even possible?
If not, how do I get Manjaro to free up more space for itself? I do have an external hard drive that I can use as a temporary measure (and also has backups of all my important files), but it’s just not practical.
And is it recommended (or worth it) to try dual booting Windows and Manjaro again or would I just end up further bricking my laptop?

Really would appreciate some quick and useful solutions on this.

I tried to dual-boot Manjaro and Windows. Disabled C drive encryption, created partition manually, disabled secure boot, then tried installing Manjaro from a USB. Attempt 1 failed. Could not boot Windows after that.
Tried installing again and let Manjaro do its own partitioning. This succeeded. Still can’t load Windows.
Manjaro file system says I only have 27 GB space remaining. Windows file system (device?) has 240 GB. Need it to be the other way around, or need to be able to recover Windows. Auto recovery not working.

Hi and welcome to the forum :wave:

Please add a overview of your system (see how to provide good information) to the post, it had some details most users who support others know what to look for in your case and lend a hand.

One thing to start to check is the following: Since booting into manjaro works, you maybe need to tell grub to find your windows install to boot from.the output of sudo update-grub should have 2 lines that look like this on a recent install:

Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.

If you have the output below:

Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.

then you need to enable os-prober, the easiest with the following command combination in a terminal: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

I probably won’t be of much further use to you since I will be away for at least a day. For a first post, :+1: it sounds like a learning journey, i hope it is educational :slight_smile:

A dual boot guide that on this forum is a good read / guide to follow along. (no personal experience with dual booting)

One way to start over with windows and make a rescue usb drive is described here

Hi, thanks for the reply.
I ran sudo update-grub, and this was the output:

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.13-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.13-x86_64.img
Found initrd fallback image: /boot/initramfs-5.13-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/nvme1n1p1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Root partition isn't a btrfs filesystem.
This script only supports snapshots of the btrfs filesystem.
If you think an error has occurred , please file a bug report at " "
Nothing to do. Abort.
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme1n1.

Not sure what to do now.

I don’t know how you to help you now, but if you repair Windows and keep trying to dualbooting, deactivate FastBoot in Windows or you’ll have problems booting into Windows after booting directly into manjaro.

Alternatively, don’t boot into manjaro, boot into windows and then reboot into manjaro. But if you forget it,…

It has to do with windows not writing everything to disk during the shutdown in order to shutdown faster and boot faster next time.

That’s my experience.