Failed installing icu (75.1-1) breaks dependency 'libicui18n.so=74-64' required electron25

Im on
x86_64
Manjaro Linux
DISTRIB_ID=“ManjaroLinux”
DISTRIB_RELEASE=“24.0.0”
When I do

sudo pacman -Syu                                          ✔  UK  
error: failed to prepare transaction (could not satisfy dependencies)
:: installing icu (75.1-1) breaks dependency 'libicui18n.so=74-64' required by electron25

How do I fix?

what depends on electron25?
Why is it installed?
… can you temporarily remove them? electron25 is from the AUR and would need to be rebuilt

electron25 is an unsupported third party package.

sudo pacman -Rns electron25

Nothing in the repos anymore.

Because something previously required it.

FYI, older, insecure Electron packages are dropped from the repos to the AUR once nothing requires them.

is there a command line tool to determine dependency chains?
a search of the wiki does not reveal it…

For simple direct depends you can look at the package info;

pacman -Qi electron25

To see a tree you could use

pactree -r electron25

pactree is provided by the pacman-contrib package.

1 Like

thanks that will prove useful

However, if you happen to have an appication that absolutely must use electron25 (as is the case with one app I use) you could likely use electron25-bin from the AUR until that application is updated.

1 Like

No electron 25 anymore problem solved. Thanks guys.

Got the same error and solved this way.

Also we can use this moment to delete the orphaned packages and prevent future similar problems :slight_smile:

$ pacman -Qdt
$ sudo pacman -Rs $(pacman -Qdtq)
2 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.