External monitor not detected

I’ve been trying to get my laptop to connect to an external monitor, but it’s not working. When I use xrandr to check the display information, it only shows the information for edp1 which I assume is my laptop. It doesn’t show me any information about any other display port or displays connected to my laptop. The system settings don’t show anything related to the external monitor. The only thing that detects the external monitor is the nvidia xserver settings. I have no idea what to do and I can’t find anything online that helps.

1 Like

We need more information:

At the least we need hardware details. If the machine has hybrid graphics you may need to create a virtual device.

1 Like

An inxi --full --admin --verbosity=7 --filter --no-host would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

:innocent:

1 Like
System:
  Kernel: 5.7.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=7ea97d17-48db-4568-81fe-7cc92a1c4a9b rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LENOVO product: 81SY v: Lenovo Legion Y540-15IRH-PG0 
  serial: <filter> Chassis: type: 10 v: Lenovo Legion Y540-15IRH-PG0 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0Q55722 WIN serial: <filter> 
  UEFI: LENOVO v: BHCN29WW date: 06/19/2019 
Battery:
  ID-1: BAT0 charge: 47.1 Wh condition: 48.0/52.5 Wh (91%) volts: 12.7/11.2 
  model: SMP L17M3PG1 type: Li-poly serial: <filter> status: Unknown 
  cycles: 42 
Memory:
  RAM: total: 7.66 GiB used: 1.41 GiB (18.4%) 
  RAM Report: 
  permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Topology: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: D6 L2 cache: 8192 KiB bogomips: 38408 
  Speed: 1301 MHz min/max: 800/2400 MHz Core speeds (MHz): 1: 1300 2: 1300 
  3: 1300 4: 1300 5: 1301 6: 1301 7: 1300 8: 1300 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon 
  art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm 
  lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
  pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti 
  pts rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Lenovo 
  driver: nvidia v: 440.100 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1f91 
  Device-3: Lite-On Integrated Camera type: USB driver: uvcvideo 
  bus ID: 1-6:3 chip ID: 04ca:7070 
  Display: x11 server: X.Org 1.20.8 driver: modesetting,nvidia 
  alternate: fbdev,intel,nouveau,nv,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 
  size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.5 
  direct render: Yes 
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:a348 
  Sound Server: ALSA v: k5.7.15-1-MANJARO 
Network:
  Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi 
  v: kernel port: 5000 bus ID: 00:14.3 chip ID: 8086:a370 
  IF: wlp0s20f3 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 3000 bus ID: 07:00.0 
  chip ID: 10ec:8168 
  IF: enp7s0 state: down mac: <filter> 
  WAN IP: <filter> 
Drives:
  Local Storage: total: 953.87 GiB used: 17.74 GiB (1.9%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKKW010T8L size: 953.87 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: L12C scheme: GPT 
  Message: No Optical or Floppy data was found. 
RAID:
  Message: No RAID data was found. 
Partition:
  ID-1: / raw size: 94.87 GiB size: 92.88 GiB (97.90%) 
  used: 17.69 GiB (19.0%) fs: ext4 dev: /dev/nvme0n1p6 label: N/A 
  uuid: 7ea97d17-48db-4568-81fe-7cc92a1c4a9b 
  ID-2: /boot/efi raw size: 260.0 MiB size: 256.0 MiB (98.46%) 
  used: 54.2 MiB (21.2%) fs: vfat dev: /dev/nvme0n1p1 label: SYSTEM_DRV 
  uuid: 90BA-B896 
Swap:
  Alert: No Swap data was found. 
Unmounted:
  ID-1: /dev/nvme0n1p2 size: 16.0 MiB fs: <superuser/root required> 
  label: N/A uuid: N/A 
  ID-2: /dev/nvme0n1p3 size: 366.16 GiB fs: ntfs label: Windows-SSD 
  uuid: A07CBD9F7CBD7120 
  ID-3: /dev/nvme0n1p4 size: 533.0 MiB fs: ntfs label: N/A 
  uuid: 626608B466088B4D 
  ID-4: /dev/nvme0n1p5 size: 492.04 GiB fs: ntfs label: STORAGE 
  uuid: 8E6EE9006EE8E247 
USB:
  Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 
  Device-1: 1-1:2 info: Logitech Unifying Receiver type: Keyboard,Mouse 
  driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 046d:c534 
  Device-2: 1-6:3 info: Lite-On Integrated Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 04ca:7070 
  Device-3: 1-9:4 info: Integrated Express ITE Device(8910) type: Keyboard 
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s 
  chip ID: 048d:c100 
  Device-4: 1-14:5 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  chip ID: 8087:0aaa 
  Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s 
  chip ID: 1d6b:0003 
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 278 Uptime: 3m Init: systemd v: 245 Compilers: gcc: 10.1.0 
  Packages: pacman: 1103 lib: 310 flatpak: 0 Shell: Bash v: 5.0.18 
  running in: xfce4-terminal inxi: 3.1.05

BJM2125 Are you Ursavus ad have you lost your password or are you someone else with the same problem?

:thinking: