External hard drive not mounting

I found an external hardware that I’ve had lying around for 10 years (buried in the basement, didn’t even remember I had it). I had to get one anyway as I’m running out of storage on my laptop, so finding one was great. However, after 10 years I didn’t have much faith in it working.

I plugged it in and there were all the files! I spent half an hour searching through all those files filed with nostalgia. It’s a 1 TB drive and was more than half empty, so plenty of space to move some things over from the laptop which has 230 GB. Great.

I deleted some useless files that were on the drive, awesome, no problem.

I cut and paste some files from the laptop to the drive. It starts to copy, great. Suddenly, unknown error. It can’t find the folder on the drive I was copying to. Annoying, but ok, lets see what happened. Drive isn’t mounted. Ok, maybe lose cable? Adjust and lets try again.

Unknown error, can’t mount drive. Over and over. Can’t open, can’t mount. Tried rebooting, same problem.

It’s an ntfs drive. If you need any more data let me know.

Thanks in advance for any help!

Do you have NTFS-3G package installed?

1 Like

I don’t know, I’m pretty knew to this. how can I check?
But if it was a case of lack of support for the file system, wouldn’t I not have been able to read it in the first place?
However, let me know how to check please and I can try to see if that solves the problem.


You can check several ways. Here are a couple: pacman -Q ntfs-3g
or you could search for the version of ntfs-3g: ntfs-3g -v.

A quick search on the internet showed some suggestions to run chkdsk in Windows to repair the drive.

1 Like

To see it if it installed, just look in Octopi software and see if it is installed. I believe there is read only support out of the box…

If you think the drive may have errors, try Gparted, top menu > Device > Attempt Data Rescue may help also.

1 Like

ok, I ran it and I do have ntfs support:

pacman -Q ntfs-3g
ntfs-3g 2017.3.23-5

ntfs-3g -v
ntfs-3g: No device is specified.

ntfs-3g 2017.3.23 external FUSE 29 - Third Generation NTFS Driver
Configuration type 7, XATTRS are on, POSIX ACLS are on

Copyright © 2005-2007 Yura Pakhuchiy
Copyright © 2006-2009 Szabolcs Szakacsits
Copyright © 2007-2017 Jean-Pierre Andre
Copyright © 2009 Erik Larsson

Usage: ntfs-3g [-o option[,…]] <device|image_file> <mount_point>

Options: ro (read-only mount), windows_names, uid=, gid=,
umask=, fmask=, dmask=, streams_interface=.
Please see the details in the manual (type: man ntfs-3g).

Example: ntfs-3g /dev/sda1 /mnt/windows

I can’t run anything in Windows because I only have my Manjaro computer, (And an android phone and tablet), no windows devices.

I suggest this is an usb device. older drives need a lot of power. did you check a usb-cable that use two connections at the computer ?

1 Like

So I Attempted Data Rescue in Gparted and I got
“Failed creating read-only view”
An error occurred wile creating the read-only view.
Either the file system can not be mounted (like swap), or there are inconsistencies or errors in the file system.

The thing is I could read the data when I first plugged it in, and then I stopped being able to. It may have got damaged at some point when I was exploring it and trying to copy some files over.

Any suggestions for how I can access it again and get my data?

Why not just install windows in a VM and attach the drive to the VM?

1 Like

It’s a good idea. But I don’t own a copy of windows… I don’t suppose there’s a legal way of getting a free copy for that purpose? I don’t want to (better said, I can’t afford) to spend the money for a one time use

I didn’t, no. It didn’t occur to me. But it always worked with one usb and it worked for a bit before stopping working. If it required two USBs wouldn’t it not have worked at all the first time?

Have a look at this: NTFS-3G - ArchWiki

1 Like

A ten-year old USB drive (or any drive of that matter) should be considered unsafe and unreliable to store any new data. You’re lucky that it could momentarily read files, after having been unpowered for a decade. :frowning: Any part of the mechanical components could be malfunctioning, let alone existing unrecoverable / unreadable sectors scattered over the platters.

What does the output of this command show? (S.M.A.R.T. error log)
sudo smartctl -l error /dev/sdX

(Replace sdX with the device name.)

What about the selftest results?
sudo smartctl -l selftest /dev/sdX

What happens if you try to run a quick short test?
sudo smartctl -t short /dev/sdX
(wait a few minutes and then…)
sudo smartctl -l selftest /dev/sdX

1 Like

I hadn’t thought of the shelf life…
Even if I can’t end up using to store new data I’d at least like to recover the data that’s on it…
Here is the output of those commands:

sudo smartctl -l error /dev/sdb
[sudo] password for ross:
smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.10.23-1-MANJARO] (local build)
Copyright © 2002-20, Bruce Allen, Christian Franke, w w w.smart montools. org

SMART Error Log Version: 1
No Errors Logged

sudo smartctl -l selftest /dev/sdb
smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.10.23-1-MANJARO] (local build)
Copyright © 2002-20, Bruce Allen, Christian Franke, w w w.smart montools .org

SMART Self-test log structure revision number 1
No self-tests have been logged. [To run self-tests, use: smartctl -t]

sudo smartctl -t short /dev/sdb
smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.10.23-1-MANJARO] (local build)
Copyright © 2002-20, Bruce Allen, Christian Franke, w w w.smart montools .org

Sending command: “Execute SMART Short self-test routine immediately in off-line mode”.
Drive command “Execute SMART Short self-test routine immediately in off-line mode” successful.
Testing has begun.
Please wait 2 minutes for test to complete.
Test will complete after Sun Apr 4 10:34:55 2021 EDT
Use smartctl -X to abort test.

sudo smartctl -l selftest /dev/sdb
smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.10.23-1-MANJARO] (local build)
Copyright © 2002-20, Bruce Allen, Christian Franke, w w w.smart montools. org

SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error

1 Short offline Completed: read failure 90% 5678 260940480

Since a short test already results in a read failure, there’s no point in running an extended test.

If you have 1TB of free space somewhere, you can create an image of the entire drive, with which you can later try to recover whatever data is stored on there. There’s no guarantee. It still assumes that the mechanical components will work long enough to create an image. If the “read head” fails or you get the “click of death”, it’s pretty much game over at this point, unless you want to chalk up a lot of money for a professional recovery service. :frowning_face:

Have you used ddrescue before? The concept is that you plug in the device and then make a full image file of it. This image file can be saved on your main internal drive or another external drive, and will require 1TB free space. (This will be the size of the image file, no compression used.) Once that is complete, this image file (old_usb.img) will act like your old external drive, and whatever recoverable files or file corruption will exist in the same state as they did on your actual physical drive.

Trying to do a bunch of recovery processes on a dying drive can vastly increase your risks of causing further damage. It’s not a good situation to be in, I know. This also stresses why backups of important and nostalgic data should be part of your regular routine.

1 Like

Oh well. Nah, I don’t have another 1TB lying around anywhere. I’ll eventually get another external drive (trying to avoid expenses at the moment), but I guess I can wait for now. When I get it I’ll try ddrescue. I haven’t used it before but I guess I will be able to figure it out and, if I can’t, google and forums can help. Thanks for the advice!

How much total free space do you have, even on your current primary drive? You don’t need a separate dedicate device, as you can use your existing primary storage drive.

My primary device is under 300GB total out of which there are about 30GB free… That’s the reason why I was looking to use this drive in the first place

The quickest and safest way to use it is to run a single pass, no scraping, without retrying unreadable sectors:
sudo ddrescue -n -f /dev/sdb /home/ross/old_usb_drive.img /home/ross/old_usb_drive.log

(Change the paths and names that apply to your own setup. I used arbitrary names and paths for the sake of example.)

The above command will skip the multi-retries and skip scraping, simply going through the entire device (sdb) and imaging it to an image file named old_usb_drive.img, while keeping track of its progress (used for second-passes, etc) in the log file old_usb_drive.log. It is this image file (old_usb_drive.img) that you can try to mount, do an ntfs repair, recover files, etc, as if it was the physical drive itself.

ddrescue is a destructive and dangerous tool, so be sure to read, re-read, and re-re-read the command before continuing, as you can accidentally overwrite a good drive if you reverse the order of the arguments or type in an “a” instead of “b” for the device name. Be careful!

1 Like

Thank you so much! And thanks for the warning, I’ll make sure it is right!