Everything is jittery/slow

Just installed Manjaro, I’m not totally new to Linux but I’m not used to this happening and I could probably fix it myself except for some reason the OS isn’t allowing me to change most of my graphics settings, specifically the rendering backend is the biggest pain not to be able to change.
Any time there is any animation on screen, even something as simple as a mouse hover over animation, dips my framerate into the 20s. I AM pretty new to the Linux community so I’m not certain what information I need to provide in this post but I’m willing to provide any info needed to solve this issue.

First thing to mention is that baloo (indexing) will have to take some time early in a new KDE install.

Second … a good start is system info;

Hey! Thanks for letting me know.

  Kernel: 6.1.25-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=6a481ecd-2178-463a-a908-31ccc17454cd rw quiet splash
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Hewlett-Packard product: HP Z210 Workstation v: N/A
    serial: <superuser required> Chassis: type: 6 serial: <superuser required>
  Mobo: Hewlett-Packard model: 1587h serial: <superuser required>
    UEFI: Hewlett-Packard v: J51 v01.52 date: 02/13/2015
  Info: model: Intel Core i7-2600 bits: 64 type: MT MCP arch: Sandy Bridge
    gen: core 2 level: v2 built: 2010-12 process: Intel 32nm family: 6
    model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2067 high: 2754 min/max: 1600/3800 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2754 2: 1977 3: 1634
    4: 1610 5: 1803 6: 2611 7: 2256 8: 1896 bogomips: 54299
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GF114 [GeForce GTX 560 Ti] vendor: PNY driver: nouveau
    v: kernel alternate: nvidia_drm,nvidia non-free: series: 390.xx+
    status: legacy-active (EOL~late 2022) arch: Fermi code: GF1xx
    process: 40/28nm built: 2010-16 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    ports: active: DVI-I-2 empty: DVI-I-1,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:1200 class-ID: 0300 temp: 38.0 C
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: nouveau gpu: nouveau
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93") monitors: <missing: xrandr>
  Monitor-1: DVI-I-2 model: Dell P2212H serial: <filter> built: 2013
    res: 1920x1080 dpi: 102 gamma: 1.2 size: 531x299mm (20.91x11.77")
    diag: 551mm (21.7") ratio: 16:9 modes: max: 1920x1080 min: 720x400
  API: OpenGL v: 4.3 Mesa 23.0.2 renderer: NVCE direct-render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel bus-ID: 1-1.6:5 v: kernel
    chip-ID: a014:b014 bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0300
    class-ID: 0403 serial: <filter>
  Device-2: NVIDIA GF114 HDMI Audio vendor: PNY driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:0e0c class-ID: 0403
  Device-3: Insignia (Best Buy) Desktop Microphone NS-PAUM50 type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  API: ALSA v: k6.1.25-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-3: PulseAudio v: 16.1 status: active tools: pacat,pactl
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
    driver: e1000e v: kernel port: f040 bus-ID: 00:19.0 chip-ID: 8086:1502
    class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-1: ASUSTek ASUS USB-BT500 type: USB driver: btusb v: 0.8
    bus-ID: 2-1.6:3 chip-ID: 0b05:190e class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0 port: f020
    bus-ID: 00:1f.2 chip-ID: 8086:2822 rev: N/A class-ID: 0104
  Local Storage: total: 480.41 GiB used: 8.75 GiB (1.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WDBNCE5000PNC
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 00RL scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB model: General size: 14.65 GiB
    block-size: physical: 512 B logical: 512 B type: N/A serial: <filter>
    rev: 5.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 26.68 GiB size: 26.09 GiB (97.80%) used: 8.72 GiB (33.4%)
    fs: ext4 dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 513 MiB size: 509 MiB (99.22%)
    used: 30.8 MiB (6.1%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  Alert: No swap data was found.
  System Temperatures: cpu: 55.0 C mobo: N/A gpu: nouveau temp: 38.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 1710
  Processes: 258 Uptime: 37m wakeups: 0 Memory: 15.58 GiB
  used: 3.9 GiB (25.0%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1132 libs: 329 tools: pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.26

By the way I am aware of how little storage I gave this partition, it’s only temporary. I would have given it a bit more but windows being windows it only wanted to free up a little less than 30GB of my 150GB free space for a new partition.

A rather old model … You might have BIOS updates.

This doesnt provide iGPU ?

Of course its up to you … but the proprietary 390 does exist in the repos/mhwd.

Configure Graphics Cards - Manjaro

You also have no swap. Again up to you … but generally having some swap is a good idea.

This doesnt provide iGPU ?

Forgive me, what is that?

You also have no swap. Again up to you … but generally having some swap is a good idea.

Yeah I plan on giving it swap. Just wanting to ensure I can get Manjaro stable before committing to wiping the drive that windows is on.

And yeah don’t worry I am painfully aware that this PC is old. Would you happen to have any idea why most of my compositor settings seem to be missing or how I can stop the framerate from dipping so drastically? Or at all preferably? lol

And if it boils down to getting that driver you mentioned installed, could you walk me through installing it?

I only ask because when I tried, this was the output.

sudo mhwd -a pci nonfree 0300                                                                        ✔ 
[sudo] password for beau: 
> Skipping already installed config 'video-nvidia-390xx' for device: 0000:01:00.0 (0300:10de:1200) Display controller nVidia Corporation GF114 [GeForce GTX 560 Ti]

And then I’m pretty sure nothing changed. Forgive me I just really don’t know what I’m doing for the most part.

thats intel graphics, which is probably disabled in bios…

its probably the nouvea driver causing the issue, so you either install the proprietary one, or you can switch to the older kernels: 5.4/ 5.10/ 5.15, and test with them, nouveau works better with them…

post output from:
mhwd -l -li
since it looks it is already installed…

also disable baloo, go to system settings/ search/ file search and uncheck all options, click apply

I’d love to try installing the proprietary one but I simply don’t know how. I thought I had already done it but I suppose not?

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-390xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:01:00.0 (0300:10de:1200) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-390xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

Disabled baloo.

you already have it installed… the driver is not being loaded …
post output from:
ls /etc/modprobe.d
find /etc/X11/ -name "*.conf"
pacman -Qs 'nvidia|bbswitch|optimus'

local/egl-wayland 2:1.1.11-4
    EGLStream-based Wayland external platform
local/lib32-libvdpau 1.5-1
    Nvidia VDPAU library
local/lib32-nvidia-390xx-utils 390.157-4
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.5-1
    Nvidia VDPAU library
local/libxnvctrl-390xx 390.157-4
    NVIDIA NV-CONTROL X extension
local/linux419-nvidia-390xx 390.157-21 (linux419-extramodules)
    NVIDIA drivers for linux
local/linux61-nvidia-390xx 390.157-30 (linux61-extramodules)
    NVIDIA drivers for linux
local/mhwd-nvidia 530.41.03-4
    MHWD module-ids for nvidia 530.41.03
local/mhwd-nvidia-390xx 390.157-5
    MHWD module-ids for nvidia 390.157
local/mhwd-nvidia-470xx 470.182.03-1
    MHWD module-ids for nvidia 470.182.03
local/nvidia-390xx-settings 390.157-4
    Tool for configuring the NVIDIA graphics driver
local/nvidia-390xx-utils 390.157-5
    NVIDIA drivers utilities
local/xf86-video-nouveau 1.0.17-2 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards

looks ok…
so reinstall the drivers… first make sure you are up to date:
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
then remove them:
sudo mhwd -r pci video-linux
sudo mhwd -r pci video-nvidia-390xx
install them:
sudo mhwd -a pci nonfree 0300

if there were no errors, enable early loading:
kate /etc/mkinitcpio.conf
and edit the modules section to look like this:

MODULES=(nvidia nvidia_drm nvidia_uvm nvidia_modeset)

save it and update it:
sudo mkinitcpio -P
reboot… and hopefully you will not end up with a black screen … if you do, in the black screen enter into TTY: alt+ctrl+f2 or f1-f6 keys, enter your username and password, and remove them:
sudo mhwd -r pci video-nvidia-390xx
and install again the video linux:
sudo mhwd -i pci video-linux
systemctl reboot

Sorry for the late reply. I was trying to see if that fixed it, and it didn’t, then I got busy.

I did all the above and it didn’t work. Though the proprietary drivers are installed and are running now to the best of my knowledge.

post output from:
mhwd -li && inxi -G