Every slow boot after update

I don’t know what happened but my boot time went from 8 seconds to 1 min 30 seconds. help me please.
command output:

Startup finished in 2.816s (firmware) + 7.852s (loader) + 1.525s (kernel) + 1min 30.595s (userspace) = 1min 42.789s
graphical.target reached after 1min 30.594s in userspace

systemd-analyze blame

2.902s optimus-manager.service
1.234s systemd-random-seed.service
514ms dev-sda5.device
495ms var-lib-snapd-snap-core-10577.mount
487ms var-lib-snapd-snap-gnome\x2d3\x2d28\x2d1804-145.mount
458ms var-lib-snapd-snap-snapd-10238.mount
424ms var-lib-snapd-snap-core18-1932.mount
417ms systemd-logind.service
411ms var-lib-snapd-snap-snapd-10492.mount
409ms var-lib-snapd-snap-spotify-43.mount
388ms var-lib-snapd-snap-core18-1944.mount
385ms var-lib-snapd-snap-gtk\x2dcommon\x2dthemes-1514.mount
385ms var-lib-snapd-snap-discord-119.mount
382ms dev-loop9.device
379ms var-lib-snapd-snap-skype-161.mount
367ms upower.service
359ms dev-loop1.device
354ms dev-loop2.device
345ms dev-loop8.device
333ms dev-loop0.device
325ms snapd.service
313ms dev-loop5.device
312ms dev-loop4.device
311ms dev-loop6.device
310ms dev-loop3.device
301ms systemd-udevd.service
283ms dev-loop7.device
282ms systemd-timesyncd.service
258ms systemd-machined.service
256ms systemd-journald.service
250ms boot-efi.mount
240ms systemd-journal-flush.service
227ms apparmor.service
185ms polkit.service
116ms NetworkManager.service
113ms user@1000.service
96ms ufw.service
91ms udisks2.service
78ms systemd-fsck@dev-disk-by\x2duuid-2AAC\x2d6C48.service
77ms systemd-modules-load.service
70ms systemd-udev-trigger.service
66ms ModemManager.service
45ms bluetooth.service
41ms snapd.apparmor.service
30ms systemd-tmpfiles-setup-dev.service
26ms systemd-rfkill.service
25ms dev-disk-by\x2duuid-3fa4a140\x2d8c01\x2d4f80\x2d9834\x2d0b8ac1d69e6a.swap
21ms wpa_supplicant.service
21ms gdm.service
20ms colord.service
19ms systemd-tmpfiles-clean.service
18ms systemd-tmpfiles-setup.service
12ms accounts-daemon.service
10ms systemd-binfmt.service
10ms systemd-backlight@backlight:intel_backlight.service
10ms dev-hugepages.mount
9ms linux-module-cleanup.service
9ms dev-mqueue.mount
9ms sys-kernel-debug.mount
8ms systemd-update-utmp.service
8ms iptables.service
8ms sys-kernel-tracing.mount
8ms systemd-remount-fs.service
8ms user-runtime-dir@1000.service
7ms kmod-static-nodes.service
6ms modprobe@drm.service
6ms systemd-sysctl.service
4ms sys-fs-fuse-connections.mount
3ms rtkit-daemon.service
3ms systemd-user-sessions.service
2ms sys-kernel-config.mount
2ms tmp.mount
1ms proc-sys-fs-binfmt_misc.mount
892us snapd.socket

systemd-analyze critical-chain

The time when unit became active or started is printed after the “@” character.
The time the unit took to start is printed after the “+” character.

graphical.target @1min 30.594s
└─gdm.service @1min 30.573s +21ms
└─systemd-user-sessions.service @1min 30.568s +3ms
└─network.target @1min 30.565s
└─NetworkManager.service @1.679s +116ms
└─network-pre.target @1.678s
└─iptables.service @1.669s +8ms
└─basic.target @1.665s
└─sockets.target @1.665s
└─snapd.socket @1.664s +892us
└─sysinit.target @1.662s
└─systemd-backlight@backlight:intel_backlight.service @1.750s +10ms
└─system-systemd\x2dbacklight.slice @1.748s
└─system.slice @474ms
└─-.slice @474ms

Hello @dev-the-code-reaper :wink:

Seems GDM (Gnome Desktop Manager) slows it down.

Whats says?

systemctl status gdm.service --no-pager


journalctl -b1 -u gdm.service --no-pager

@dev-the-code-reaper, have you tried this fix already?

sudo systemctl status gdm.service --no-pager

[sudo] password for kahtras:
● gdm.service - GNOME Display Manager
Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: disabled)
Active: active (running) since Sat 2021-01-02 10:00:31 IST; 4min 22s ago
Process: 819 ExecStartPre=/usr/lib/gdm-wait-for-drm (code=exited, status=0/SUCCESS)
Main PID: 820 (gdm)
Tasks: 3 (limit: 18957)
Memory: 8.0M
CGroup: /system.slice/gdm.service
└─820 /usr/bin/gdm

Jan 02 10:00:31 HP-Omen systemd[1]: Starting GNOME Display Manager…
Jan 02 10:00:31 HP-Omen systemd[1]: Started GNOME Display Manager.
Jan 02 10:03:09 HP-Omen gdm-password][1272]: gkr-pam: unable to locate daemo…ile
Jan 02 10:03:09 HP-Omen gdm-password][1272]: gkr-pam: stashed password to tr…ion
Jan 02 10:03:09 HP-Omen gdm-password][1272]: pam_systemd_home(gdm-password:a…nd.
Jan 02 10:03:09 HP-Omen gdm-password][1272]: pam_unix(gdm-password:session):…=0)
Jan 02 10:03:09 HP-Omen gdm-password][1272]: pam_env(gdm-password:session): …led
Jan 02 10:03:09 HP-Omen gdm-password][1272]: gkr-pam: gnome-keyring-daemon s…ing
Jan 02 10:03:14 HP-Omen gdm[820]: Gdm: Child process -951 was already dead.
Hint: Some lines were ellipsized, use -l to show in full.

journalctl -b1 -u gdm.service --no-pager

– Logs begin at Thu 2020-12-24 16:50:42 IST, end at Sat 2021-01-02 10:06:34 IST. –
Dec 25 01:30:15 HP-Omen gdm[854]: Gdm: Tried to look up non-existent conversation gdm-launch-environment
Dec 25 01:30:15 HP-Omen gdm[854]: Gdm: Freeing conversation ‘gdm-launch-environment’ with active job
Dec 25 01:30:15 HP-Omen systemd[1]: Stopping GNOME Display Manager…
Dec 25 01:30:15 HP-Omen systemd[1]: gdm.service: Succeeded.
Dec 25 01:30:15 HP-Omen systemd[1]: Stopped GNOME Display Manager.

wait let me try it