Eve Pixelbook: Switching Pipewire to PulseAudio works on Vanilla Arch & Endeavour but not on Manjaro?

I have a weird issue with Manjaro that may take a bit of explaining, so bear with me.

I’m running (or want to run), Manjaro with Gnome on my EVE Pixelbook (Google Pixelbook)

I currently have Fedora 39 on this using some hacks and tweaks from GitHub - jmontleon/pixelbook-fedora: How to install Fedora on a Pixelbook with reasonable results and GitHub - lyncolnmd/PixelbookLinux.

Most notably, it requires switching from PipeWire to PulseAudio.

So I tested this on vanilla archlinux installing with pulseaudio from scratch, and once I copied the firmware files, it worked.

Next I tried Endeavour OS, and switched from pipewire to pulse using

sudo pacman -S pulseaudio pulseaudio-alsa pulseaudio-bluetooth pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf

Then copied the firmware files and it all worked.

I tried Manjaro doing the same thing, but also adding

sudo pacman -S manjaro-pulse

As that should switchover corresponding files.

And here’s the crunch. These steps (installing manjaro-pulse and all the other pulse packages) USED TO WORK on Manjaro (I’m talking maybe several weeks to a few months back), but now when I try to do this again on a fresh, clean Manjaro installation, doing the same steps as on a vanilla arch or Endeavour OS installation, (with the addition of installing manjaro-pulse), it doesn’t take – by which I mean audio doesn’t work (Gnome’s audio settings don’t see the device)

I’m reimaged back to Fedora for now, so I can write this message.

Does anyone have any thoughts on what might be going on here? I suspect something else might need to be installed/uninstalled, but it seems Manjaro-specific.

That is not necessary as

would provide same result.

Manjaro does not have anything which makes it stand out compared to Arch Linux or EndeavourOS so if you have a working install why would you need Manjaro?

If you because of the theming - that can be downloaded and installed on any other Arch based system.

Problem with manjaro-pulse was first reported August 2022
But packages can be installed individually without metapackage

For pacman:

sudo pacman -S pulseaudio pulseaudio-alsa

Package manager will request install of the optional dependencies: pulseaudio-bluetooth pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf

Because I like the feel of Manjaro. Yes, Endeavour works, and yes, I could indeed use that, but I like to understand why things don’t work.

Also, I like the zsh integration (Endeavour defaults to Bash)

So do I :slight_smile:

But I also know that the meta-packages are convenience.

One should really look at the actual dependencies to get the correct picture.

If you do that - you will find that you may have already installed a package providing a given functionality which is identical and thus manual intervention is required to get the expected result.

e.g. package foo1 provides foo bar-y and package foo2 provides foo bar-x

you have the package foo1 installed providing foo and bar-y.

if you have another package foobar requiring foo that packages will not install foo2 as that dependency is already satisfied by the foo1 package.

if on the other hand you expect bar-x to be available you will be disappointed

you will have to specify foo2 as part of your installatio of foobar if you want to make sure your expectation is met

Yes you could - but that is simply a choice between package managers and not the result on your package layout

I assume I could also do

sudo pacman -R manjaro-pipewire


Just a bit of an update.

I tried this again, using the steps (but without doing pacman -S manjaro-pulse as you mentioned that doesn’t do anything different to the other pacman commands.)

I still have the same problem with no sound, but I did realise I didn’t mention an additional symptom in my original post.

After copying the firmware and installing the pulse packages, Manjaro gets stuck on shutdown with the message “A stop job is running for Save/Restore Sound Card State (Xmin Xs / Ymin Ys)”, with the time limit increasing each time it gets exceeded (4min → 6 min e.g.)

Possibly something is conflicting under the hood that is blocking?