Ethernet not working on fresh Manjaro install

Hi guys, I had this issue for quite some time now. If I restart pc, sometimes even by itself, the network would simply stop working. Now I reinstalled Manjaro, but the problem still persists. Sometimes its enough to restart NetworkManager service, but sometimes I have to boot into windows and then back to manjaro to get it to work. Here is my system info:

    System:    Kernel: 5.9.1-1-MANJARO x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 root=UUID=7d35020e-4b06-4944-a2b8-f5a879360b76 rw quiet apparmor=1 
           security=apparmor resume=UUID=52fe86da-52a7-42df-99ff-7c1a797da17e udev.log_priority=3 
           Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Gigabyte product: B450M DS3H v: N/A serial: <filter> 
           Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <filter> UEFI: American Megatrends v: F51 date: 07/29/2020 
CPU:       Topology: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 1 stepping: 1 
           microcode: 8001138 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 95847 
           Speed: 2015 MHz min/max: 1550/3000 MHz boost: enabled Core speeds (MHz): 1: 2015 2: 1336 3: 1682 4: 1351 5: 1666 
           6: 1970 7: 1445 8: 1404 9: 1879 10: 1457 11: 1725 12: 1853 13: 1476 14: 1385 15: 2047 16: 1363 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: driver: nouveau v: kernel bus ID: 07:00.0 
           chip ID: 10de:1b06 
           Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nouveau unloaded: modesetting 
           alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.9x11.2") s-diag: 1052mm (41.4") 
           Monitor-1: DP-2 res: 1920x1080 hz: 60 dpi: 102 size: 476x267mm (18.7x10.5") diag: 546mm (21.5") 
           Monitor-2: HDMI-1 res: 1920x1080 hz: 60 dpi: 102 size: 476x267mm (18.7x10.5") diag: 546mm (21.5") 
           OpenGL: renderer: NV132 v: 4.3 Mesa 20.1.8 direct render: Yes 
Audio:     Device-1: NVIDIA GP102 HDMI Audio vendor: driver: snd_hda_intel v: kernel bus ID: 07:00.1 
           chip ID: 10de:10ef 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 09:00.3 chip ID: 1022:1457 
           Sound Server: ALSA v: k5.9.1-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel 
           port: f000 bus ID: 05:00.0 chip ID: 10ec:8168 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u bus ID: 1-4:5 chip ID: 148f:7601 
           serial: <filter> 
           IF: wlp2s0f0u4 state: up mac: <filter> 
Drives:    Local Storage: total: 2.88 TiB used: 25.05 GiB (0.9%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 250GB size: 232.89 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 1B2QEXE7 scheme: GPT 
           ID-2: /dev/sda vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC47 scheme: MBR 
           ID-3: /dev/sdb vendor: Kingston model: SKC600512G size: 476.94 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 0104 scheme: GPT 
           ID-4: /dev/sdc vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC43 scheme: GPT 
           ID-5: /dev/sdd vendor: Kingston model: SUV500240G size: 223.57 GiB block size: physical: 4096 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 56RI scheme: GPT 
           ID-6: /dev/sde type: USB vendor: Western Digital model: WD1600BEVS-60RST0 size: 149.05 GiB block size: 
           physical: 512 B logical: 512 B serial: <filter> scheme: MBR 
Partition: ID-1: / raw size: 223.79 GiB size: 219.28 GiB (97.98%) used: 13.08 GiB (6.0%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A gpu: nouveau temp: 47 C 
           Fan Speeds (RPM): N/A gpu: nouveau fan: 0 
Info:      Processes: 334 Uptime: 31m Memory: 31.37 GiB used: 1.87 GiB (6.0%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           Packages: pacman: 1216 lib: 345 flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.0.18 running in: yakuake 
           inxi: 3.1.05

i get this error:

IP configuration was unavailable

Can you please post

cat /etc/NetworkManager/NetworkManager.conf

Cross-linking to his related issue: Various issues with Manjaro KDE

currently, this is what I have in NetworkManager:

Configuration file for NetworkManager.
See “man 5 NetworkManager.conf” for details.

Add the following lines to this file:


and make sure dhclient is installed. Afterwards reboot.

I did it now, I also tried that before, still nothing, weird thing is, when the network is working, that file has all the necessary settings

Then have a look into your connections.


cd /etc/NetworkManager/system-connections
ls -la

and post it.

There you go

total 16
drwx------ 2 root root 4096 Oct 23 17:58 .
drwxr-xr-x 7 root root 4096 Oct 23 19:00 …
-rw------- 1 root root 352 Oct 23 17:58 Cajmir.nmconnection
-rw------- 1 root root 288 Oct 23 17:14 ‘Wired connection 1.nmconnection’

These files contain your private network profiles. Not something you want to share here(!) I would recommend you to open an editor and study the content. It could be an option to make a backup of one or the other of these files (or both), then delete the original file and try to reboot. if it’s not helping restore from backup file(s).

P.S. Don’t forget to leave root environment sometime by exit, as you are currently having root permissions.

I tried this multiple times, deleted and created new, all over again, still nothing

So you have 2 interfaces up with addresses from the same network?

Well that is possible, but far from ideal and can cause (strange) issues.

I would set them together as a bridge interface.
That is if you want both interfaces active in a way. Else just turn down the wlan-interface. .

A guide to setup a bridge can be found here