Various issues with Manjaro KDE

I have been using the same installation for almost two years now, and it’s starting to show its battle scars (read self-inflicted wounds). Now my first instinct as a long time Windows user was, I’ll just reinstall this, then I remembered, we don’t do that here, so after a lot of hours spent googling, these are some issues I did not find a resolution to:

  1. Octopi won’t start: I tried installing deepin desktop alongside kde, things got broken, tried removing deepin with octopi, did not close it properly, now its stuck. My suspicion is that it is trying to load deepin files that I selected, but can’t find those. I tried reinstalling it, I tried installing git version. Still the same issue. Is there some way to clear cache maybe, what do you reckon? Here is the version of octopi i currently use:

Name : octopi-git
Version : 0.10.0.r9.fd787a7-1
Description : This is Octopi, a powerful Pacman frontend using Qt libs
Architecture : x86_64
URL : GitHub - aarnt/octopi: A powerful Pacman (Package Manager) front end using Qt libs
Licenses : GPL2
Groups : None
Provides : octopi octopi-cachecleaner octopi-helper octopi-notifier octopi-repoeditor octopi-sudo
Depends On : alpm_octopi_utils pkgfile qtermwidget sudo
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : octopi octopi-cachecleaner octopi-helper octopi-notifier octopi-repoeditor octopi-sudo octopi-dev octopi-kde-git octopi-notifier-frameworks octopi-notifier-qt5 octopi-notifier-noknotify
Replaces : None
Installed Size : 7.58 MiB
Packager : Unknown Packager
Build Date : Sun 18 Oct 2020 14:53:12 CEST
Install Date : Sun 18 Oct 2020 14:54:23 CEST
Install Reason : Explicitly installed
Install Script : Yes
Validated By : None

  1. Internet breaks for no apparent reason: As I said, ethernet would lose connection, I get a yellow triangle, it tries to reconnect i get no IP error, I check IP command in terminal I don’t have ipv4 at all, I run command:

sudo systemctl restart NetworkManager.service

and the network comes back again. Now I tried everything, I change the router, I changed kernels, I changed ports, I changed cable, I even changed religion, nothing works. Sometimes event restarting service won’t help, so I have to change ports, when that doesn’t work, I have to boot into Windows and back, and it starts working.

Now, I hope you can at least point me in the right direction, also I would be really grateful if someone could send me a couple of commands which are best used for system diagnostics in general, cause I noticed some hickups here and there. And finally, here is system info:

    System:    Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
               parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=35d578d0-077a-4e75-b639-4f8a20b90748 rw quiet 
               resume=UUID=d8259a72-d9c4-4a8b-9dc4-625dd58a744a 
               Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
    Machine:   Type: Desktop System: Gigabyte product: B450M DS3H v: N/A serial: <filter> 
               Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <filter> UEFI: American Megatrends v: F51 date: 07/29/2020 
    CPU:       Topology: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 1 stepping: 1 
               microcode: 8001138 L2 cache: 4096 KiB 
               flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 95846 
               Speed: 3154 MHz min/max: 1550/3000 MHz boost: enabled Core speeds (MHz): 1: 3154 2: 3113 3: 2982 4: 3522 5: 2763 
               6: 2927 7: 2728 8: 2905 9: 3063 10: 3179 11: 3224 12: 2770 13: 2655 14: 2795 15: 2774 16: 2729 
               Vulnerabilities: Type: itlb_multihit status: Not affected 
               Type: l1tf status: Not affected 
               Type: mds status: Not affected 
               Type: meltdown status: Not affected 
               Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
               Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
               Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
               Type: srbds status: Not affected 
               Type: tsx_async_abort status: Not affected 
    Graphics:  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] vendor: eVga.com. driver: nvidia v: 430.64 
               alternate: nouveau,nvidia_drm bus ID: 07:00.0 chip ID: 10de:1b06 
               Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia display ID: :0 screens: 1 
               Screen-1: 0 s-res: 3840x1080 s-dpi: 80 s-size: 1219x343mm (48.0x13.5") s-diag: 1266mm (49.9") 
               Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102 size: 476x267mm (18.7x10.5") diag: 546mm (21.5") 
               Monitor-2: DP-2 res: 1920x1080 hz: 60 dpi: 102 size: 476x267mm (18.7x10.5") diag: 546mm (21.5") 
               OpenGL: renderer: GeForce GTX 1080 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 430.64 direct render: Yes 
    Audio:     Device-1: NVIDIA GP102 HDMI Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 07:00.1 
               chip ID: 10de:10ef 
               Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
               bus ID: 09:00.3 chip ID: 1022:1457 
               Sound Server: ALSA v: k5.8.11-1-MANJARO 
    Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel 
               modules: r8168 port: f000 bus ID: 05:00.0 chip ID: 10ec:8168 
               IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
               IF-ID-1: br-c8cdd0cb62ff state: down mac: <filter> 
               IF-ID-2: docker0 state: down mac: <filter> 
    Drives:    Local Storage: total: 2.73 TiB used: 1.28 TiB (47.0%) 
               SMART Message: Unable to run smartctl. Root privileges required. 
               ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 250GB size: 232.89 GiB block size: physical: 512 B 
               logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: 1B2QEXE7 scheme: GPT 
               ID-2: /dev/sda vendor: Seagate model: ST1000DM003-1CH162 size: 931.51 GiB block size: physical: 4096 B 
               logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC47 scheme: MBR 
               ID-3: /dev/sdb vendor: Kingston model: SKC600512G size: 476.94 GiB block size: physical: 4096 B logical: 512 B 
               speed: 6.0 Gb/s serial: <filter> rev: 0104 scheme: GPT 
               ID-4: /dev/sdc vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB block size: physical: 4096 B 
               logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC43 scheme: GPT 
               ID-5: /dev/sdd vendor: Kingston model: SUV500240G size: 223.57 GiB block size: physical: 4096 B logical: 512 B 
               speed: 6.0 Gb/s serial: <filter> rev: 56RI scheme: GPT 
    Partition: ID-1: / raw size: 227.52 GiB size: 201.80 GiB (88.70%) used: 96.81 GiB (48.0%) fs: ext4 dev: /dev/nvme0n1p2 
    Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
               ID-1: swap-1 type: partition size: 5.07 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 
    Sensors:   System Temperatures: cpu: 50.9 C mobo: N/A gpu: nvidia temp: 52 C 
               Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
    Info:      Processes: 481 Uptime: 4h 00m Memory: 31.37 GiB used: 10.22 GiB (32.6%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
               Packages: pacman: 1632 lib: 411 flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.0.18 running in: terminator 
               inxi: 3.1.05

First of all I am not an expert user.
However with regard to the Octopi issue I suspect that installing both Deepin and KDE will have exacerbated the difficulties of sorting this out.

You may be better using the command line interface / terminal.

See Manjaro Wiki Pacman Overview - Manjaro

Since you have separate issue usually best to post as different threads.

Sorry I don’t have the technical knowledge to give you a specific solution.

1 Like

Oh no worries, i am using pacman, its just octopi notifications are useful, thanks anyway :slight_smile:

What terminal says if you run octopi from it?
And why you are using git version of Octopi btw?

Hi, I would suggest that you save your important files, your browser’s bookmarks and anything else you value to a DVD or the Cloud or to a USB stick. Then download the current version of Manjaro, install it and have fun.

Your machine was very out of date to start with. If you want to run KDE and Deepin, install them separately, then they will not be bumping into each other. There is a very old computer term (Cascade of errors). What this means is to focus on the first error message. Fix it, retry and then deal with the next error if there are any. Please keep your computer up to date, that is very important.

Also, visit this forum at least a couple of times a week, read the threads. That way you will learn how others deal with such problems. At the first error, present it here and you will get help and you will increase your knowledge.

Good luck and save the important things and then do an install of the latest of Manjaro.

gary

1 Like

NIC is using the driver r8169
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169

Gigabyte motherboards require the correct driver r8168 to work properly

suggest you change to r8168 driver with Manjaro Settings Manager

manjaro-settings-manager -m msm_mhwd

enable option in bottom left corner - Show All Devices

Look in section Network controller > RTL8111/8168/8411 for network-r8168

Right click on network-r8168 and select Install

image

Manjaro Settings Manager will install the driver for all installed kernel versions and create a blacklist command to prevent driver r8169 from loading

1 Like

Another reason could be due to conflict of NetworkManager and systemd-networkd, if his ethernet connection is managed by systemd-networkd he should make sure NetworkManager is not touching it…
eg:

> cat /etc/NetworkManager/conf.d/10-globally-managed-devices.conf
[keyfile]
# Set devices that should be ignored by NetworkManager.
# unmanaged-devices=type:ethernet
unmanaged-devices=*,except:type:wifi,except:type:gsm,except:type:cdma
> cat /etc/NetworkManager/conf.d/11-Skip-Ethernet.conf
[main]
# Specify devices for which NetworkManager shouldn't create default wired connection.
no-auto-default=type:ethernet

I do not understand what this means or why you appear to be misquoting me

It seems a bit hasty to suggest a solution for a problem that may not exist

I would suggest OP first check if there is any problem with NetworkManager.service

systemctl -l --no-pager status NetworkManager.service

if there were a conflict with systemd-networkd it would show in error messages

@nikgnomic
I quoted your quote, and replied with another reason why his problem could have occurred besides what you mentioned.
Thus my reply was related to yours but not directly to what you said…
The problem i have mentioned only shows itself with lost connection when the two are controlling the ethernet at same time, there is no log message saying they are in conflict or exit with error code…

So in short it was just some info for you to keep around in your head, and for him to check also…
(Just trying to be helpful with another pair of eyes)