ERROR with Chrome 100.0.4896.60-1 and Ferdi 5.8.1-1 updates :S

It appeared the update in the programs app, but finished with error, here i share the image of the error in the update app…and also the final part of the log:

9551 verbose type range
9552 verbose stack minimist: No matching version found for minimist@^1.2.6.
9552 verbose stack at module.exports (/usr/lib/node_modules/npm/node_modules/npm-pick-manifest/lib/index.js:209:23)
9552 verbose stack at /usr/lib/node_modules/npm/node_modules/pacote/lib/registry.js:126:26
9552 verbose stack at async Arborist.[nodeFromEdge] (/usr/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/arborist/build-ideal-tree.js:1081:19)
9552 verbose stack at async Arborist.[buildDepStep] (/usr/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/arborist/build-ideal-tree.js:950:11)
9552 verbose stack at async Arborist.buildIdealTree (/usr/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/arborist/build-ideal-tree.js:216:7)
9552 verbose stack at async Promise.all (index 1)
9552 verbose stack at async Arborist.reify (/usr/lib/node_modules/npm/node_modules/@npmcli/arborist/lib/arborist/reify.js:153:5)
9552 verbose stack at async Install.exec (/usr/lib/node_modules/npm/lib/commands/install.js:156:5)
9552 verbose stack at async module.exports (/usr/lib/node_modules/npm/lib/cli.js:66:5)
9553 verbose cwd /var/tmp/pamac-build-solidcapo/ferdi/src/ferdi-5.8.1/build
9554 verbose Linux 5.10.105-1-MANJARO
9555 verbose argv “/usr/bin/node” “/usr/bin/npm” “install” “–production” “–prefer-offline”
9556 verbose node v16.13.2
9557 verbose npm v8.5.4
9558 error code ETARGET
9559 error notarget No matching version found for minimist@^1.2.6.
9560 error notarget In most cases you or one of your dependencies are requesting
9560 error notarget a package version that doesn’t exist.
9561 verbose exit 1
9562 timing npm Completed in 13231ms
9563 verbose unfinished npm timer reify 1648611245444
9564 verbose unfinished npm timer reify:loadTrees 1648611245450
9565 verbose code 1
9566 error A complete log of this run can be found in:
9566 error /home/solidcapo/.npm/_logs/2022-03-30T03_34_05_278Z-debug-0.log

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
1 Like

See comments on ferdi’s AUR page. Run npm cache clear --force and rebuild the package.

1 Like

Hi @SolidCapo,

Why not use the Ferdi .AppImage? I do, and it works wonderfully!\

1 Like

Awesome! it took a while, don’t know exactly what that did, but solved the problem! thankyou :smiley:

And thanks to @andreas85 and @Mirdarthos , but the solution of using the manjaron app updater it’s easier for me cause i’m a newbie and not a programer, what i saw is that all of you knew the problem was Ferdi, cause i updated first and only chrome and it worked fine, an with the solution of @ishaanbhimwal was solved, thanks again to all :smiley: i’m happy to be able to ask for help and get solutions this fast! :smiley:

I’m very happy you managed.

Just FYI, you don’t need to be a programmer to use the .AppImage. It’s very easy to “install”.

Oh ok…saw that i could download it, but just double click and does the rest? and updates also automatically?

Download it and mark it as executeable. Right-click on it, go to Properties, go to the Permissions tab, and select the :white_check_mark: Is executeable checkbox. Apply and/or OK Everything and then run it as usual.

Select to integrate it and everything should be automagic from then.

Or, well, that’s the theory I work with anyway.

1 Like

Awesome! thanks @Mirdarthos :smiley: i’ll try that option too, in fact, i’m recommending Ferdi to a lot of friends and not only with Linux :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.