Error relocating /usr/lib/ system stuck

I was just messing up for my unreal-engine build which almost success just few files where getting error. And sorry for now i am unable to copy then due to current error the are like /usr/bin/../lib64 error a very big error .To fix this error i downloaded libc6, libc6-dev, linux-libc-dev-amd64 and all ubuntu 18 based deb files which i tried to install with sudo dpkg -i libc6.deb libc6-dev.dpkg linux-libc-dev.deb and me stupid thought that this command caused crash on the terminal so i just ran exit without thinking anything . and now each and every command gave error even sudo .The error is

relocation error: /usr/lib/ symbol _dl_fatal_printf version GLIBC_PRIVATE not defined in file with link time refrence

even my fish shell promt which i stole from gradua linux sucks giving same error for whoami and sed

plz help me out i can currently access my open apps which are brave, xfce4-terminal , thunar.

plz help me out as fast as possible i am really worried as nothing even sudo doesn’t work

from here i found a script but how can i create it nothing i working

sudo dpkg -i libc6.deb libc6-dev.dpkg linux-libc-dev.deb
that command wouldn’t even have begun to work with a standard installation - since dpkg is a different package manager than Arch/Manjaro’s pacman/pamac

You can install it however - and apparently you did.
Then you used it to install vital system files (glibc) - thereby very likely overwriting/messing up vital parts of your system.

With that Debian glibc it is not even to be expected that your system will still work, much less after now having a mix of original and “new” files due to your “stunt” :wink:

You could try to (probably focrfefully) reinstall the original glibc - which is likely still in your pacman cache (/var/cache/pacman/pkg/).
… if pacman still allows you to do that …

You could also try “surgery” from outside - boot a live system and use that to replace the files inside the package named glibc-2.xx.pkg.tar.zst (from your pacman cache).

Or you could reinstall …


Not sure what you are up to, and why are you doing what you do, but messing with core package like glibc will lead to a broken system.


i have glib2 will it work pacman and pamac and sudo gives same error

no - that is a similar name, but that is not the package you … tinkered with

then what should i do . i found same error on red hat and that persons kernel panic after reboot

What I said? :wink:
In order - or just go straight to reinstall if you don’t know how to do that.

will replacing package work with chroot in live usb

It will either work right now - without chroot.
Or it won’t work - but then chroot isn’t going to help you either.
the system in chroot is just as broken as it is now …

1 Like

will replacing the file work , reboot don’t even work. I’m worried about my files

it probably will - but it is not just one file
it is the contents of the package glibc-2.xx… as I said above
all of it

copy the files where pacman would put them when it was doing the installation …

no worries - they are still there
but since the system does not boot now, they are only accessible via booting from live medium - like the installer USB you would use to chroot …
or almost any other Linux live system


Wtf is this in live usb cp is not working

1,460 files in glibc 2.33.5 (according to Pamac). There is a reason why the uninstall button is greyed-out in the package manager:

1 Like

I understand your frustration - but that just cannot be true.

Take a breath - and calm down.

My strategy would be:

  • boot the Manjaro live installer
  • access your drive - mount it somewhere
  • use the live system package manager to install “mc”
    (sudo pacman -S mc)
  • use mc to navigate to /var/cache/pacman/pkg/ on your broken system
  • find glibc-2.xx ...
  • open the archive, just by tapping enter on it
  • on the other side/pane, go to the root directory of your system - it is below where you mounted it to
  • mark every one of the three directories you see when you opened the archive - and copy it to the other side
    do this as root (start mc as: sudo mc)
    … you should be done :wink:

@scotty65 and that is how easy it is to restore all those thousands of files in one swoop :wink:
The system is already broken - it does not hurt to at least try.


But how I copy I don’t have glibc pkg I install it on live usb but cp is not working even rsync

Unless you specifically took the action of cleaning out your pacman cache - which I don’t think you did - the last few versions of every package are still in the pacman cache

and, as I said:
cp not working on the live usb is simply not true
can’t be!

Are you on your live system now?
what system are you on now?
Is the disk with the broken system connected to it?

1 Like

Bash: /usr/bin/cp: Input/Output error and I am using arcolinux usb cause that’s the only one right now

but that is not the live system -. it is your broken one (?)

1 Like

Arcolinux live usb how I change my folder permission . I forgot as I am use to fish auto fill