Error no such cryptodisk found

Yo i am brand new to Linux i had installed Manjaro at the beginning of the year. today I turn on my laptop and it gave me this error with out letting me enter my password. Now im new so i panicked, i booted up Tails from a usb and entered the disk manager and found the Manajor partition on my hard-drive i deleted it thinking it would help me get passed this screen but it did not. what do i do now? please thanks currently using Kali to boot up and use Firefox.

I cant seem to upload an image its not allowing me, but the screen says
"error no such cryptodisk found, perhaps a needed disk or cryptodisk module is not loaded
error : disk cryptouuid/4abd5f3209744018b702411b6d0794a0’ not found.
Entering rescue mode…
grub rescue_

thats the message i get when i boot up my computer id normally be able to type my encypted password but i cant. I still have windows installed on my harddrive i want to be able to boot to it how can i do that. damn if some one here can help me please to fix this that be awesome thanks.

A couple of months is enough to find out about reading the Announcements in the forum. What exactly have you tried from this?

Have a look at the forum Search results for 'no such cryptodisk found ' - Manjaro Linux Forum

I have tried nothing because this just happened a week ago or two. im new to linux having all this code is helpful but i dont know what to do with it. where do i start? what the first step to gettiing my laptop back to work. i straight up just need help getting passed that message after a reboot it wont allow me to enter my password to continue so idk what to do. how do i go about checking /boot/grub.cfg ?

And you decided to use luks encryption? It is easy to install it that way with Manjaro, but look, you need to get familiar with that. Such major changes can occur from time to time, and you need to be tech-savvy enough to follow such instructions at least.

Might sound unhelpful, but it is time to understand the basic configurations of your systems. You would need to spend time and read documentations.

While Manjaro is a good entry point to Linux and an Arch-based Distro, it is not a handholding distro, which does everything for you.

Since you applied the update already, you would need to boot a Manjaro Live Session and chroot into the system. Then adjust the text file by manually editing it.

If you have specific questions, then ask, but don’t expect a full tutorial, which you can blindly type, and it magically works.


So live session you mean use a usb correct? How do i chroot into the system, and how do i get to ending the file manually? Seems like someone posted what must be done removing the dashes.

I appreciate the honesty man. I am new to linux i got my first laptop ever not to long ago and asked my self what can i do with a computer and found out about Tails and then found out about all these other linux distros. What do you recommend i learn in order to follow instructions for new updates? Like coding language?


chroot - ArchWiki

Or you can use the helper script manjaro-chroot:

# auto-detection
sudo manjaro-chroot -a

But since you have a luks encryption, you need to unlock it, mount it and then run it like this:

# <device> could be sda1 for example
sudo cryptsetup luksOpen /dev/<device> root
sudo mount /dev/mapper/root /mnt
sudo manjaro-chroot /mnt /usr/bin/bash

If you have more partitions, you would need to repeat step 1 and 2.

In the chroot session on the terminal, you open the file with an editor such like nano.

nano /boot/grub/grub.cfg

Read the links which were posted by @bogdancovaciu.

A coding language is not necessary. Just understand how to use the terminal and bash/zsh. When administering a Linux Distro, you will be able to avoid the terminal for some degree, but in most cases you get just terminal commands. It is the main and preferable way to administer the system easy and fast, because on any Distro it is 90% the same. If you use GUIs (Graphical Windows), you will soon see that the design is very different on every Desktop Environment and you have to search the options again.

The terminal on Linux is not like the CMD on Windows, which stuck at 1980 and was not improved since then. It is the most advanced tool for power users.

how do i go about mounting it? where do i get the option to enter my password. also you mentioned run it like this. so i have to mount if first before i can run it, how do i check what device or partition manjaro is installed in

lsblk -f
to find out the device name, which you’ll need to substitute in the example given:

Executing the first command will prompt you for the password.
(first for the admin/sudo password, as is usual when using sudo
then for the password to unlock the encrypted device)
The second command will then attach the unlocked device to /mnt
where it’s contents are available
the third command does the actual chroot process

There is the IT convention of <variable> to be replaced by someValue, but it can be a trap for newbies who don’t know this yet and type in the angle brackets, i.e. instructions to redirect data, which they likely also don’t know about yet.