Error Mounting NTFS drive in Dolphin [KDE]

Good morning everyone, I’m pretty new to Manjaro (but not totally on linux) and its board, so forgive if I’m in the wrong section :slight_smile:

At the startup, I got this error into dolphin and I can’t access to this network drive anymore (ntfs).

Error mounting /dev/sdb1 at /run/media/garyno/DATI: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error

The other drives, sdc (ext4 - Manjaro) and sda (ntfs - SSD) are accessible without any issues.

Thanks for any help =)

Hi @Garino, and welcome!

Considering it’s NTFS, and

…I don’t want to say you’re screwed…but…you’re possibly screwed.

If you dual-boot, you should make sure that Windows is shut down properly, not hibernated or something like that, and make sure in your BIOS/UEFI that fast startup and secure boot (if present) is disabled. Also boot into windows, and check the disk for any errors, and repair them.

If you’re not dual booting, well then why are you using NTFS?


And what @linux-aarhus said:

1 Like

Usually the message is caused by filesystem errors.

ntfs is a proprietary filesystem and repairs should be done within Windows.

So reboot into Windows and run a check on the filesystem.

If you do not have Windows installed - Hirens Boot CD provides a Windows PE/RE for various tasks.


That’s a good question. No, I dropped dual boots time ago. Was ntfs to keep “windows” compatiblity, I guess.
This is a linux machine. Only the drives (excluded the ext4) are linked to other windows PC with samba shares.

Should be off.

I’d exclude a drive failure. The other working drive has a valid mount point at /run/media/garyno/14E313C243C08047 whereas this one seems to had lost its mount point at /run/media/garyno/DATI.

Btw, I’ll see what is going on. Should have already Hiren on an usb pen :slight_smile:

Seems like you don’t need NTFS.

And besides, in my opinion the SAMBA is a much better and more reliable option than NTFS…

Should, but confirm…

The drive isn’t the partition, though…so it could still be a failure…

That is a temporary mount point that shouldn’t be used for permanent mounts anyway. The same with:

See here for more info:


If the drive in question happens to be an external USB drive, you might also consider the physical connection. Is the cable seated securely; has the onboard controller died?

If not external, you can disregard this. :wink:

1 Like

@ all Ok I’ve pretty much reclaimed all my manjaro drives, but feel I have to study a bit for correctly make static mount points (with the guide) so, following the “safest route”:

  • Booted Hiren PE with USB and the presumed faulty NTFS HDD drive (“Dati”) was there with its files and was checked for issues;
  • Moved all the files to the other SSD NTFS drive (“SSD”) and then formatted “Dati” (again as NTFS). Likely I borked it when I copied the files via network from windows;
  • Rebooted to Manjaro and unmonted+formatted “Dati” as ext4;
  • Moved back files from “SSD” to “Dati”;
  • Unmounted+formatted “SSD” as ext4";
  • Now I have three fixed drives with ext4 (sdc is Manjaro, sdb is Dati, sda is SSD)

I wrongly assumed that fixed drives were already in fstab with static mount points (probably the NTFS are supposed to be only temporary, for good reasons) and also that drives in ext4 were inaccessible as network shares (not true, ext4 is fine and I see everything).

p.s: I “might” also did some mistakes experimenting, as I locked up /run/media folder so don’t blame me too much for all of these, which I really feel are wrong (especially the third):

chmod 777 --recursive /run/media
chown Garyno:Garyno --recursive /run/media

and had to change this in smb.conf (should be like everyone, which is probably not good)

usershare owner only = no

I’m one of those who are extremely against chmod 777
If you are looking for a way for the files to be created with a specific user and mask, I have this samba config for you, take it or leave it. :slight_smile:

path = /path/to/share/
browsable = yes
writable = yes
read only = no
force user = YOUR_USERNAME
create mask = 0644
public = no
1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.