Error loading QML file

When opening manjaro system settings certain tabs (like Global Themes/Plasma Themes/Colors/Icon) display a “Error loading QML file” error.

I have had this issue for quite a while now and I am unable to get it fixed.

sudo pacman-mirros -f5 && sudo pacman -Syyu knewstuff

Please make sure you did not mixed with -git packages …

I ran the command and the issue still persists.
Not sure what you mean by not getting mixed with -git packages. I haven’t installed any -git packages on my system.

Please show:

pamac search -iq git | grep git

Here it is


Should I remove the -git packages?

You don’t need to do it.

When you last time restarted your computer? Maybe it will help.

I removed the -git packages and restarted (not using them anyway), but the issue still persists.

Ok, so try first or second solution from here (Plasma desktop behaves strangely or Clean cache to resolve upgrade problems):

After trying the first solution, the plasma workspace resets to its defaults but the issue still persists.

The second solution gives me the following output:

kbuildsycoca5 running… The desktop entry file “/usr/share/applications/Singular-manual.desktop” has Type= “Link” instead of “Application” or “Service”
kf.service.sycoca: Invalid Service : “/usr/share/applications/Singular-manual.desktop”
kf.service.sycoca: The menu spec file contains a Layout or DefaultLayout tag without the mandatory Merge tag inside. Please fix your file.

But the issue still exists.

I had a similar problem which I solved by installing Kirigami that somehow was missing.
See if that helps

The issue still persists after installing kirigami, unfortunately.

I finally fixed it. I had to redownload and reinstall all of plasma.
Basically I did sudo pacman -Scc
and then sudo pacman -S plasma dolphin konsole xdg-user-dirs packagekit-qt5 knewstuff

If I did the last command with doing sudo pacman -Scc then pacman would use the existing packages in the cache and it wouldn’t fix the issue.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.