System Settings crashes (after update)

Every time the kernel wants to update, something essential breaks…

systemsettings5 would crash after latest update. Right click on icon and launch Global Themes would launch into Global Themes but clicking around, various sections will crash - like Colors, Fonts …

I have noticed switching between kernels sometimes corrects things. So I installed higher and lower kernels and started testing between them.

The newer kernels didn’t change anything. So when I rebooted to linux54 (the lowest I had), memtest86+ started running.

Something removed ALL my kernels.

Pressing shift before it could enter memtest86 got me to the grub commandline.

Kernel images should be in /boot.
ls /boot

no kernel images.

Plug in majaro iso on usb to live boot.
Connect to wifi
F12 for command prompt
sudo manjaro-chroot -a
sudo pacman -Syyuu
mhwd-kernel -li
(shows linux54 is current - even though it was not in /boot folder??)
mhwd-kernel -i linux54
mhwd-kernel -i linux510
mhwd-kernel -i linux514

Ok, now boots but doesn’t get to login screen.
Hit Alt-F2 for commandline.
sudo nano /etc/sddm.conf.d/kde_settings.conf


(both empty)
should have:


… still wont boot.
can’t find an xorg.config file, so:

sudo nvidia-xconfig

(in logs: Failed to initialize the NVIDIA Kernel module)

nmcli c
nmcli -a c up wifi connection

sudo mhwd -a pci nonfree 0300

Can finally log back in again, System Settings still doesnt work

I’ve updated plasma:

yay plasma-desktop
yay plasma-workspace
yay plasma-framework

Also did this (which broke my theme completely and didnt fix System Settings):

sudo pacman -Scc
sudo pacman plasma dolphin konsole xdg-user-dirs packagekit-qt5 knewstuff

I don’t understand how to fix System Settings. When run from the commandline it just says:

[~]$ systemsettings5
WARNING: CPU random generator seem to be failing, disabling hardware random number generation
WARNING: RDRND generated: 0xffffffff 0xffffffff 0xffffffff 0xffffffff
QQmlEngine::setContextForObject(): Object already has a QQmlContext
29 – exe=/usr/bin/systemsettings5
13 – platform=xcb
11 – display=:0
24 – appname=systemsettings5
17 – apppath=/usr/bin
10 – signal=11
9 – pid=5443
18 – appversion=5.23.3
28 – programname=System Settings
31 –
12 – startupid=0
KCrash: crashing… crashRecursionCounter = 2
KCrash: Application Name = systemsettings5 path = /usr/bin pid = 5443
KCrash: Arguments: /usr/bin/systemsettings5
KCrash: Attempting to start /usr/lib/drkonqi
WARNING: CPU random generator seem to be failing, disabling hardware random number generation
WARNING: RDRND generated: 0xffffffff 0xffffffff 0xffffffff 0xffffffff
QSocketNotifier: Invalid socket 8 and type ‘Read’, disabling…
QSocketNotifier: Invalid socket 23 and type ‘Read’, disabling…

[1]+ Stopped systemsettings5

Sooo, that was my day…

This issue mentions re-install Kirigami.

Using Kirigami gallery I notice some controls crash the gallery:

Selection Controls
Text Field
Form Layout

That something had to be you. There is nothing in a normal system that will just do that automatically.

While these arent technically invalid commands … on manjaro we use mhwd-kernel for these things, which you showed with the listing above. example:

sudo mhwd-kernel -i linux510

Hm. I wonder what nvidia card you have and what driver you are using.
Nvidia dropped a lot of cards between 470 and 495 …

This along with some other quirks sounds a lot like a misconfigured/fragmented plasma.
(for example - old badly coded widget that breaks new plasma, etc)

So see this for a list of commands to clear those caches and configs:

Yeah, I admit I removed everything EXCEPT linux54 in the last reboot.
I really don’t believe I accidentally removed all of them…

Yeah. Typo. That is what I did.

TU116 [GeForce GTX 1660 Ti]

$ rm ~/.config/Trolltech.conf
$ kbuildsycoca5 --noincremental
$ rm -rf ~/.cache/*

Did all these things. Nothing has changed.

I thought I was onto something proving certain Kirigami controls crash the gallery, but I can’t find any more info and I’ve already re-installed it.

Btw, thanks for the response!