ERROR: device 'UUID=' not found. Skipping fsck

I’m getting ERROR: device 'UUID=' not found. Skipping fsck. when trying to boot onto bare metal from a USB drive installation of manjaro.

The drive is a persistent USB install created with alma-git from within a VM. It’s a bit of a long story but the tl;dr is that at the moment using a linux VM is the only way I’ve been able to create the USB installer.

I’m guessing the issue could be related to the VM using a different UUID for the volume: the UUID that the error refers to while attempting to boot to bare metal doesn’t match the actual UUID of the USB volume, according to the output of diskpart run on bare-metal windows 10. The usb-install boots properly when run from within a VM.

I’ve tried editing /etc/fstab to properly reflect the UUID of the USB volume that diskpart lists but I’m still seeing the error mentioning a different UUID when booting onto bare metal.

Bit of a mess, I know.
Any help greatly appreciated. Thanks in advance.

Hello @tibiapill :wink:

I cannot verify your problem, but it be could a workaround using a LABEL instead of the UUID.

  1. Add a label to the partition on the flash drive: Persistent block device naming - ArchWiki
  2. Edit fstab and replace the UUID=<long_number> with LABEL=Manjaro

:notebook: The label must be unique on the whole system.

1 Like

Isn´t it necessary

also to add the UUID / label to grub.cfg on the usb-stick ?

On my (with alma-git created) stick is grub (silent). And in the first partition is grub.cfg with some UUIDs

ls -lA                                                                                                                      
insgesamt 60
drwxr-xr-x 2 root root   512 16. Jun 15:06 fonts
-rwxr-xr-x 1 root root  6840 20. Nov 20:20 grub.cfg
-rwxr-xr-x 1 root root  5267 19. Jun 12:25 grub.cfg.old
-rwxr-xr-x 1 root root  1024 16. Jun 14:50 grubenv
drwxr-xr-x 2 root root 20480 16. Jun 15:06 i386-pc
drwxr-xr-x 2 root root  5632 16. Jun 15:06 locale
drwxr-xr-x 3 root root   512 16. Jun 15:06 themes
drwxr-xr-x 2 root root 19968 16. Jun 15:06 x86_64-efi
1 Like

You may compare your notes with:


Thanks for your suggestion!
I added the correct UUID to grub.cfg, however now the same error appears but with what seems to be the correct UUID :confused:

The first image is the output of diskutil list, and the second image is of the machine attempting to boot from the USB drive. The UUID looks correct to me?

I tried making a regular USB install (non-persistent).

It got as far as grub, but after making a selection I received:

ERROR: '/dev/disk/by-label/MANJARO_XFCE2116' device did not show up after 30 seconds...

I think using a volume label is also not working on this system :thinking:

ALMA is not a known-working image writer for manjaro.
(or ‘persistent-usb-creator’ or whatever you might call it)
Please use any other method from ventoy to dd to verify.

Please have a look at:

  • This is from phil m manjaro
  • I did try and succeeded 3 times


  • The UUID for the partition is wrong, or
  • Your Disk is not accessible from GRUB (reason unknown)

Be sure to start in UEFI-Mode

Hi, thanks for replying cscs.

I installed ventoy on the USB alongside the manjaro iso and booted it: I could get as far as grub but when I selected boot with open source / proprietary drivers the machine stuck on a black screen.

I also wrote the image to usb using DD and got to grub but again received the error about disk by-label not showing up after 30 seconds.

I have verified the SHA of the iso. I’m not sure how to verify with DD, if you could suggest a full command, or link to an explanation I would be happy to give it a shot. Unfortunately I was not able to find this information myself.