Error building python-pynput

I see those messages while trying to update python-pynput:

Erstelle python-pynput...
==> Erstelle Paket: python-pynput 1.7.2-1 (Mi 27 Jan 2021 14:32:56 CET)
==> Prüfe Laufzeit-Abhängigkeiten...
==> Prüfe Buildtime-Abhängigkeiten...
==> Empfange Quellen...
  -> pynput-1.7.2.tar.gz gefunden
  -> python-pynput.patch gefunden
==> Überprüfe source Dateien mit sha256sums...
    pynput-1.7.2.tar.gz ... Durchgelaufen
    python-pynput.patch ... Durchgelaufen
==> Entferne existierendes $srcdir/ Verzeichnis...
==> Entpacke Quellen...
  -> Entpacke pynput-1.7.2.tar.gz mit bsdtar
==> Beginne prepare()...
patching file
==> Entferne existierendes $pkgdir/ Verzeichnis...
==> Beginne build()...
WARNING: The wheel package is not available.
  ERROR: Command errored out with exit status 1:
   command: /usr/bin/python -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-wheel-caf5ll9x/setuptools-lint_77f800c207fb4f5ebbc7caea66d68faa/'"'"'; __file__='"'"'/tmp/pip-wheel-caf5ll9x/setuptools-lint_77f800c207fb4f5ebbc7caea66d68faa/'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);'"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' bdist_wheel -d /tmp/pip-wheel-afqzd4yd
       cwd: /tmp/pip-wheel-caf5ll9x/setuptools-lint_77f800c207fb4f5ebbc7caea66d68faa/
  Complete output (6 lines):
  usage: [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
     or: --help [cmd1 cmd2 ...]
     or: --help-commands
     or: cmd --help
  error: invalid command 'bdist_wheel'
  ERROR: Failed building wheel for setuptools-lint
ERROR: Failed to build one or more wheels
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/setuptools/", line 75, in fetch_build_egg
  File "/usr/lib/python3.9/", line 373, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['/usr/bin/python', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmphjxif1_p', '--quiet', 'setuptools-lint>=0.5']' returned non-zero exit status 1.

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/var/tmp/pamac-build-sepp/python-pynput/src/pynput-1.7.2/", line 85, in <module>
  File "/usr/lib/python3.9/site-packages/setuptools/", line 152, in setup
  File "/usr/lib/python3.9/site-packages/setuptools/", line 147, in _install_setup_requires
  File "/usr/lib/python3.9/site-packages/setuptools/", line 686, in fetch_build_eggs
    resolved_dists = pkg_resources.working_set.resolve(
  File "/usr/lib/python3.9/site-packages/pkg_resources/", line 766, in resolve
    dist = best[req.key] = env.best_match(
  File "/usr/lib/python3.9/site-packages/pkg_resources/", line 1051, in best_match
    return self.obtain(req, installer)
  File "/usr/lib/python3.9/site-packages/pkg_resources/", line 1063, in obtain
    return installer(requirement)
  File "/usr/lib/python3.9/site-packages/setuptools/", line 745, in fetch_build_egg
    return fetch_build_egg(self, req)
  File "/usr/lib/python3.9/site-packages/setuptools/", line 77, in fetch_build_egg
    raise DistutilsError(str(e)) from e
distutils.errors.DistutilsError: Command '['/usr/bin/python', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmphjxif1_p', '--quiet', 'setuptools-lint>=0.5']' returned non-zero exit status 1.
==> FEHLER: Ein Fehler geschah in build().
    Breche ab...

I’m a novice, but isn’t it strange that the package is located in AUR than a “normal” repo?!


Fixed it with

  1. removing python-pynput
  2. removing and rebuilding python-setuptools-lint
  3. rebuilding python-pynput

Welcome to the forum! :wave:

Please do not post about AUR packages in Announcement threads. While the AUR is not officially supported, users can post here in #support:aur for help.

When pasting terminal output, please use the Preformatted text </> button, not the Quote " button. I’ve fixed it for you this time. :wink:

1 Like

Related issue:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.