Epson Perfection V600 drivers

Hi, everyone.

My question appears trivial, but somehow I can’t seem to find a good answer. I am trying to make an Epson Perfection V600 scanner work with my Manjaro KDE PC, and have thus far found just one source of good information, posted at the archived Manjaro forum (URL Epson Scanner Perfection V600 driver - Drivers - Manjaro Linux Forum).

In that article, the poster indicated the only way to do this is by using “debtap” to generate an Arch Linux compatible installation package. So, you start by downloading the archived deb file from the Epson web file, named “iscan-gt-x820-bundle-2.30.4.x64.deb.tar.gz”.

From here, it would appear it is just a matter of extracting the deb file from this archived deb.tar.gz file, however, when I do this, I do not end up with a “deb” file, but instead, with a “deb” folder which contains all of the files contained within the deb file. As a result, if I run:

$ debtap iscan-gt-x820-bundle-2.30.4.x64.deb,

I get a “Error: You haven’t specified a valid deb package” message.

So, the question I have after this all too long preamble is, how do I go about extracting the deb file from this deb.tar.gz file? I would normally ask the gentleman who made the original posting, unfortunately, the original Manjaro forum has been archived and I have no means to contact him.

Thanks in advance for any and all help.

Herlock

Have you tried using the iscan-plugin-gt-x820 AUR package? There are atleast no comments indicating failure to install and use, so it might be worth a shot.

2 Likes

I have in fact attempted that, but it does not work. It appears that Epson has updated its drivers since that AUR entry, and consequently, when you attempt to install it, the installation routine fails, claiming the MD5/SH256 checksums do not match. I then downloaded the snapshot from AUR, manually updated the checksums contained within the PKGBUILD script to reflect the correct ones, and ran it locally, but still, I cannot get the scanner to work. I contacted the AUR maintainer and asked if he could correct the issue, but so far have not heard a word back. Interestingly, when I run $lsusb, I see the V600 listed, but none of the scanning software I have tried (VueScan professional, Image Scan! for Linux, etc.) can see the scanner.

Thanks

Hello, everyone.

If there’s someone out there who can provide me with information on how to make an Epson Perfection V600 work with Manjaro KDE, I would be immensely appreciative.

I have spent the better part of the last week searching high and low for an answer, and unsuccessfully attempting to implement the ones I have found, and this includes information found in the archived version of the Manjaro Forum and elsewhere. Using a spare SSD, I installed Linux Mint 20 and later Kubuntu, and the Epson drivers for this scanner installed without a hitch on both, after which the scanner was recognized and became fully operational.

However, thus far, zero luck with Manjaro. I made a previous post here (Extracting "deb" file from a deb.tar.gz) but got no response that would work.

Again, thanks in advance for any help.

Herlock

Then flag the AUR package out of date so the maintainer is aware.

I already flagged it and contacted the maintainer a week ago, with zero acknowledgments. In addition, I downloaded the latest Epson rpm package, calculated the checksums, and updated the pkgbuild posted in AUR, and ran the script locally. While it appeared to complete successfully, the various scanning applications I have run in Manjaro fail to recognize the V600 scanner. As I stated, I have tried almost everything under the sun, and so far far nothing works, whereas in other, Debian based distributions (Mint and Kubuntu) there are zero issues. This is extremely frustrating.