Enable wifi option disappeared from Networks

The checkbox to enable wifi and airplane mode from the network tab completely disappeared for me in kde. I upgraded kernel from 5.10 to 5.11 but that didn’t fix the issue.
The last time I used the wifi - I turned it off and then tried turning it on after about 10 seconds, which caused the UI to freeze for a few seconds and the wifi showed some error notification “Wireless Interface - The wifi network could not be found” (I think this was the error but I cant remember for certain). I was unable to enable the wifi so I rebooted. And then the options completely disappeared. The wifi not working and causing freeze for a few seconds did happen to me before once or twice but the options never disappeared.

inxi -Nazy            
Network:
Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel  
port: 5000 bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280  
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet  
vendor: Lenovo driver: r8168 v: 8.048.03-NAPI modules: r8169 port: 3000  
bus-ID: 07:00.0 chip-ID: 10ec:8168 class-ID: 0200
rfkill list
0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: ideapad_bluetooth: Bluetooth
        Soft blocked: yes
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no

Things I installed few mins before were kvantum-manager and some themes.

And no I dont dual boot windows or any other.

I also tried to timeshift to a previous backup(with default settings) but that didn’t solve anything.

Need help.

1 Like

I went through the forum but none of the solutions worked for me. I just went to the bios settings and disable and re enabled wireless. This did the job for me. I still have no idea what caused it tho.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.