Enable Mouse movement during Keyboard Usage

Hello y’all,
Today I was trying to play a game on my Laptop running Manjaro-Deepin.
Quickly I realized that the mouse movement stopped when i pressed a key on the keyboard.
Is there a way to disable this behaviour.

Thanks in advance

Hi! Welcome to the forum.

We need more info. You were playing in which platform? Steam? A native game? Wine? Does it happen with other applications or games? What game is it?

Some info about your system can also help: inxi -Fazy

1 Like

hi I have a similar problem and It is not good, but I found a thread. https ://forum.manjaro.org/t/no-disable-touchpad-while-typing-configuration-option/21277
Plz help me understand what it says. I will be grateful (BTW delete the space between https and : for using the link.

Mbb I dont think there are steam and wine issues, even if you type or play browser game or any for that matter the same think happens, Check my link for this

If you’re using KDE, you can configure it in System settings > Input devices > Mouse pad > Enable/disable.

If you’re not using KDE, you can set it up in /etc/X11/xorg.conf.d/
Create a file there, for example:

You can get more info on config options here.

If you’re talking about a hand mouse (not pad), then there is something else to look at.

Do you mean It will work on xfce, and What part of the comment do I have to copy? Show Light.

Can you give the full code to copy, It doesn’t show the whole code.

What do you mean? If you open the linked post, there’s a scroll bar on the code box.

EDIT: Anyway, you need to get the device’s name with xinput, for example, and then create a file similar to the one on the linked post. The option you’re looking for is

Option "DisableWhileTyping" "false"

yeah I did it in my own thread check it out it is solved with full solution

No, what you did is valid through a single session. Once you reboot you’ll need to do it again. The proper way is to write a config file. I also don’t advise you to keep xinput installed - it’s a security hole.

Yeah I have to do it again. But it is only a line of code that I have already memorised, so eh. Is there any way to download avast antivirus through linux. It isnt listed in the add/remove software and I cant find an aur package. Did try your way, but xfce hates me peeking and saving conf files and it is pretty messy. Better is to just fire up terminal and enter. Better this way.

xinput set-prop 13 310 0

Whatever! You’re free to do what you want, just don’t go off topic. Open a new topic if you need to.

ok bro, sorry to anger you. Thanks for the info anyways