How can I use touchpad and keyboard simentaniously. it doesnt work

I have shifted towards Manjaro. I regularly update it, with me using the xfce 20.3 version, the problem rises when I start to play games. Pressing any key on my keyboard disables the touchpad, which is a huge problem. Pressing a shift, caps or ctrl key dosnt affect it however. I read a thread but it is outdated, and i do not understand the steps. Please help

If anyone understands plz help me in this regard. Thank you.

1 Like

Hi @Murgi and welcome to the forum. I don’t use xfce but in KDE there is a setting under Input Device -> Touchpad : disable while typing

You should uncheck this box.

I guess xfce has the same settings but I’m not sure.

No, I don’t think there are settings for this, still confused.

did you try to launch xfce4-settings-manager from terminal ?
if not try to install it and check out ! you will find the settings “Mouse & Touchpad”

1 Like

Still not happening. This is just the terminal way for opening mouse and touchpad, Please if you know and use xfce than plz help. There is no way shown there in mouse and touchpad.

either open pamac [add/remove software] and install xfce4-settings-manager OR
from terminal you can install with sudo pacman -S xfce4-settings-manager
once installed you can see the settings option in the whisker menu of xfce.
go to Mouse & Touchpad options [in the hardware section] and configure how you wish to.

This info might help:

[SOLVED] Touchpad doesn't works when I hold a keyboard key / Newbie Corner / Arch Linux Forums (last post)

1 Like

The post does help, but there are many differences between manjaro and arch linux even though they are based off each other.

That will make it impossible to use this code unless we have some hardcore coder, soo?

I do find many sources for disabling this feature in linux, but FOR SOME REASON, Manjaro doesn’t have an official guide of this thing, and Xfce doesn’t have this feature, while KDE has. Why?

Um hey, a bit off topic here, but I did a bit of stupidity and accidentaly disabled mouse in the terminal.

sudo modprobe -r psmouse
This is supposedly to disable mouse in terminal. I thought it as disable mouse by typing, and did it. No I cant use the mouse and am typing this post on my other laptop. If you know the reverse code to enable the mouse in terminal, please share. HELP

so if the answer has solved your problem mark it as solution.

yes and most of the arch wiki, solutions and guides (with sane changes) will work with manjaro since manjaro is arch based.

Each DE has it’s own way to expose system settings and configurations. Some may choose not to expose certain settings. Probably XFCE made that choice to keep it simple.

It is usually unwise to run unknown commands, without understanding what they do. It is more unwise to do so with “sudo”.
modprobe can be used to remove and add modules to the kernel. Just try to use modprobe to add it again (without the -r) or just try to reboot. I dont think modprobe commands persist across boots.

1 Like

Thanks Heavens Audiachie for this. Ran to boot my other laptop and the cursor is back to normal! But I am not a coder guy, but I know quite a bit of C and C+. My interest is generally in computers, and coding is not my thing. If someone is kind enough to give me the code to copy paste into a config file or something like that, Most welcome. Again, An awesome communtiy backed by awesome members

1 Like

Guys please finish this, I have stumbled on a very interesting thread, check it out. It is also recent, and if anyone understands, let me know what the steps are.
Shed some light on what this means, thank you.

The info on that website is actually correct. Just tested with a laptop with Manjaro xfce. You do have to install xinput first. The name of the package is xorg-xinput . After that you can do the commands listed in that forum thread.

Installed the package, and tested it. Fully working. but what’s the next step? Which config file do I have to go to? Come on, I am new here.

Figured it out. First I feared for some config file. But all I have to do was to go to Terminal:

  1. Enter xinput
  2. Enter xinput list-props 13 (In my case id of mouse is 13 yours may be different)
  3. Look through the directories to Disable touch pad by typing. Check the boolean, if 1 so on and if 0 then off.
  4. Enter xinput set-prop 13 310 0 (In my case the function Id was 310, yours may differ, but make sure to enter 0 at last.)
  5. Done! But still do check by xinput list-props 13 and navigating to the disable touchpad while typing feature.
  6. Great Community! Love ya.
  7. Btw it took me a while to understand the archlinx thread, so I simplified it for xfce users. And what do I do now with the thread. I guess I wil keep it open :smile:
1 Like

I would also suggest you to include the archlinux link in your solution. So the next person who finds it and sees your marked solution, he gets more reference.


Ok, any more ideas are accepted! Thanks guys for this problem solving.

The source is here, by the awesome community! [SOLVED] Touchpad doesn't works when I hold a keyboard key / Newbie Corner / Arch Linux Forums