Dualboot not working, cannot access BIOS, Stuck in grub rescue

Hello! :wave:

I guess you have to reinstall grub: GRUB/Restore the GRUB Bootloader - Manjaro

That is weird… are you sure F2 opens the UEFI? There are sometimes other Keys for opening it…

Hey, thank you for your response!

I also think I have to repair/reinstall grub, but is it possible to do this from grub rescue?

In terms of BIOS, it really is the F2 Key for my device (Acer Predator Helios Laptop). It worked also during the installation of the dualboot. However spamming all keys just result in the same behavior:

It’s weird even if you screw up the boot loader it should not impact your BIOS, in my opinion you can screw BIOS only by a bad firmware update.

The BIOS worked correctly right before the installation. The tutorial tells you to switch to AHCI etc and I did this, so I can confirmed there were no problems. However I have read this issue can be related to not switching from CMS to UEFI or something like this but I do not know what this actually means?

I used the regular manjaro installer and manual partitioning as mentioned in the tutorial. I created a boot, swap, root and home partition

Here a screenshot from my grub rescue

Do I need to set the cmdpath differently since it directs to a unresolved filesystem?

UEFI is a replacement for BIOS and CMS is legacy BIOS within the UEFI. If you installed Grub with EFI then just turn off CMS in the UEFI.

So if you created a boot partition (i don’t mean the EFI boot partition), then you need to use the this partition and not the root partition like you use now. The boot partition is mounted on /boot of your root partition.

Unknown file system means most that it is a ntfs file system and therefore windows.

A common issue is also the “gpt” remove it and use it like this: (hd1,7)

I am really not well informed in this topic, i just Followed the mentioned tutorial. In terms of partitions it says:

In addition, I just set the root and swap flags respectively to the partitions, which is not mentioned in the tutorial, but I do not think this may be a problem? I thought this may be cleaner.

After following the tutorial not manjaro booted but windows. The tutorial also had an answer for this which was to do the following in windows:

I did so and then the problem appeared.

Regarding the boot thing you mentioned would this then be the correct way?

And can i do the uefi thing from the grub rescue? I do not know if I did this or not, I did not read about it explicitly in the tutorial.

As an extra information, I can only access two partitions which are stated to be ext2 not ext4, I do not know if this is redundant. In addition i do not find the fat32 formatted partition, may there have been a mistake from me during the setup? Or is grub reacue also not able to read this format and therefore it is referred to as unknown filesystem?

I guess Windows messed it up then… You need to reinstall grub: GRUB/Restore the GRUB Bootloader - Manjaro

If only Windows is booting, i would check the boot order in the UEFI and set Manjaro first. That is how i did it.

Nothing boots at all that is my Problem. Neither windows nor manjaro and I cannot access BIOS. The only thing which seems to work is grub rescue and I do not know how to reinstall grub from here or how to start windows from it or a bootable USB.

Therefore is my question is one of these options possible in my situation?

At grub rescue it seems you can’t do it.

To force opening the UEFI, you will need to unplug your HDD. I see no other solution. You need to access the UEFI.


Here is similar problem with the UEFI : Helios 300 Can’t Enter BIOS Settings PH315-52 — Acer Community

I believe it has to do with Windows and the firmware…

1 Like
  1. As stated earlier i think something has gone wrong with firmware.
  2. How did you partition your drive during install a separate “boot/efi” and “/” partition or a single “/” partition.

I did boot/efi and / as stated in the tutorial, was that wrong, or did I mess up here?

I also just copied the windows command

And I think that might have been very dumb as there is a path in there. I thought this should be the same, since I did everything as explained in the tutorial.

There’s no problem in having a separate boot partition.

In grub rescue use ls command to locate

In the EFI directory there should be two sub directories
boot and manjaro

you may even have a third directory if you have recently update BIOS firmware.

Both booth boot and manjaro directories will have efi files

some laptops have problems in booting from

they can only boot from /boot/efi/EFI/boot/bootx64.efi

It seems like i do not have those files, the lowest directory seems to be boot/efi

May this be the cause of my problem?

If you neglected to format the EFI partition as FAT32 - then you have a problem as a FAT filesystem is mandatory for the $esp.

So is the only Option to remove the hdd and Reset everything?

I do not know if I neglected it, but may this cause my problem? And is there a good way to fix it?

first line of your boot points suggests either you have formatted the drive wrong or wrong drive is marked as boot drive grub config.

Try to check you are able to get to the boot menu by pressing F12 after you start your laptop.
If yes then you can create a live usb and install grub.

can you boot on USB iso manjaro
open a terminal and a browser on this topic
and reports

inxi -Mxa
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l 
sudo manjaro-chroot -a
ls -lha /boot/efi/EFI/*
exit ( end-chroot )


Thanks to:

I have made the decision to open my notebook, unplug the HDD and boot from USB to reinstall Manjaro. It works just fine now without any problems. I think the errors were related to the multiple partitions created as recommended by the tutorial.

For me it works best if I just use a single partition for the installation and another partition for storing files. Important to notice, is to not use manual partitioning, which needs an EFI partition and things can get messy. The “install alongside” worked perfectly.

However, if you know what you do, manual partitioning might have its advantages!

Thank you all for your time and help!

Helpful Information
In order to provide unplugging the HDD in future, make sure to enable the selection where to boot form in BIOS. This would have allowed me to press “F12” to enter the menu and directly choose where to boot from.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.