Dual monitors acting like single monitor

Hello all. For some reason, my dual-screen setup is being treated as a single monitor. One screen is my laptop’s and the other is external. Whenever I maximize a window, it maximizes across both monitors. When I try to run games at full screen, it runs across both as well. I did manage to get all my icons and panel set to one monitor, but other than that, it is like the two monitors have merged into some annoying mega monitor. Any thoughts?

:+1: Welcome to Manjaro! :+1:

  • Yes, that’s by design… If you don’t want that, you can mirror the monitors instead (same output on both so you can close your laptop)

  • on KDE, you can have different activities on different screens but you have to define those and you cannot mix different virtual desktops on different screens with different activities for the same reason XFCE cannot do that neither: from an X perspective, the two monitors are one huge screen unless they’re mirrored or one of them turned off.


Is that something new?
Okay I haven’t use Plasma, XFCE or Gnome in a while (using i3) but I am certain when I used one of those I could maximize a Window on one screen even with 4 screens attached that was no problem and did not need any special tricks or so.

@ dudemcbro
What DE are you running and what graphical card are you using? (lol just click and seen it)

Yup, that’s the one that can do this.

Click on the OPs avatar and that’ll answer your question to him/her. :innocent:

Please post the output of inxi -Fazy.

As can Gnome and Plasma and lots of others.

Just installed xfce4 and also no problem to maximize a window on one monitor only. So keeps the " by design" thingy unclear to me.

So back on topic.

I tried it on my system with a clean xfce4 install. Only think I can think of is that my xrand settings have something to do with it, but there also kinda basic.

I don’t use fixed resolutions, because that gave me some issues, with auto all seems fine.

I dunno if you have xrandr setup with fixed resolutions, in that case perhaps try auto instead. Its all I can think of, since Xfce is not what I use to work with.

@Fabby I’ve never experienced this issue before on various laptops I have had. I definitely don’t want to mirror the images. Because of the nature of my work, I have to have several windows open at the same time and need the two monitors for screen space. This isn’t a major issue, but it does make window snapping and maximizing annoying.

Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64
root=UUID=9ce0d192-74cb-480c-a301-5218e56ae9d2 rw quiet apparmor=1
security=apparmor resume=UUID=5b9fd5b9-6a63-41d5-977e-336d40f2ebaf
Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4
dm: LightDM 1.30.0 Distro: Manjaro Linux
Type: Laptop System: Micro-Star product: GF65 Thin 9SD v: REV:1.0
serial: Chassis: type: 10 serial:
Mobo: Micro-Star model: MS-16W1 v: REV:1.0 serial:
UEFI: American Megatrends v: E16W1IMS.108 date: 12/04/2019
ID-1: BAT1 charge: 48.8 Wh condition: 48.8/51.3 Wh (95%) volts: 12.8/11.4
model: MSI Corp. MS-16W1 type: Li-ion serial: N/A status: Full
Device-1: hidpp_battery_1 model: Logitech Wireless Keyboard K360
serial: charge: 55% (should be ignored) rechargeable: yes
status: Discharging
Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP
arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6
L2 cache: 12.0 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 62431
Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel UHD Graphics 630 vendor: Micro-Star MSI driver: i915
v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b
Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Micro-Star MSI
driver: nvidia v: 450.66 alternate: nouveau,nvidia_drm bus ID: 01:00.0
chip ID: 10de:2191
Display: x11 server: X Org 1.20.9 driver: modesetting,nvidia
unloaded: intel,nouveau alternate: fbdev,nv,vesa display ID: :0.0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 120 dpi: 142 size: 344x193mm (13.5x7.6")
diag: 394mm (15.5")
OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.8
direct render: Yes
Device-1: Intel Cannon Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci
bus ID: 00:1f.3 chip ID: 8086:a348
Sound Server: ALSA v: k5.8.11-1-MANJARO
Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel
port: 5000 bus ID: 00:14.3 chip ID: 8086:a370
IF: wlo1 state: up mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel port: 3000 bus ID: 03:00.0
chip ID: 10ec:8168
IF: enp3s0 state: down mac:
Local Storage: total: 476.94 GiB used: 225.14 GiB (47.2%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN530 SDBPNPZ-512G-1032
size: 476.94 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 serial: rev: 21101000 scheme: GPT
ID-1: / raw size: 127.80 GiB size: 125.30 GiB (98.04%) used: 8.19 GiB (6.5%)
fs: ext4 dev: /dev/nvme0n1p4
ID-2: /home raw size: 316.65 GiB size: 310.67 GiB (98.11%)
used: 216.95 GiB (69.8%) fs: ext4 dev: /dev/nvme0n1p3
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 32.00 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p2
System Temperatures: cpu: 45.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 297 Uptime: 11h 49m Memory: 31.21 GiB used: 3.27 GiB (10.5%)
Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages:
pacman: 1093 lib: 317 flatpak: 0 Shell: Bash v: 5.0.18
running in: xfce4-terminal inxi: 3.1.05

Exactly what I expected. I’m fairly certain that this is caused by you using the nvidia gpu as an output sink (please post the output of xrandr --listproviders, xrandr -q, and nvidia-smi to confirm it). See this thread for more information. I recommend installing optimus-manager and switching to nvidia mode if you want to use external outputs.

1 Like

I did the following with no luck: same issues.
xrandr --output eDP-1 --primary --auto --output HDMI-1-0 --auto --left-of eDP-1

xrandr --listproviders 
Providers: number : 2
Provider 0: id: 0x43 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 3 outputs: 1 associated providers: 1 name:modesetting
Provider 1: id: 0x26e cap: 0x2, Sink Output crtcs: 4 outputs: 1 associated providers: 1 name:NVIDIA-G0 ```

xrandr -q
Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 344mm x 193mm
1920x1080 120.11*+ 59.97 59.96 59.93 48.08
1680x1050 59.95 59.88
1400x1050 74.76 59.98
1600x900 59.99 59.94 59.95 59.82
1280x1024 85.02 75.02 60.02
1400x900 59.96 59.88
1280x960 85.00 60.00
1440x810 60.00 59.97
1368x768 59.88 59.85
1280x800 59.99 59.97 59.81 59.91
1152x864 75.00
1280x720 60.00 59.99 59.86 59.74
1024x768 85.00 75.05 60.04 85.00 75.03 70.07 60.00
1024x768i 86.96
960x720 85.00 75.00 60.00
928x696 75.00 60.05
896x672 75.05 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
832x624 74.55
960x540 59.96 59.99 59.63 59.82
800x600 85.00 75.00 70.00 65.00 60.00 85.14 72.19 75.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
700x525 74.76 59.98
800x450 59.95 59.82
640x512 85.02 75.02 60.02
700x450 59.96 59.88
640x480 85.09 60.00 85.01 72.81 75.00 59.94
720x405 59.51 58.99
720x400 85.04
684x384 59.88 59.85
640x400 59.88 59.98 85.08
576x432 75.00
640x360 59.86 59.83 59.84 59.32
640x350 85.08
512x384 85.00 75.03 70.07 60.00
512x384i 87.06
512x288 60.00 59.92
416x312 74.66
480x270 59.63 59.82
400x300 85.27 72.19 75.12 60.32 56.34
432x243 59.92 59.57
320x240 85.18 72.81 75.00 60.05
360x202 59.51 59.13
360x200 85.04
320x200 85.27
320x180 59.84 59.32
320x175 85.27
HDMI-1-0 connected 1920x1080+0+0 480mm x 270mm panning 3840x1080+0+0
1920x1080 60.00*+ 74.97 59.94 50.00
1680x1050 59.95
1600x900 60.00
1440x900 59.89
1400x1050 59.98
1280x1024 75.02 60.02
1280x800 59.81
1280x720 60.00 59.94 50.00
1152x864 75.00
1024x768 75.03 60.00
800x600 75.00 60.32
720x576 50.00
720x480 59.94
640x480 75.00 59.93 59.94
1680x1050 (0x49) 146.250MHz -HSync +VSync
h: width 1680 start 1784 end 1960 total 2240 skew 0 clock 65.29KHz
v: height 1050 start 1053 end 1059 total 1089 clock 59.95Hz
1280x1024 (0x52) 135.000MHz +HSync +VSync
h: width 1280 start 1296 end 1440 total 1688 skew 0 clock 79.98KHz
v: height 1024 start 1025 end 1028 total 1066 clock 75.02Hz
1280x1024 (0x53) 108.000MHz +HSync +VSync
h: width 1280 start 1328 end 1440 total 1688 skew 0 clock 63.98KHz
v: height 1024 start 1025 end 1028 total 1066 clock 60.02Hz
1280x800 (0x5e) 83.500MHz -HSync +VSync
h: width 1280 start 1352 end 1480 total 1680 skew 0 clock 49.70KHz
v: height 800 start 803 end 809 total 831 clock 59.81Hz
1152x864 (0x60) 108.000MHz +HSync +VSync
h: width 1152 start 1216 end 1344 total 1600 skew 0 clock 67.50KHz
v: height 864 start 865 end 868 total 900 clock 75.00Hz
1024x768 (0x69) 78.750MHz +HSync +VSync
h: width 1024 start 1040 end 1136 total 1312 skew 0 clock 60.02KHz
v: height 768 start 769 end 772 total 800 clock 75.03Hz
1024x768 (0x6b) 65.000MHz -HSync -VSync
h: width 1024 start 1048 end 1184 total 1344 skew 0 clock 48.36KHz
v: height 768 start 771 end 777 total 806 clock 60.00Hz
800x600 (0x86) 49.500MHz +HSync +VSync
h: width 800 start 816 end 896 total 1056 skew 0 clock 46.88KHz
v: height 600 start 601 end 604 total 625 clock 75.00Hz
800x600 (0x87) 40.000MHz +HSync +VSync
h: width 800 start 840 end 968 total 1056 skew 0 clock 37.88KHz
v: height 600 start 601 end 605 total 628 clock 60.32Hz
640x480 (0x9a) 31.500MHz -HSync -VSync
h: width 640 start 656 end 720 total 840 skew 0 clock 37.50KHz
v: height 480 start 481 end 484 total 500 clock 75.00Hz
640x480 (0x9b) 25.175MHz -HSync -VSync
h: width 640 start 656 end 752 total 800 skew 0 clock 31.47KHz
v: height 480 start 490 end 492 total 525 clock 59.94Hz

Sun Oct 4 09:11:51 2020
| NVIDIA-SMI 450.66 Driver Version: 450.66 CUDA Version: 11.0 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| | | MIG M. |
| 0 GeForce GTX 166… Off | 00000000:01:00.0 On | N/A |
| N/A 39C P8 6W / N/A | 36MiB / 5944MiB | 27% Default |
| | | N/A |

| Processes: |
| GPU GI CI PID Type Process name GPU Memory |
| ID ID Usage |
| 0 N/A N/A 787 G /usr/lib/Xorg 35MiB |

Yes, that’s what I expected. As I’ve previously mentioned, I suggest installing optimus-manager.

I’ll give it a shot. I tried installing the 440xx driver just to see what happens, but now only my external monitor displays anything. I tried reverting back to the 450xx but the issue persists. Any ideas how to get both screens working again?

In the future, when providing code/output, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that the output looks like this:

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

instead of like this:

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

(as that makes our life much easier so you get helped more quickly and efficiently)


I did that, but for whatever reason, it only worked for the first code block. Probably a typo somewhere. I’ll try and be more vigilant in the future.

1 Like

I installed optimus-manager like the guide said and everything works! Just one last question. When running in nvidia mode, does run everything through the dGPU by default?

Yes, that is correct.

Thanks. I noticed increased screen tearing now since installing optimus-manager. Is that normal?

Unfortunately it often is the case that screen tearing is present. You could try enabling “Force Composition Pipeline” or “Force Full Composition Pipeline” in nvidia-settings under “X Server Display Configuration” (select the external monitor, and click “Advanced”).

Tried that. It helped, but now there is a some stuttering when scrolling through web pages or moving windows, but it is manageable. Thanks again for your help.

I also corrected the solution. You accidentally accepted a comment by yourself instead of @pobrn 's solution.

:wink: :grin: