Dual Display not working - Manjaro KDE

Hi there

I registered a query on the old forum re my dual display not working in Manjaro, although it worked fine in Mint

The advice then was to wait for new nVIDIA 450xx hybrid drivers

Have just installed and rebooted and confirmed they are installed via MHWD

Sadly dual monitor still not recognised

Grateful for some pointers please as I miss having this resource in this version of Linux


Should add I have a HP Omen Elite Gaming Laptop connected to a Dell Monitor via HDMI through a Toshiba Dynadock 3.0 docking station

Tried following after Googling:
xrandr --output eDP-1 --auto --output HDMI-1 --auto --above eDP-1
xrandr --output HDMI-1 --auto

xrandr has following output that shows my HDMI is disconnected even though it was fine in Mint and still works in Windoze:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
1920x1080 120.11*+ 60.01 60.06 59.97 59.96 59.93
1680x1050 59.95 59.88
1400x1050 74.76 59.98
1600x900 59.99 59.94 59.95 59.82
1280x1024 85.02 75.02 60.02
1400x900 59.96 59.88
1280x960 85.00 60.00
1440x810 60.00 59.97
1368x768 59.88 59.85
1280x800 59.99 59.97 59.81 59.91
1152x864 75.00
1280x720 60.00 59.99 59.86 59.74
1024x768 85.00 75.05 60.04 85.00 75.03 70.07 60.00
1024x768i 86.96
960x720 85.00 75.00 60.00
928x696 75.00 60.05
896x672 75.05 60.01
1024x576 59.95 59.96 59.90 59.82
960x600 59.93 60.00
832x624 74.55
960x540 59.96 59.99 59.63 59.82
800x600 85.00 75.00 70.00 65.00 60.00 85.14 72.19 75.00 60.32 56.25
840x525 60.01 59.88
864x486 59.92 59.57
700x525 74.76 59.98
800x450 59.95 59.82
640x512 85.02 75.02 60.02
700x450 59.96 59.88
640x480 85.09 60.00 85.01 72.81 75.00 59.94
720x405 59.51 58.99
720x400 85.04
684x384 59.88 59.85
640x400 59.88 59.98 85.08
576x432 75.00
640x360 59.86 59.83 59.84 59.32
640x350 85.08
512x384 85.00 75.03 70.07 60.00
512x384i 87.06
512x288 60.00 59.92
416x312 74.66
480x270 59.63 59.82
400x300 85.27 72.19 75.12 60.32 56.34
432x243 59.92 59.57
320x240 85.18 72.81 75.00 60.05
360x202 59.51 59.13
360x200 85.04
320x200 85.27
320x180 59.84 59.32
320x175 85.27
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
HDMI-1-0 disconnected
DP-1-0 disconnected
DP-1-1 disconnected

More info:
[raaj@raaj-CHiP ~]$ inxi -Faz
System: Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A
parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=ac23b24b-18c8-4d4a-84e9-fe45b3aa87d1 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 info: cairo-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux
Machine: Type: Laptop System: HP product: OMEN by HP Laptop 15-ce0xx v: N/A serial: Chassis: type: 10
Mobo: HP model: 838F v: 40.21 serial: UEFI: American Megatrends v: F.08 date: 09/29/2017
Battery: ID-1: BAT0 charge: 52.7 Wh condition: 57.2/57.2 Wh (100%) volts: 16.8/15.4 model: HP Primary type: Li-ion
serial: N/A status: Unknown
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master serial:
charge: 100% (should be ignored) rechargeable: yes status: Discharging
CPU: Topology: Quad Core model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158)
stepping: 9 microcode: D6 L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 44817
Speed: 804 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 808 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics: Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] vendor: Hewlett-Packard driver: nvidia v: 450.66
alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c8c
Device-3: Realtek HP Wide Vision FHD Camera type: USB driver: uvcvideo bus ID: 1-6:5 chip ID: 0bda:58e6
Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: modesetting,nvidia unloaded: intel,nouveau
alternate: fbdev,nv,vesa display ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP-1 res: 1920x1080 hz: 120 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.1.7 direct render: Yes
Audio: Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3
chip ID: 8086:a171
Device-2: DisplayLink 4-Port USB 3.0 Hub type: USB driver: cdc_ncm,snd-usb-audio bus ID: 2-1.1:3 chip ID: 17e9:4305
Sound Server: ALSA v: k5.8.6-1-MANJARO
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
port: c000 bus ID: 03:00.0 chip ID: 10ec:8168
IF: enp3s0 state: down mac:
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: c000 bus ID: 04:00.0 chip ID: 8086:095a
IF: wlp4s0 state: up mac:
IF-ID-1: enp0s20f0u1u1i5 state: up speed: N/A duplex: N/A mac:
Drives: Local Storage: total: 1.14 TiB used: 21.04 GiB (1.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 vendor: Toshiba model: N/A size: 238.47 GiB block size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 serial: rev: AAHA4102 scheme: GPT
ID-2: /dev/sda vendor: HGST (Hitachi) model: HTS721010A9E630 size: 931.51 GiB block size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: rev: A3T0 scheme: GPT
Partition: ID-1: / raw size: 68.36 GiB size: 66.79 GiB (97.70%) used: 20.96 GiB (31.4%) fs: ext4 dev: /dev/nvme0n1p5
Swap: Alert: No Swap data was found.
Sensors: System Temperatures: cpu: 60.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 262 Uptime: 8m Memory: 15.53 GiB used: 1.48 GiB (9.5%) Init: systemd v: 246 Compilers: gcc: 10.2.0
Packages: pacman: 1625 lib: 425 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

 video-modesetting            2020.01.13                true            PCI
       video-linux            2018.05.04                true            PCI

video-hybrid-intel-nvidia-450xx-prime 2019.10.25 false PCI

Warning: No installed USB configs!

Could it be to do with the fact that my laptop connects to the dock via a USB 3 connection?


Remove video-modesetting and reinstall video-hybrid-intel-nvidia-450xx-prime then reboot.

Thanks for the quick reply. Any chance you could advise re actual scripts so I can paste please

sudo mhwd -r pci video-modesetting
sudo mhwd -f -i pci video-hybrid-intel-nvidia-450xx-prime
systemctl reboot

Thanks on running first command got:
Error: config ‘video-modesetting’ is required by config(s): video-hybrid-intel-nvidia-450xx-prime

I ran both commands, ignoring first error message and rebooted.
Unfortunately did not change anything

Ah, ok. Then i understood it backwards. So, you keep the video-modesetting but remove video-linux and then reinstall the video-hybrid-intel-nvidia-450xx-prime
You should be able to do that even from TTY.

Thanks again for your quick advice
Followed through both commands but regrettably the issue remains

So, what you did when this was suggested in the archived forum?

Ok will do. The hybrid laptop was identified previously in July when I had 440 driver. i was told the 450 would resolve. So do I try optimus now?

Hi. So what do I do next then?

Did you try to connect it without the dock? Maybe the issue is with the dock and not the display.

Thanks. Just to clarify the issue only appeared when I moved to Manjaro. Other linux distros have worked straight away and Windoze still works as well. My dock has an ethernet connection and multimedia etc. It is a deal breaker for me that I must be able to use my dock. If there are Manjaro drivers for the dock I need to install please advise. Thanks again R

Yeah but just try to test it so we know what the culpript is. If Manjaro detects the display when you connect it directly then it might be the dock, and we can focus our efforts on that. I too have a laptop, it’s quite old so it has a VGA output, and Manjaro picks it up no problem.

Ok understood. I connected the HDMI cable directly to the laptop, bypassing the dock. The second monitor displayed fine in Windows but again, not in linux. Aside from the monitor issue, the dock otherwise works in linux in terms of access to ethernet connection, printer and speakers.

HI Grateful for some more advice just to have one last stab at this before I chuck the towel in on Manjaro and move on to another distro that easily recognises dual display…

Looks like no takers after nearly 3 weeks. Very disappointing. Had high hopes

I don’t have a working HP machine (several HP scraptops though) and no dock so can’t offer specific advice, but on my machine (a Lenovo T440), also running Manjaro KDE, with my mate’s TV I connect the leads, select the input and then have to power-cycle the TV before it is picked up by the system. Works fine after that, until next time.

This might not be much use but thought I’d post just in case.