Dual Booting-can no longer access Windows

Hello-from my brief look around it seems as if this topic has been gone over a dozen times so I am sorry if this is a tired question, but I am new to Linux in general and I just want to make sure that I don’t screw things up further than I already have. I’ve been attempting to dual boot with Windows 10 and Manjaro. I was able to successfully install and use Manjaro without any issues, but it seems that I’ve broken my installation of Windows 10 in the process. From my understanding of what I’ve read here it seems I might have Windows installed in BIOS mode and Manjaro installed in UEFI mode, but I am too new at this to be sure of anything.

sudo parted -l
[sudo] password for jacob: 
Model: INTEL HBRPEKNX0203A (nvme)
Disk /dev/nvme0n1: 1024GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  274MB   273MB   fat32        EFI system partition          boot, esp
 2      274MB   290MB   16.8MB               Microsoft reserved partition  msftres
 3      290MB   761GB   761GB   ntfs         Basic data partition          msftdata
 5      761GB   1023GB  262GB   ext4
 4      1023GB  1024GB  889MB   ntfs         Basic data partition          hidden, diag

Model: INTEL HBRPEKNX0203AO (nvme)
Disk /dev/nvme1n1: 29.3GB
Sector size (logical/physical): 512B/512B
Partition Table: loop
Disk Flags: 

Number  Start  End     Size    File system  Flags
 1      0.00B  29.3GB  29.3GB  ntfs

My partition table.

[jacob@jacob-zephyrusmgu502gvgu502gv ~]$ efibootmgr -v
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0004,0003,0000,0001,0002
Boot0000* Windows Boot Manager  HD(1,GPT,b1bf6c45-71e2-4bb1-b564-ab1c51412fb8,0x800,0x82000)/File(\EFI\MICROSOFT\BOO
Boot0001* UEFI: KingstonDataTraveler 2.01.00    PciRoot(0x0)/Pci(0x14,0x0)/USB(2,0)/CDROM(1,0x543c28,0x8000)..BO
Boot0002* UEFI: KingstonDataTraveler 2.01.00, Partition 2       PciRoot(0x0)/Pci(0x14,0x0)/USB(2,0)/HD(2,MBR,0x0,0x5
Boot0003* Manjaro       HD(1,GPT,b1bf6c45-71e2-4bb1-b564-ab1c51412fb8,0x800,0x82000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0004* rEFInd Boot Manager   HD(1,GPT,b1bf6c45-71e2-4bb1-b564-ab1c51412fb8,0x800,0x82000)/File(\EFI\REFIND\REFIND

The boot manager.

[jacob@jacob-zephyrusmgu502gvgu502gv ~]$ sudo os-prober
[sudo] password for jacob: 
/dev/nvme0n1p1@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi

And OS prober.

What can I do to fix this? Any help is appreciated, thanks :smile:

Your Windows seems to be also in UEFI and is detected by os-prober. So probably the only thing you need is to edit the file /etc/default/grub and uncomment (remove the # from the beginning) the line GRUB_DISABLE_OS_PROBER=false

After that, execute sudo update-grub and that should be it.

Thank you for the reply! When I do that, the terminal returns

[jacob@jacob-zephyrusmgu502gvgu502gv ~]$ sudo update-grub
/etc/default/grub: line 39: Uncomment: command not found

I’m going to try and reboot my machine to see if that’s changed anything.

‘Uncommenting’ means change




That’s in the .txt file, right? I changed it there-unless I should’ve done it somewhere else?

Yep, edit it in mousepad or other text editor, and as Wollie says find the line
and change it to
Save it and exit. Then from a shell/terminal
sudo update-grub

and you should be golden

Like this, right? Terminal still returns the same error message.

Uncomment this option to enable os-prober execution in the grub-mkconfig command GRUB_DISABLE_OS_PROBER=false

I’m unable to upload media items according to the forum otherwise I would upload a picture, but this is in etc/default/grub

You uncommented the wrong line.This is how it should be in your file:

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

Notice that one line is commented (has a #) and the other one not. And they are two different lines
PS: these are the lines 39 and 40 in the file

If you have had the ‘luck’ that Windows is installed in BIOS/GPT mode then most likely your Manjaro will be installed in EFI/GPT mode.

To my knowledge you cannot make grub recognize the loader for a different loading type.

Another option - to avoid reinstallation - is to use your firmware boot-override key - check with your system’s manual but often something like F7 or F12 - to select the operating system to load.

Looking more closely on the data provided suggests your system could be using Intel Optane or Intel Volume Management as you have two nvme devices

  • nvme0n1
  • nvme1n1

Is your system equipped with an Intel Optane H10 nvme disk or something similiar?

If yes - there is similar issues like yours

A wild guess is adding a kernel argument to enable the system to see the two devices as one - but I have no hands on experience with this.

The guess was not as far fetched as I initally thought as I found this on the Arch BBS

Especially note comment #17 which apparently solved the issue - please remember I have no experience with these devices - I am merely putting my search-fu at work - you will have to take it from here.