Dual boot: Weird no sound behavior but devices are visible

Hi, I recently tried to install manjaro on my laptop, everything was going well till I found that that there is no sound from my inbuilt speaker or headphone audio jack. Weirdly enough if I plug my usb audio adapter and plug my headphone to it, audio works just fine. I can see the correct levels being displayed in pavucontrol panel.

I can also see my speaker and headphone as a device. I also looking at different topics I tried diagnosing this on my own but here I am.
Just as an info I am dual booting from windows, it works fine there, it works fine even with my weird adapter thing. I am fast boot off and secure boot. Unfortunately I can’t upload images and links till my trust level is little bit higher.

Thanks for any help sid : )


I am using Asus Vivobook_ASUSLaptop K6500ZE_K6500ZE
CPU: 12th Gen Intel i5-12450H (12) @ 4.400GHz 
GPU: NVIDIA GeForce RTX 3050 Ti Mobile

Hello @sid and welcome :wink:

Dumb question, since you did not mention it: Did you set the correct sound profile?

Otherwise, I can imagine that the pins are vendor-specific and needs to be adjusted. hdajackretask is then your friend (pkg: alsa-tools). A change of pins can happen, when you update the vendor-firmware for example.

The content of the link looks quite normal and everything seems to be detected correctly.

1 Like

Hi @megavolt , I did check in hdajackretask, you can see in the image linked. Everything seems alright in it to me although I only have half a clue on what I am looking at. Just a mention that, I can hear crackling sounds if I raise my headphone’s sound to 100. Also I tried distro hopping a bit seems like it is the same case with ubuntu fedora I am back on manjaro with my trustee adapter that I have.


ALSA mixer settings show control for speaker output is muted and level set to 0%

!!-------Mixer controls for card PCH

Simple mixer control 'Speaker',0

  Front Left: Playback 0 [0%] [-65.25dB] [off]
  Front Right: Playback 0 [0%] [-65.25dB] [off]

I suggest you try this command to unmute and increase audio level for speaker output

amixer -D PCH sset 'Speaker' 80% unmute

But it is probably not sufficient to get speakers working

An online hardware scan for same make and model system has a workaround for the speakers

Intel Alder Lake PCH-P High Definition Audio Controller
Chip is ALC294.
Not working with kernel 5.15.19, but I did not try the workaround below. With kernel 5.19.17 (Slackware-current as of Jan 2nd, 2023), I had to install alsa-tools, then use once the commands:

    hda-verb /dev/snd/hwC0D0 0x20 0x500 0x1b
    hda-verb /dev/snd/hwC0D0 0x20 0x477 0x4a4b
    hda-verb /dev/snd/hwC0D0 0x20 0x500 0xf
    hda-verb /dev/snd/hwC0D0 0x20 0x477 0x74

…and audio magically appeared.

This workaround was referred to ALSA kernel developers for further attention, but the bug report was closed ein 2021 because there was no reponse to proposed patch
206289 – No sound on ASUS Zenbook UX533FTC | bugzilla.kernel.org


That did not work as you said. But

This did magically work. Thanks @nikgnomic @megavolt for all the help. I hope this gets patched, is there something I should do to raise this issue.

I should mention this, for further details as I saw the bug report and these some of the things that were asked.

  • This fixed my internal speakers and 3.5 mm jack output.
  • This also got my internal mic detected and and also my headset’s mic detected
  • Mic output from both internal and headset were staticy and was cutting out for no reason. Something is wrong with the input.

    Note : The microphone quality was wayyy down, compared to my general experience overtime and also when I used my dongle for headset mic comparison.

  • All 4 commands were required to make this work ( I saw this being asked in the bug report conversation).
  • And obviously this fix does not persist over reboots.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.