Dual Boot ubuntu/manjaro Grub

Hi all!
Since 2 years i use Manjaro (before ubuntu) and i enjoy it very much and i like to thank everybody for contributing. As i like to keep ubuntu in dualboot i am in troble after every ubuntu grub update/install.

Isn’t there any chance to get and information about to fix this problem, without using the grub rescue in manjaro wiki? Also a hint for howto fix this from ubuntu side would be great.
I found a post on askubuntu but i can’t get it work.

Is there anything ? Thanks in advance

1 Like

You need to provide info first How to provide good information

You also need to explain in detail how you have installed and setup both OS and GRUB.

Yeah, like what @omano said… I don’t think anybody is going to be able to help you without more information about your setup. How many hard drives do you have? How are they partitioned? What filetype is being used? There are too many possible things that could be going on and without more information there really isn’t much anybody can do to help.

PS: Ubuntu’s GRUB can not boot Manjaro. Manjaro’s GRUB though, can boot anything.

I think I understand your problem because in the past I had similar problematic issue.
In my case I only want one operating system to be ‘bootable’ with grub. I install it in the real boot partition.
The rest of operating systems were installed in a ficticious bootable partition (real in disk but not for booting).
When the systems update, update their grubs but nothing change in the main boot partition.
The consequence is you are forced to update the main grub to recognice changes in the other systems.
I hope this was the idea.

thanks for your replies. I didn’t provide more info because it was more a generic meant issue. Many people are facing it and there are quite a lot posts regariding it since a long time.
Here is my inxi
inxi -Fazy
Kernel: 5.10.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1
parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
root=UUID=7842c133-5f50-46e4-8720-6060e34e506c rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Type: Desktop Mobo: ASRock model: B460 Steel Legend serial:
UEFI: American Megatrends v: P1.10 date: 05/13/2020
Info: 6-Core model: Intel Core i5-10400 bits: 64 type: MT MCP
arch: Comet Lake family: 6 model-id: A5 (165) stepping: 5 microcode: E0
L2 cache: 12 MiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 69629
Speed: 4198 MHz min/max: 800/2901 MHz boost: enabled Core speeds (MHz):
1: 4198 2: 4198 3: 4048 4: 4105 5: 4100 6: 4112 7: 4046 8: 4095 9: 4091
10: 4109 11: 4098 12: 4093
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA GK208 [GeForce GT 630 Rev. 2] vendor: Palit Microsystems
driver: nvidia v: 460.39 alternate: nouveau,nvidia_drm bus ID: 01:00.0
chip ID: 10de:1284 class ID: 0300
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver:
loaded: nvidia display ID: :0 screens: 1
Screen-1: 0 s-res: 3200x1080 s-dpi: 93 s-size: 874x292mm (34.4x11.5")
s-diag: 921mm (36.3")
Monitor-1: VGA-0 res: 1280x1024 hz: 60 dpi: 96 size: 340x270mm (13.4x10.6")
diag: 434mm (17.1")
Monitor-2: DVI-D-0 res: 1920x1080 hz: 60 dpi: 94
size: 521x293mm (20.5x11.5") diag: 598mm (23.5")
OpenGL: renderer: GeForce GT 630/PCIe/SSE2 v: 4.6.0 NVIDIA 460.39
direct render: Yes
Device-1: Intel vendor: ASRock driver: snd_hda_intel v: kernel
alternate: snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a3f0 class ID: 0403
Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Palit Microsystems
driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:0e0f
class ID: 0403
Device-3: Creative Live! Cam Chat HD [VF0700] type: USB
driver: snd-usb-audio,uvcvideo bus ID: 1-9:3 chip ID: 041e:4088
class ID: 0102 serial:
Sound Server: ALSA v: k5.10.15-1-MANJARO
Device-1: Realtek RTL8125 2.5GbE vendor: ASRock driver: r8169 v: kernel
modules: r8125 port: 3000 bus ID: 02:00.0 chip ID: 10ec:8125 class ID: 0200
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac:
Local Storage: total: 5.11 TiB used: 1.39 TiB (27.2%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20EFRX-68EUZN0
size: 1.82 TiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
rotation: 5400 rpm serial: rev: 0A82 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SUV400S37120G
size: 111.79 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
rotation: SSD serial: rev: D6SD scheme: GPT
ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital model: WD20EZRX-00D8PB0
size: 1.82 TiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
rotation: 5400 rpm serial: rev: 0A80 scheme: GPT
ID-4: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WD5000AAKX-003CA0 size: 465.76 GiB block size: physical: 512 B
logical: 512 B speed: 6.0 Gb/s serial: rev: 1H15 scheme: MBR
ID-5: /dev/sde maj-min: 8:64 vendor: Western Digital model: WD10EADS-00M2B0
size: 931.51 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
serial: rev: 0A01 scheme: MBR
ID-1: / raw size: 63.68 GiB size: 62.43 GiB (98.04%) used: 31.3 GiB (50.1%)
fs: ext4 dev: /dev/sdb4 maj-min: 8:20
ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%)
used: 24.2 MiB (8.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.48 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sdb3 maj-min: 8:19
System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 43 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 30%
Processes: 251 Uptime: 1h 48m wakeups: 0 Memory: 15.55 GiB
used: 1.77 GiB (11.4%) Init: systemd v: 247 Compilers: gcc: 10.2.0
clang: 11.0.1 Packages: pacman: 1461 lib: 430 flatpak: 0 Shell: Bash
v: 5.1.0 running in: konsole inxi: 3.3.01

my fdsik -l /dev/sd

sudo fdisk -l /dev/sdb
Disk /dev/sdb: 111,79 GiB, 120034123776 bytes, 234441648 sectors
Disk model: KINGSTON SUV400S
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 05142918-142F-4B4A-BE9A-7E2266610B32

Dispositivo     Start      Fine   Settori  Size Tipo
/dev/sdb1        4096    618495    614400  300M EFI System
/dev/sdb2      618496  83109887  82491392 39,3G Linux filesystem
/dev/sdb3   216647754 234441389  17793636  8,5G Linux swap
/dev/sdb4    83109888 216647679 133537792 63,7G Linux filesystem

Manjaro is on sdb4 and ubuntu on sdb2, Disk is a SSD i use only for OS

Hope this is ok like info. If you need more just let me know.

Thanks again in advance

Please, could you get the output from? → efibootmgr -v

efibootmgr -v
BootCurrent: 0000
Timeout: 1 seconds
BootOrder: 0000,0001
Boot0000* manjaro       HD(1,GPT,7f993757-b6e1-4634-811e-873c8470fc13,0x1000,0x96000)/File(\EFI\MANJARO\GRUBX64.EFI)
Boot0001* ubuntu        HD(1,GPT,7f993757-b6e1-4634-811e-873c8470fc13,0x1000,0x96000)/File(\EFI\UBUNTU\SHIMX64.EFI)


ok, thanks.
You have got the two entries in the UEFI partition.
Why do you need the rescue grub method after the ubuntu update? Is the Manjaro entry dissappeared?
Can’t you boot in the Manjaro boot menu selecting manually from the firmware? (for exemple I need to click the ESC key to enter the selection menu of the firmware → then it shows the two options for selecting with grub menu I want to start).
Thanks again.

Actually the entry never disappears. It is there. The problem is that when i select it doesn’t boot. it gets a black screen immediately and stops.

to boot in from firmware i didn’t know that it is possible. next time when it happens i will try. this doesn’t solve the situation.

Anyway. i’m not a coder just an enduser. so that’s why i was wondering that there is no remaining solution for this.

thanks !

For testing the problem I start from an external drive I have installed various systems.
And It’s right: from the Ubuntu entry, grub doesn’t start any Manjaro (the Manjaro in the same external disk, nor the Manjaro in the ssd internal disk).
If in grub take off the ‘quiet’ parameter I see ‘kernel panic’.
In opposite, from an OpenSuse entry for grub, it is possible to start any system.
The same if I start from Manjaro entries.
Maybe the answer is definitive: omano
9 h
PS: Ubuntu’s GRUB can not boot Manjaro. Manjaro’s GRUB though, can boot anything.

I insert the images from my system:

1 Like

I tried to boot from the Ubuntu grub menu again, and I get start the ArchLinux partition with no problems.
But not with any Manjaro. Sorry.
I think it was by that I discard to start from any other than Manjaro Grub. Thanks for the Manjaro team.

I had the sane problem and I solved installing REFInd under Ubuntu, now I have Manjaro/W10/Fedora all boot from REFInd

1 Like

Well, there are known ways to modify your GRUB to suit your needs, like here . Three options are given. I, personaly, use the third one and forgot all troubles with updates and upgrades of my many OSes long ago.
For this method you may create your personal 06_custom file in /etc/grub.d as described here and here .

The custom entry is the neat solution.

A simple work-around for Manjaro to co-exist with Ubuntu- based systems (which only rarely get an update for their grub pkg) is to always have Manjaro to be in charge of grub. That means eg after installing Ubunt on an existing Manjaro (which will break grub since Ubuntu’s grub will take over) simply boot from a Manjaro live-usb, do
manjaro-chroot -a
pick your Manjaro partition and re-install grub
sudo grub-install dev/sdx (where x is your drive with the boot partition, most likely sda)

In my experience around once a year an installed Ubuntu sys will get an update for its grub pkg that can re-break that, also any later added non-Manjaro distro will, so just repeat and get (any) Manjaro grub back in charge.

I also had the same exact issue - not being able to boot my Manjaro (main OS) from Ubuntu Grub and after seeing your post, installed REFInd on the Ubuntu and fixed it for like 5 mins.

Thanks a lot!