Dual Boot suddenly isn't working

Sorry, I’m new to the forum, so feel free to ask me to provide more information or correct something. Or if I’m just totally asking in the wrong place. I’m also pretty new to Linux, so I apologize if I don’t understand something.

I first installed Manjaro a couple months ago and it has worked (apparently) without problems since then, until sometime last week. I installed it dual-boot style alongside Windows 10, and normally, upon restart, the system will boot to the GRUB screen, where I can select either Manjaro or Windows.

As of last week, Manjaro won’t start. I can still get to GRUB, and select either Manjaro or Windows, but selecting Manjaro will just show the “LEGION” screen I’m used to, but it won’t actually start Manjaro. I’ve checked a couple things in the BIOS menu—secure boot is off, it’s set to UEFI (which is, I’m pretty sure, correct for my installation).

Like I said, I’m happy to go looking for more information, but I’m not sure how to get at some of it, given that I can’t boot Manjaro right now. :grimacing: Advice is appreciated!

I’d love it if someone had a fix for this, but I know there’s not a lot of information to be obtained here, so I’m really looking for tests I can run to try to ascertain the issue. I’m happy to provide more info.

First did you install windows 10 after installing Manjaro?

1 Like

And please tell us did you get any text on the screen past the selection of OS?
Can you get inside your Windwos OS?

1 Like

Windows was pre-installed, and I added Manjaro afterwards.

After I select Manjaro, I don’t see anything except the model logo. I suspect that it would remain on the screen for hours if I let it.

Windows works fine, at least.

Have you tried reinstalling Manjaro? Sometimes I get a bad install and the only solution I find is reinstalling. I understand if you don’t want to do that but if you can it most likely will be the fastest and easiest fix. I am mostly suggesting this because it seems like you just installed it and don’t have any data to loose.

1 Like

You are having AMD or Nvidia GPU ?

That could be a fast option. But let him try fixing it first and potentially learn something.

1 Like

I haven’t tried reinstalling. That’s a path that I’ve been trying to avoid, mostly because it’s a miracle that I pulled it off without a hitch when I first did it (April? May?), and by now I’ve forgotten all the nuances of the process. I don’t have a ton of data I’d risk losing, but it’s enough to make me hesitate.

I do have an Nvidia GPU. And I certainly hope I learn something from this process!

Also, thank you all for the prompt replies! Sorry that my rate of response is probably going to be the bottleneck in this process.

Ok that’s fine I just know that reinstalling is a quick way to get up and going sometimes.

Ok so when you installed it you must have selected the nvidia driver on the boot screen of the usb installer correct?

Your welcome!

Oh boy. That was a while ago. Most likely, yes? I know for certain I started from a USB drive; I don’t recall the settings I selected.

Did you experience a Windoze update before your issue started?

1 Like

Ok cause if you didn’t chose the nvidia drivers than that could be the issue.

1 Like

Good call this always breaks things but usually grub gets broken when this happens.

1 Like

I don’t believe so, but that could be I’m not certain when precisely the problem occurred. I haven’t been able to use Manjaro as frequently as I’d like the past month, so I’ve got a window of at least a week in which the issue could’ve occurred without me noticing.

I know my last BIOS update (which has been the thing to mess things up in the past), was not in this time window, though. If that helps.

If it was a driver problem, would that have been immediately apparent after install? Because I was able to boot and run Manjaro for several months after install, no problem.

Boot into Windoze as Admin and switch off all hibernation features such as Fastboot etc. Also run at a command prompt:

powercfg.exe /hibernate off

Fully poweroff your PC. Then you need a live ISO on an USB stick to boot into a Manjaro live ISO.
Restore the bootloader (for EFI system) acc. to following guide:
IMHO Windoze operates somehow like a bulldozer and tends to ignore/damage foreign entries in /boot/efi partition.


Ahhh I did not know this. No it should have been immediately apparent.


Also do you have 2 fat32 partitions on your disk one for windows boot and the other for Manjaro? You can check this by looking at gparted after booting the live usb.

1 Like

Ah, downloading the live ISO really takes me back…

While I’m waiting, status update. Fast startup and Hibernate appear to be off, sleep and lock appear to still be on. Should those be off? Also, I ran the command, and got no output. I assume that’s good.

Yeah, I really suspect Windows is the culprit here. It kind of scares me that Windows can see my Manjaro boot partition (if I remember correctly what that is) and just lists it as a D: drive. The good news, though, is that the “Date modified” listed for the contents of that drive is all May. Hopefully that means that Windows hasn’t played with any of that.

Yea I would agree that windows is the culprit as well. What command did you run?