Dual boot network problem - fresh install

Hello guys,

My internet is working now so I don’t need any help at all for the moment. What I need though is the knowledge how to solve the problem when I encounter a fresh install with no internet.

My situation before was this: I dual boot with Windows and Manjaro. I use Minimal XFCE because I don’t like having a bloated installation. But always after the fresh install, my system can’t connect to the internet but it was all okay when using the Live USB install. I had no idea what happened but I only get an internet connection whenever I boot to Windows first and then restart to Manjaro. Then my problem was solved. My concern is, what happened under the hood that going from Windows to Manjaro solves my network connection? Booting to Manjaro and then restarting to Manjaro didn’t solve my network issue, but booting to Windows first then Manjaro solves it.

Anyone know how does this happen? Is it the problem that I use the Minimal version of the ISO?

Welcome at the forum, @patrina

This is most likely an issue linked to your specific hardware background.

Thank you @Wollie for the welcome. :smiley:

May I know what you mean by that? When I boot to Live USB to install, I can connect just fine, so I don’t think it is a hardware problem. Then after rebooting to Manjaro to complete installation from a fresh install, I couldn’t find any network at all. Then like I said, I had to boot to Windows first (just one time), restart to Manjaro, and my connection is completely solved. Want to know how does that happen.

To summarize the situation:

  1. Live USB - okay network
  2. Fresh install asking me to reboot to Manjaro - no network
  3. Restart to Manjaro - no network
  4. Boot to Windows - okay network
  5. Boot to Manjaro - okay network (fixed)

So my situation was, I had to first boot to Windows “ONCE” just to get a network connection to my Manjaro.

Have you tried turning off “fast startup” in Windows, and “fast boot” in the BIOS?

Yes, both are disabled actually.

Really weird how booting to Windows (once right after fresh Manjaro installation) first, fixed my Manjaro network connection.

Please post the output of inxi -Nazy.

  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8168 v: 8.048.03-NAPI modules: r8169 
  port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 

I have no issue with my Manjaro network since I boot to Windows once.

Could you reboot so that it doesn’t work, and then run sudo modprobe -r r8168 && sudo modprobe r8168 and see if that does anything?

1 Like

Actually no idea how to make it not work. :frowning_face: Can’t replicate the issue unless I install a fresh Manjaro installation again. I can say that confidently because I’ve been hopping between Manjaro KDE/Gnome and finally settled with XFCE. Same issue on all 3, no network upon fresh install, then issue fixed once I boot to Windows once.

Another reason could be that you sometimes just have to reboot twice to get some things sorted in Manjaro and the booting into Windoze had nothing to do with fixing the initial issue. :upside_down_face: The booting into Windoze won’t change anything on Manjaro’s software side, but potentially on hardware side. :wink:

Not really. That was what I thought too, “a simple reboot” would solve the issue, but I actually tried rebooting to Manjaro immediately right after the installation tells me to reboot. Same issue, no network.

I’ve actually pointed it out from the step 2 to 3 from my previous comment.

As I said - a second reboot could change things. I’ve seen this happening at other computers being reported here.

I may have lost count to how many times I rebooted to Manjaro right after the fresh installation. But there’s a possibility I may have rebooted more than 2 times but I am not sure about it now.

I’ll definitely try it out sometime this week, do a fresh installation and reproduce it and make sure I reboot at least 3 times and see if the issue would still be there.

@Wollie Okay, replicated the issue. This time I made sure I restarted 4-5 times, same problem. I had to boot to Windows first then my network issue gets solved.

forgot my password from previous account. so made another. sorry.

Might it be to do with DHCP i.e. an IP address not being assigned initially within Manjaro? Did you try assigning one manually, to see if that gets the connection working? I do know some people have issues like this (and network lease time) when switching between OSes.

1 Like

Hi @BG405, I have a good feeling what you recommended is where I should look at. Cause I noticed in my default i3wm bar where the “lan: xxxxx” part, when network wasn’t working, there was a bunch of numbers that looked like a MAC address. Then when I boot to Windows then go back to Manjaro to fix my network, that part reads “” now.

Is this where I should look at to do what you recommend? https:// wiki .manjaro .org/ index.php/ Networking (sorry I can’t put links)

… I added the link in correct format in my quote for convenience.

That is worth a look. I’ll do so a bit later when I’ve had some sleep … I tend to reserve a few addresses for fixed IPs on my home network and also find the DHCP-served ones tend to get asigned the same IPs whichever network they are on i.e. here or at one of the locals.:slight_smile:

1 Like

From what I have read in the wiki, and what I am seeing in my system, I guess I am using Network Manager to handle my network. Will try to experiment setting them up manually. I haven’t completely understand the concept yet but I am starting to get to grasp the situation.

This is fun. Thank you so much for your help @BG405! :smiley:

edit: wanted to make this topic solved but I can’t see any resolved button to do it because I lost my original account when I installed a fresh new one. :frowning:

You’re most welcome! :smiley_cat:

Re. your user accounts, maybe a PM to one of the admins asking for the two to be merged?

Hello there,

i can reproduce this issue consistently every time i restart!

I would also like to find out what is happening and how to fix it.

So to be clear, i have the same behaviour as patrina:

  • Dual boot setup with Win10 and Manjaro
  • If i’m in Manjaro and restart back to it, network hangs and can’t ‘resolve IP’.
  • If i’m in Manjaro, restart back to windows, and back to Manjaro, network works fine.

I’m available for running commands and other info related to my configuration, if you guys have any ideas.

Tried the above suggested commands by pobrn, while network had the issue, the results are below:

~ ᐅ inxi -Nazy 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
sudo modprobe -r r8168 && sudo modprobe r8168
modprobe: FATAL: Module r8168 not found.

But modprobe has the same output as when i run it while network is fine.
Any suggestions ?