Dual Boot - Manjaro hangs on Dell logo during boot

> [estudio@Dell ~]$ inxi -Fazy
> System:
>   Kernel: 5.4.85-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
>   parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
>   root=UUID=3a63b7ba-0224-4eab-a2df-01dec97b0ba2 rw quiet splash 
>   Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
>   Distro: Manjaro Linux 
> Machine:
>   Type: Portable System: Dell product: Vostro 14-5459 v: 1.0.4 
>   serial: <filter> Chassis: type: 8 serial: <filter> 
>   Mobo: Dell model: 01KK0Y v: A00 serial: <filter> UEFI: Dell v: 1.0.4 
>   date: 01/07/2016 
> Battery:
>   ID-1: BAT0 charge: 8.0 Wh condition: 12.0/44.5 Wh (27%) volts: 11.5/11.4 
>   model: SIMPLO Dell type: Li-ion serial: <filter> status: Discharging 
>   Device-1: hidpp_battery_0 model: Logitech M585/M590 Multi-Device Mouse 
>   serial: <filter> charge: 55% (should be ignored) rechargeable: yes 
>   status: Discharging 
> CPU:
>   Info: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP 
>   arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: E2 
>   L2 cache: 4 MiB 
>   flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
>   bogomips: 20810 
>   Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 500 3: 500 
>   4: 501 
>   Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
>   Type: l1tf 
>   mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
>   Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
>   Type: meltdown mitigation: PTI 
>   Type: spec_store_bypass 
>   mitigation: Speculative Store Bypass disabled via prctl and seccomp 
>   Type: spectre_v1 
>   mitigation: usercopy/swapgs barriers and __user pointer sanitization 
>   Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
>   IBRS_FW, STIBP: conditional, RSB filling 
>   Type: srbds mitigation: Microcode 
>   Type: tsx_async_abort status: Not affected 
> Graphics:
>   Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Dell driver: i915 
>   v: kernel bus ID: 00:02.0 chip ID: 8086:1916 
>   Device-2: NVIDIA GM108M [GeForce 930M] driver: N/A alternate: nouveau 
>   bus ID: 01:00.0 chip ID: 10de:1346 
>   Device-3: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo 
>   bus ID: 1-7:5 chip ID: 1bcf:2b90 
>   Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel 
>   display ID: :0 screens: 1 
>   Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
>   s-diag: 582mm (22.9") 
>   Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 157 size: 310x170mm (12.2x6.7") 
>   diag: 354mm (13.9") 
>   OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.3.1 
>   direct render: Yes 
> Audio:
>   Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel 
>   v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d70 
>   Sound Server: ALSA v: k5.4.85-1-MANJARO 
> Network:
>   Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: f040 
>   bus ID: 02:00.0 chip ID: 8086:3165 
>   IF: wlp2s0 state: down mac: <filter> 
>   Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
>   driver: r8169 v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 
>   IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
> Drives:
>   Local Storage: total: 232.89 GiB used: 92.17 GiB (39.6%) 
>   ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT250MX200SSD1 
>   size: 232.89 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
>   serial: <filter> rev: MU03 
>   SMART Message: Unknown smartctl error. Unable to generate data. 
> Partition:
>   ID-1: / raw size: 29.3 GiB size: 28.71 GiB (98.00%) used: 24.66 GiB (85.9%) 
>   fs: ext4 block size: 4096 B dev: /dev/sda6 maj-min: 8:6 
>   ID-2: /boot/efi raw size: 350 MiB size: 346 MiB (98.86%) 
>   used: 27.5 MiB (7.9%) fs: vfat block size: 512 B dev: /dev/sda1 maj-min: 8:1 
> Swap:
>   Alert: No Swap data was found. 
> Sensors:
>   System Temperatures: cpu: 39.0 C mobo: 29.8 C 
>   Fan Speeds (RPM): cpu: 0 
> Info:
>   Processes: 183 Uptime: 7h 05m wakeups: 12 Memory: 7.66 GiB 
>   used: 2.56 GiB (33.4%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
>   clang: 11.0.0 Packages: pacman: 1843 lib: 475 flatpak: 0 Shell: Bash 
>   v: 5.1.0 running in: konsole inxi: 3.2.01 

The issue is as follows - when working on W10 and deciding to switch to Manjaro the system hangs.
I have to turn off the machine by pressing the power switch button long enough it stops working. Then I am able to boot just fine. Biz as usual.
When did it happen?
I guess I can relate it to one of the recent W10 upgrades, or I am mistaken here as well.

I have tried this:

sudo pacman -Syyu haveged
sudo systemctl enable haveged --now

And I was certain it worked but the problem persists nonetheless. I was wrong to think it worked fine.

Which of the info should I include now:

Have you switched off Fast Startup completely in Windoze? Win10 tends to hibernate only. If that’s not disabled, it may lock your disk and file system.

How to mount Windows (NTFS) filesystem due to hibernation - Manjaro

Also I think you should install a proprietary Nvida graphic driver if you want to use the Nvidia device.

Configure NVIDIA (non-free) settings and load them on Startup - Manjaro

1 Like

Thank you, Wollie for your time here.

I have just disabled Fast Startup - again I had to turn off my machine before booting into Manjaro, meaning it didn’t help this time round.

As for the Nvidia drivers - while monitoring the latest huge update of Manjaro, I had been prompted to install new drivers and I thought that was the proper way to continue as suggested.

I still would assume Windoze is rather not properly shutting down. It’s not trivial to ensure this, maybe you could describe here exactly how you tried to switch it off.

Furthermore, please report status of firmware setting related to

  • secure boot
  • fast boot
  • TPM
1 Like

And most likely that’s the thing.

  • secure boot status: disabled
  • fast boot - deactivated
  • TPM - compatible TPM cannot be found
    -AHCI - Sata Operations / in Device Manager i can see the AHCI controller no errors
    -RAID - Basic

Have I submitted the info accordingly?

I have similar problems on my laptop. So you are not alone. I don’t know how to fix it either, but I do know that this is a problem that didn’t exist when I tried Ubuntu and Fedora.
For me what usually helps is to keep multiple kernels as options and (usually the most current and the latest LTS) and try the other one if the first one hangs.

jim, all of a sudden it got back to the usual so I stopped thinking about it but after the recent upgrade of the system, the issue persists, alas.

good to know I am not alone wink