Dual Boot Issue (Grub Menu Only Appearing From Bios and not Automatically)

Hello guys,

Today I made a new partition in order to install Windows. I did install windows and first problem I encountered is Grub Menu wasn’t appearing and the system directly booted to Windows. I opted out to threads and found out how to enable grub menu.

But I still have problem because Grub is not appearing automatically after boot. I need to go to Boot Device Options (It has three entries OS boot manager, manjaro xxxx , Boot from EFI file). When I click manjaro option only then grub menu appears.

I think OS boot manager is taking priority over manjaro xxx option because when I click OS boot manager windows open by default. Or, maybe Grub isn’t my default OS boot manager.

Please help me.

(Edit : I have Manjaro installed in UEFI mode and so is Windows)

Follow this guide…take notice of the checklist in the beginning and all the way down there is an explanation as to why you boot into windows and how to resolve this.

Try reinstalling GRUB, like so… :arrow_down:

sudo grub-install --recheck --no-rs-codes --modules="part_gpt part_msdos" --efi-directory="/boot/efi" --target="x86_64-efi"
sudo update-grub

I guess we have some error in command. I got this reply.

grub-install: unrecognized option '--platform=x86_64-efi'
Try 'grub-install --help' or 'grub-install --usage' for more information.

Also I found out something

When I run efibootmgr command I don’t see my BootCurrent Value in BootOrder. Is this something I must be addressing?

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 3003,3000,2001,2002,2003
Boot0000* manjaro
Boot0003* Windows Boot Manager
Boot2001* USB Drive (UEFI)
Boot2002* Internal CD/DVD ROM Drive (UEFI)
Boot3000* Internal Hard Disk or Solid State Disk
Boot3003* Internal Hard Disk or Solid State Disk

My bad, it was a momentary memory lapse. It should be --target="x86_64-efi". I have modified my post above now.

Yes, You should set it as the first item.

Also why is 2003 number listed in BootOrder.?The list clearly shows there is no such number.

I’m guessing MS-Glassware added that. :thinking:

The numbering is weird, though. On my system here ─ exclusively dedicated to Manjaro; I don’t do Windows ─ all entries start with “000”, and the only other entries beside the SSD are for removable devices.

I tried following command,

sudo efibootmgr -o 0000,3003,3000,2001,2002

The output showed that the order was changed. But when I rebooted (of course Windows booted again). I manually entered Manjaro and hit efibootmgr and saw that the bootorder doesn’t have 0000.

Please help me with adding the bootnumber.

Have you run the command to reinstall GRUB, as per my recommendation? That should normally add a menu item to the EFI boot manager.

You could even try adding the --bootloader-id="0000" option.

I did miss your post I guess. I am trying that now. Will let you know ASAP.

sudo grub-install --recheck --no-rs-codes --modules=“part_gpt part_msdos” --efi-directory="/boot/efi" --target=“x86_64-efi”

I had no success with this

Appending --bootloader=“0000” option seem to change name in boot option. Initially it wass manajaro xxxx now it is 0000 and no success either

What’s the output of… :arrow_down:

sudo efibootmgr -v

… ?

I think I got into trouble now. I was trying to change the name from 0000 to Manjaro. On doing that now my boot entry for Manjaro is gone. I can’t get into Manjaro. Could you help me?

Try this… :arrow_down:

sudo grub-install --recheck --modules="part_gpt part_msdos" --efi-directory="/boot/efi" --target="x86_64-efi" --bootloader-id="Manjaro"

Then, check the boot entries with… :arrow_down:

sudo efibootmgr -v

Once you know the number of the Manjaro boot option ─ let’s assume it is “0000”, but change this in the command below if required ─ you could try this… :arrow_down:

sudo efibootmgr  -b 0000 -a
sudo efibootmgr -o 0000,<your-other-entries-here>

Should I do this from Manjaro Live USB CD? Because I cannot get into Manjaro now. I only have access to Windows.

Yes. Boot up in live mode, and then issue… :arrow_down:

sudo su -

Next, issue… :arrow_down:

manjaro-chroot -a

… and hit 1. Then issue… :arrow_down:

grub-install --recheck --modules="part_gpt part_msdos" --efi-directory="/boot/efi" --target="x86_64-efi" --bootloader-id="Manjaro"

Then, check the boot entries with… :arrow_down:

efibootmgr -v

Once you know the number of the Manjaro boot option ─ let’s assume it is “0000”, but change this in the command below if required ─ you could try this… :arrow_down:

efibootmgr -b 0000 -a
efibootmgr -o 0000,<your-other-entries-here>

Sure, I will let you know with the results

Wow, got my bootfile back and I’m in Manjaro once again.

Posting output of efibootmgr -v

BootCurrent: 0001
Timeout: 0 seconds
BootOrder: 3003,3001,2001,2002,2003
Boot0001* Manjaro       HD(1,GPT,40811db9-6242-4be3-bf29-63dcbc0233d2,0x800,0x104000)/File(\EFI\Manjaro\grubx64.efi)
Boot0003* Windows Boot Manager  HD(1,GPT,40811db9-6242-4be3-bf29-63dcbc0233d2,0x800,0x104000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...M................
Boot2001* USB Drive (UEFI)      RC
Boot2002* Internal CD/DVD ROM Drive (UEFI)      RC
Boot3000* Internal Hard Disk or Solid State Disk        RC
Boot3001* Internal Hard Disk or Solid State Disk        RC
Boot3003* Internal Hard Disk or Solid State Disk        RC

Still Windows is booting directly and the original problem exists.

And why does Manjaro’s Boot Number always disappear after resart?? I am pretty sure I added Manjaro’s boot number before restart and efibootmgr also outputed Manjaro’s number in the bootorder.

All I can suggest is… :arrow_down:

sudo efibootmgr -o 0001,0003,2001,2002,3000,3001,3003

:man_shrugging:

I don’t know if this will be much of help but 3 hours earlier pamac pushed major update to my PC. It was Mikah what was installed originally. But it’s Nibya I guess. I mean to ask did fallback image create any trouble with the bootloader?