Dual boot grub menu Win11/Manjaro no longer shows up - Windows only login screen

Typing this on Manjaro after having to set BIOS to USB 1st option boot. The grub menu has worked for months, besides working last week. Windows did an update a couple of days ago.
This happened a year or so ago with Win10 and was fixed on windows with the following command: bcdedit /set {bootmgr} path \EFI\Manjaro\grubx64.efi
That did not work this time. I used my Manjaro USB to detect and then boot the grub64.efi option.
On Windows today I got the following:

PS C:\Windows\System32> bcdedit /enum ACTIVE

Windows Boot Manager
identifier              {bootmgr}
device                  partition=\Device\HarddiskVolume4
path                    \EFI\Manjaro\grub64.efi
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
resumeobject            {1c4833b0-86b4-11ec-a697-dc2b473cb879}
displayorder            {current}
toolsdisplayorder       {memdiag}
timeout                 30

Windows Boot Loader
identifier              {current}
device                  partition=C:
path                    \WINDOWS\system32\winload.efi
description             Windows 11
locale                  en-US
inherit                 {bootloadersettings}
recoverysequence        {1c4833b3-86b4-11ec-a697-dc2b473cb879}
displaymessageoverride  Recovery
recoveryenabled         Yes
testsigning             No
isolatedcontext         Yes
allowedinmemorysettings 0x15000075
osdevice                partition=C:
systemroot              \WINDOWS
resumeobject            {1c4833b0-86b4-11ec-a697-dc2b473cb879}
nx                      OptIn
bootmenupolicy          Standard
hypervisorlaunchtype    Auto
The "Windows Boot Manager" has {current} in the 'default' field.
The "Windows Boot Loader" has {current}  in the 'identifier' field.

The PC boots to the Windows login screen without the grub menu even showing up. I don’t know how to get the grub menu to show up automatically like it should. Anyone have any pointers please?

Not sure why bcdedit didn’t work (I’m no longer on Win much),
but this should work from manjaro terminal:

List boot order


find the ‘manjaro’ id-number (0000 0001 etc.)

and if it isn’t the first (in the order list under the BootOrder) then re-order things to put manjaro first (e.g. if manjaro is 0001 and win ‘0000’), something like…

sudo efibootmgr -o 0001,0000 # (smallcaps 'o')

This is only an example,
You need to read and inform yourself about how this works and replace the actual numbers with what’s on your system.

For more details and formatting

man efibootmgr

Probably Win11 just decides for you that it should boot first, therefore it has changed the boot priority, :man_shrugging:

dragan and megavolt,
Returning on the morrow

After a Windows update, Win11 loads \WINDOWS\system32\winload.efi with the single OS choice as Windows. Before the update, Win 11 loaded \EFI\grub\grubx64.efi upon boot, and I had two choices of either starting Manjaro Linux or Win11. I tried to fix the booloader in linux Manjaro. I’m sorry I didn’t get a copy of the original working dual-boot bootloader configuration; and when I tried to fix/revert the single bootloader change that Windows put on my system, I further apologize that I didn’t keep track of my terminal commands using efibootmgr. At least my editing with linux’s efibootmgr didn’t cause the system crash, although it still only boots to Windows. I did notice extra bootloader entries after my efibootmgr editing, like ‘inherit’, ‘resumeobject’, ‘displaymessageoverride’ etc., but I’m not sure if those entries were pre-existing, due to my edit, or overridden by Windows 11 itself after my edit. At least I can still use my Manjaro USB stick, wait two minutes for it to detect bootloaders, and then I can choose the grubx64.efi option to boot into Manjaro.
I’ve combined as much information from both Windows and Manjaro as I could. These details with pictures are in a Libre Office file called “bcdedit - efibootmgr.odt”. It is downloadable from my free Mega.nz cloud account. You do not have to sign up for a Mega account, nor do you need to give any information. The download link is here.

If you’re interested in helping me, please see the details contained in this file.

@namitutonka Wiki needs more actual information - #8 by GeorgeB but I don’t seem to find the original full tutorial (article written by gohlip) in the ‘archived’ forum section. All links pointing to it are 404s. You can ask the moderators about it.

The most problems occur when Windows and Manjaro share one efi partition. Create another efi partition, replace it with the current partition in Manjaro, and reinstall grub completely.

I will search around and educate myself on how to do as you suggest.
Thanks megavolt

I didn’t need to use bcdedit in Windows nor efibootmanager in Manjaro. I had to disable secure boot in my PC’s BIOS.

Phew, what an unnecessary runaround!

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.