Dual Boot: Boot error

  Kernel: 5.9.16-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 10.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64
    root=UUID=078e24b2-846f-4627-ba86-08ac5dcb55a5 ro quiet
    root=/dev/mapper/luks-3ef5d5a5-7e9f-412e-b0fa-a9c8625930c0 splash
    apparmor=1 security=apparmor
    resume=UUID=97f9ff6f-27bf-448f-9544-8744a7ad79e7 udev.log_priority=3
  Desktop: GNOME v: 43.2 tk: GTK v: 3.24.36 wm: gnome-shell dm: GDM v: 43.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 15 9570 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0JVFJ2 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.20.0 date: 06/07/2021
  ID-1: BAT0 charge: 55.3 Wh (94.0%) condition: 58.8/97.0 Wh (60.6%)
    volts: 12.4 min: 11.4 model: SMP DELL GPM0365 type: Li-ion serial: <filter>
    status: discharging
  RAM: total: 30.99 GiB used: 3.17 GiB (10.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i5-8300H bits: 64 type: MT MCP arch: Coffee Lake
    gen: core 8 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 800 min/max: 800/4000 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 36812
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp
    rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
    driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
    ports: active: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0
    chip-ID: 8086:3e9b class-ID: 0300
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Dell
    driver: nouveau v: kernel non-free: 525.xx+ status: current (as of 2022-12)
    arch: Pascal code: GP10x process: TSMC 16nm built: 2016-21 pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0
    chip-ID: 10de:1c8d class-ID: 0302 temp: 34.0 C
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-12:4 chip-ID: 0c45:671d class-ID: 0e02
  Display: wayland server: X.org v: with: Xwayland v: 22.1.7
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: iris,nouveau gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: Sharp 0x149a built: 2018 res: 1920x1080 dpi: 142
    gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5") ratio: 16:9
    modes: 1920x1080
  API: EGL/GBM Message: No known Wayland EGL/GBM data sources.
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Sound API: ALSA v: k5.9.16-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Rivet Networks Killer Wireless-n/a/ac 1535 driver: ath10k_pci
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 3b:00.0
    chip-ID: 168c:003e class-ID: 0280 temp: 42.0 C
  IF: wlp59s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb
    v: 0.8 bus-ID: 1-4:2 chip-ID: 0cf3:e300 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-3ef5d5a5-7e9f-412e-b0fa-a9c8625930c0 maj-min: 254:0
    type: LUKS dm: dm-0 size: 24.41 GiB
  p-1: nvme0n1p9 maj-min: 259:9 size: 24.41 GiB
  Device-2: luks-df0c6b01-8f49-466a-b8ee-c16ee3407d03 maj-min: 254:1
    type: LUKS dm: dm-1 size: 31.68 GiB
  p-1: nvme0n1p10 maj-min: 259:10 size: 31.68 GiB
  Message: No RAID data found.
  Local Storage: total: 238.47 GiB used: 42.38 GiB (17.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: PM981 NVMe 256GB
    size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: EXD72D1Q temp: 27.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 24.41 GiB size: 23.9 GiB (97.92%) used: 17.43 GiB (72.9%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-3ef5d5a5-7e9f-412e-b0fa-a9c8625930c0 label: N/A
    uuid: 078e24b2-846f-4627-ba86-08ac5dcb55a5
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 508 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p7 maj-min: 259:7 label: N/A
    uuid: 9D5A-92DF
  ID-3: /home raw-size: 31.68 GiB size: 31.06 GiB (98.04%)
    used: 24.95 GiB (80.4%) fs: ext4 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-df0c6b01-8f49-466a-b8ee-c16ee3407d03 label: N/A
    uuid: 2c1ca6e5-daf7-4971-b438-ca4b3db62989
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p8 maj-min: 259:8 label: N/A
    uuid: 97f9ff6f-27bf-448f-9544-8744a7ad79e7
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 500 MiB fs: vfat label: ESP
    uuid: 1404-B4AC
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 128 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 167.22 GiB fs: bitlocker
    label: N/A uuid: N/A
  ID-4: /dev/nvme0n1p4 maj-min: 259:4 size: 990 MiB fs: ntfs
    label: WINRETOOLS uuid: 22B80C19B80BE9DD
  ID-5: /dev/nvme0n1p5 maj-min: 259:5 size: 10 GiB fs: ntfs label: Image
    uuid: 3CC60E59C60E1434
  ID-6: /dev/nvme0n1p6 maj-min: 259:6 size: 1.06 GiB fs: ntfs
    label: DELLSUPPORT uuid: D230105A301047BD
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Qualcomm Atheros QCA61x4 Bluetooth 4.0
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 0cf3:e300 class-ID: e001
  Device-2: 1-7:3 info: Shenzhen Goodix Fingerprint Reader
    type: Abstract (modem),CDC-Data driver: cdc_acm interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 27c6:5395 class-ID: 0a00
    serial: <filter>
  Device-3: 1-12:4 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:671d class-ID: 0e02
  Hub-2: 2-0:1 info: Super-speed hub ports: 10 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 38.0 C pch: 37.0 C mobo: N/A gpu: nouveau
    temp: 34.0 C
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  Processes: 276 Uptime: 1h 1m wakeups: 6530 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: 1703 pm: pacman pkgs: 1702 libs: 382 tools: gnome-software,pamac
  pm: rpm pkgs: 1 pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.24


interesting I’ll keep that in mind if other fixes won’t work.

what is this?:

thats a dead kernel for a very long time…
install a newer one the 5.15 lts for example, boot with it, and uninstall the 5.9
just to be sure post also output from:
mhwd-kernel -li

also you dont have any proper nvidia drivers installed:

so install them with:
sudo mhwd -a pci nonfree 0300
reboot and test if you have still issues with boot when running a proper kernel and proper video drivers

if it still happens, you can post logs from the failed boot:
journalctl -b-1 -p4 --no-pager

1 Like

Thanks, I’ll try and get back when I’m done!!

.oO :thinking: I’m a total noob! Where can I learn this stuff? Oo.

So I updated the kernel, restarted, removed the old one and than updated the graphicscard which worked, alhtough their were some warnings (like something may not be available).

Upon restarting (which hasn’t shown the old error 5 times out of 5) I however cannot enter manjaro anymore. Entering the correct password makes the login screen fade away and reappear.


(…reminding me of “Wild Magic” in Baldur’s Gate 2/ D&D :magic_wand: )

Writing from my Win partition

Dual boot with windows:

Switch from Windows - how to use GNU/Linux:

Please install 2 kernels (one of them LTS)

Gentle shut down a suddenly hanged PC to minimize a chance of getting a broken filesystem and data loss:


You may have to disable hibernation and fastboot in Windofs

You can find similar posts allover the forum :slight_smile: Please search for “ntfs” and fastboot

(Wisdom lies in reading :wink: ) :footprints:

1 Like

can you enter in the stuck screen into TTY: ctrl+alt+f2 or f1-f6 keys, enter your username, password, and enable early loading:
sudo nano /etc/mkinitcpio.conf
and edit the modules section to look like this:

MODULES=(i915 nvidia nvidia_drm nvidia_uvm nvidia_modeset)

save it with ctrl+x, press Y, and update it:
sudo mkinitcpio -P
systemctl reboot
and see if it helped

I hope it’s ok to post a photo of sudo mkinitcpio -P

( :thinking: Does the error hint at the old kernel that I removed?)

yes the kernel was not properly removed, there are some leftovers…
but first, did you rebooted after you edited the MODULES?
and do you boot normally now?

I did follow your instructions, so yes. The boot worked normally since your original fix. Approx. 10 out of 10 times, which indicates that it worked, though it’s not 100% verified. (Before the fix sometimes it worked oftentimes and then, time and again it didn’t. But I’m optimistic.)

so you still have issues with the 5.15 kernel and the proper nvidia drivers?
post output from:

ls /etc/mkinitcpio.d/*.preset
sudo ls /boot/initramfs-*
sudo ls /boot/vmlinuz-*
sudo ls /usr/lib/modules/*
head /etc/mkinitcpio.conf

requested outputs

ls /etc/mkinitcpio.d/*.preset
/etc/mkinitcpio.d/linux515.preset  /etc/mkinitcpio.d/linux59.preset
[manjaro-gnome ~]# sudo ls /boot/initramfs-*
/boot/initramfs-5.15-x86_64-fallback.img  /boot/initramfs-5.15-x86_64.img
[manjaro-gnome ~]# sudo ls /boot/vmlinuz-*
[manjaro-gnome ~]# sudo ls /usr/lib/modules/*
extramodules	   modules.builtin.alias.bin  modules.order
kernel		   modules.builtin.bin	      modules.softdep
kernelbase	   modules.builtin.modinfo    modules.symbols
modules.alias	   modules.dep		      modules.symbols.bin
modules.alias.bin  modules.dep.bin	      pkgbase
modules.builtin    modules.devname	      vmlinuz

nvidia-drm.ko.xz      nvidia-peermem.ko.xz  nvidia.ko.xz
nvidia-modeset.ko.xz  nvidia-uvm.ko.xz	    version
[manjaro-gnome ~]# head /etc/mkinitcpio.conf
# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=(i915 nvidia nvidia_drm nvidia_uvm nvidia_modeset)

# This setting includes any additional binaries a given user may
[manjaro-gnome ~]# 

you can remove this:
sudo rm /etc/mkinitcpio.d/linux59.preset
sudo mkinitcpio -P && sudo update-grub

now add the ibt parameter:
sudo nano /etc/default/grub
and inside this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
dont remove anything, just add it to existing parameters, save the file with ctrl+x, press Y, update grub:
sudo update-grub

now install the 61 kernel:
sudo mhwd-kernel -i linux61
reboot and boot with it and see how it works with it

I did everything you proposed and afterwards the problem unfortunately remains.

(I placed the ibt=off at the end of that line (inside the quotes).)

so the previous one was the failed one? if yes provide logs:
journalctl -b-1 -p4 --no-pager

I meant that I’m still in a login loop after booting

but you say above that you are able to boot after you force shut down?

I don’t really understand.

Currently the computer boots regularly, but when I enter my password in the login screen, the screen shortly fades as if entering the desktop, but then the login prompt reappears

i mean this:

this is ‘fixed’. but now you can enter into desktop, after you type your password in the log in screen?

Yes this seems to be fixed. (Re)booting now seems to work without the original problem

And I cannot enter the desktop. The login prompt just keeps reappearing when I enter the correct password