Dual Boot: Boot error

Thanks, I’ll try and get back when I’m done!!

.oO :thinking: I’m a total noob! Where can I learn this stuff? Oo.

So I updated the kernel, restarted, removed the old one and than updated the graphicscard which worked, alhtough their were some warnings (like something may not be available).

Upon restarting (which hasn’t shown the old error 5 times out of 5) I however cannot enter manjaro anymore. Entering the correct password makes the login screen fade away and reappear.


(…reminding me of “Wild Magic” in Baldur’s Gate 2/ D&D :magic_wand: )

Writing from my Win partition

Dual boot with windows:

Switch from Windows - how to use GNU/Linux:

Please install 2 kernels (one of them LTS)

Gentle shut down a suddenly hanged PC to minimize a chance of getting a broken filesystem and data loss:


You may have to disable hibernation and fastboot in Windofs

You can find similar posts allover the forum :slight_smile: Please search for “ntfs” and fastboot

(Wisdom lies in reading :wink: ) :footprints:

1 Like

can you enter in the stuck screen into TTY: ctrl+alt+f2 or f1-f6 keys, enter your username, password, and enable early loading:
sudo nano /etc/mkinitcpio.conf
and edit the modules section to look like this:

MODULES=(i915 nvidia nvidia_drm nvidia_uvm nvidia_modeset)

save it with ctrl+x, press Y, and update it:
sudo mkinitcpio -P
systemctl reboot
and see if it helped

I hope it’s ok to post a photo of sudo mkinitcpio -P

( :thinking: Does the error hint at the old kernel that I removed?)

yes the kernel was not properly removed, there are some leftovers…
but first, did you rebooted after you edited the MODULES?
and do you boot normally now?

I did follow your instructions, so yes. The boot worked normally since your original fix. Approx. 10 out of 10 times, which indicates that it worked, though it’s not 100% verified. (Before the fix sometimes it worked oftentimes and then, time and again it didn’t. But I’m optimistic.)

so you still have issues with the 5.15 kernel and the proper nvidia drivers?
post output from:

ls /etc/mkinitcpio.d/*.preset
sudo ls /boot/initramfs-*
sudo ls /boot/vmlinuz-*
sudo ls /usr/lib/modules/*
head /etc/mkinitcpio.conf

requested outputs

ls /etc/mkinitcpio.d/*.preset
/etc/mkinitcpio.d/linux515.preset  /etc/mkinitcpio.d/linux59.preset
[manjaro-gnome ~]# sudo ls /boot/initramfs-*
/boot/initramfs-5.15-x86_64-fallback.img  /boot/initramfs-5.15-x86_64.img
[manjaro-gnome ~]# sudo ls /boot/vmlinuz-*
[manjaro-gnome ~]# sudo ls /usr/lib/modules/*
extramodules	   modules.builtin.alias.bin  modules.order
kernel		   modules.builtin.bin	      modules.softdep
kernelbase	   modules.builtin.modinfo    modules.symbols
modules.alias	   modules.dep		      modules.symbols.bin
modules.alias.bin  modules.dep.bin	      pkgbase
modules.builtin    modules.devname	      vmlinuz

nvidia-drm.ko.xz      nvidia-peermem.ko.xz  nvidia.ko.xz
nvidia-modeset.ko.xz  nvidia-uvm.ko.xz	    version
[manjaro-gnome ~]# head /etc/mkinitcpio.conf
# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=(i915 nvidia nvidia_drm nvidia_uvm nvidia_modeset)

# This setting includes any additional binaries a given user may
[manjaro-gnome ~]# 

you can remove this:
sudo rm /etc/mkinitcpio.d/linux59.preset
sudo mkinitcpio -P && sudo update-grub

now add the ibt parameter:
sudo nano /etc/default/grub
and inside this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
dont remove anything, just add it to existing parameters, save the file with ctrl+x, press Y, update grub:
sudo update-grub

now install the 61 kernel:
sudo mhwd-kernel -i linux61
reboot and boot with it and see how it works with it

I did everything you proposed and afterwards the problem unfortunately remains.

(I placed the ibt=off at the end of that line (inside the quotes).)

so the previous one was the failed one? if yes provide logs:
journalctl -b-1 -p4 --no-pager

I meant that I’m still in a login loop after booting

but you say above that you are able to boot after you force shut down?

I don’t really understand.

Currently the computer boots regularly, but when I enter my password in the login screen, the screen shortly fades as if entering the desktop, but then the login prompt reappears

i mean this:

this is ‘fixed’. but now you can enter into desktop, after you type your password in the log in screen?

Yes this seems to be fixed. (Re)booting now seems to work without the original problem

And I cannot enter the desktop. The login prompt just keeps reappearing when I enter the correct password

i see, so in the log in screen select xorg or x11 in the log in screen settings, and try if it works with it

The only things I can choose between in the login screen is gnome and gnome classic.

Also my laptop froze two times during boot when using the 61 kernel.
The 515 kernel seems to boot normally.

I could not login on either kernel or settings :frowning:

you are on wayland, so that could be the cause for not being able to login…
post picture of the login screen;
or try login with all settings, if it doesnt work, enter into TTY, and post picture of:
mhwd -l -li
ls /etc/modprobe.d
find /etc/X11/ -name "*.conf"