Dropbox and key problems

The goal is to pick old files from Dropbox to use them in Manjaro.
Installing from Pamac failed, leading to problem with keys.

During the install process the command ”makepkg -Si” (from How to Install Dropbox on Manjaro Linux – Linux Hint) resulted in

” dropbox-lnx.x86-74.4.115.tar.gz … failed (unknown public key FC918B335044912E)
dropbox-lnx.x86_64-74.4.115.tar.gz … failed (unknown public key FC918B335044912E)
==> Error: one or more PGP-signatures could not be verified!”

From the Pacman troubleshooting - Manjaro Linux I tried to remove keys ”sudo rm -r /etc/pacman.d/gnupg”. Reinstalling the keyrings ”sudo pacman -Sy gnupg archlinux-keyring manjaro-keyring” lead to

”(3/3) Controlling the keys in the keyring [###########################################] 100%
WARNING: Public keyring not found; have you run ‘pacman-key –init’?
Error: Required key missing from keyring
Error: Could not start the transaction. (unsuspected error)
Error, no packets upgraded.”

Running 'pacman-key –init’ didn’t help.

From [Manjaro 15.12]error: key "####################" could not be looked up remotely I edited /etc/pacman.conf changing “SigLevel” from “Required DatabaseOptional” to “Never” but a new attempt to install the keyrings failed (changed /etc/pacman.conf back to its original).

I have messed it all up and don’t know how to proceed. I hope to get guidance on how to declutter my system (if needed) and make a fresh install of Dropbox.
Thank you!

When creating this topic I got a hint from “Your topic is similar to …” that “Manjaro Linux Forum” could present a solution. Following the recommendations however gave the result:

[lars@lars-pc ~]$ sudo pacman-key --refresh-keys -u --keyserver hkps.pool.sks-keyservers.net
gpg: refreshing 1 key from hkp://hkps.pool.sks-keyservers.net
gpg: updating of a key from a keyserver failed: No data
==> Error: A  local key could not be updated from the keyserver
[lars@lars-pc ~]$ 

Inxi -Fxza info:

[lars@lars-pc ~]$ inxi -Fxza
  Kernel: 4.19.138-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 
  root=UUID=3aff4f56-ceff-40d6-958f-4431518a1485 rw quiet 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: LENOVO product: 10126 v: Lenovo H515s 
  serial: <filter> 
  Mobo: LENOVO model: Kabini CRB v: 31900058 STD serial: <filter> 
  UEFI: LENOVO v: I9KT36AUS date: 11/04/2013 
  Topology: Dual Core model: AMD E1-2500 APU with Radeon HD Graphics 
  bits: 64 type: MCP arch: Jaguar family: 16 (22) model-id: N/A stepping: 1 
  microcode: 700010F L2 cache: 1024 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 5599 
  Speed: 800 MHz min/max: 800/1400 MHz Core speeds (MHz): 1: 800 2: 800 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Kabini [Radeon HD 8240 / R3 Series] vendor: Lenovo 
  driver: radeon v: kernel bus ID: 00:01.0 chip ID: 1002:9838 
  Display: x11 server: X.Org 1.20.8 driver: ati,radeon unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 338x270mm (13.3x10.6") 
  s-diag: 433mm (17") 
  Monitor-1: VGA-0 res: 1280x1024 hz: 60 dpi: 96 
  size: 337x270mm (13.3x10.6") diag: 432mm (17") 
  OpenGL: renderer: AMD KABINI (DRM 2.50.0 4.19.138-1-MANJARO LLVM 10.0.1) 
  v: 4.5 Mesa 20.1.5 direct render: Yes 
  Device-1: AMD Kabini HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:01.1 chip ID: 1002:9840 
  Device-2: AMD FCH Azalia vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1022:780d 
  Sound Server: ALSA v: k4.19.138-1-MANJARO 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo 
  driver: r8169 v: kernel port: e000 bus ID: 01:00.0 chip ID: 10ec:8136 
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8188EE Wireless Network Adapter vendor: Lenovo 
  driver: rtl8188ee v: kernel port: d000 bus ID: 02:00.0 chip ID: 10ec:8179 
  IF: wlp2s0 state: down mac: <filter> 
  Local Storage: total: 465.76 GiB used: 33.13 GiB (7.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Western Digital model: WD5000AAKX-08U6AA0 
  size: 465.76 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1H19 scheme: GPT 
  ID-1: / raw size: 143.98 GiB size: 140.72 GiB (97.74%) 
  used: 33.13 GiB (23.5%) fs: ext4 dev: /dev/sda9 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 2.00 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/sda8 
  System Temperatures: cpu: 47.1 C mobo: N/A gpu: radeon temp: 47 C 
  Fan Speeds (RPM): N/A 
  Processes: 143 Uptime: 7m Memory: 3.31 GiB used: 1.08 GiB (32.6%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: pacman: 1344 
  lib: 419 flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal 
  inxi: 3.1.05 
[lars@lars-pc ~]$	

Sorry! I Thought that the copy from the mentioned hint was OK!
It is about a post from Jan Alexander Steffens: New install fails to update, invalid keys.

I couldn’t get dropbox installed myself so ended up biting the bullet and used the flatpak version

Thank you sawdoctor!
Glad that you fixed it.
I never heard of flatpak before but found out that flatpak 1.8.1-1 is installed in my system. So now my next challenge is to start using it.

You need to the Dropbox gpg key, not mess with system keys

If you pamac to build the aur package will ask to add the without much hassle

pamac build dropbox

Or you can add the manually


Thanks, Lolix!
I don’t remember how I tried to use pamac for the install but probably not with that command.
Before running the “pamac build dropbox” I suppose the old Dropbox should be uninstalled? Anything else to rinse?

No, not needed. Also AFAIK dropbox is self-updating in the home user folder

OK, thank you! Give it a try!

Unfortunately the result was the same as before “unknown public key FC918B335044912E”.
Next will be to dive into the DNS-jungle (which I am completely unknowing of). Hoever, following the steps in the link seems possible.

Following the different steps in the link above reveales:

[lars@lars-pc ~]$ gpg --recv-key --keyserver http://pgp.key-server.io FC918B335044912E
gpg: hittade ingen giltig OpenPGP-data.
gpg: Totalt antal behandlade enheter: 0
[lars@lars-pc ~]$
[lars@lars-pc ~]$ nmcli dev show | grep DNS
[lars@lars-pc ~]$ cat /etc/resolv.conf

Generated by NetworkManager

[lars@lars-pc ~]$

I don’t know if the DNS and nameserver is of any help.

Using gpg --recv-keys 1C61A2656FB57B7E4DE0F4C1FC918B335044912E failed for me too, while downloading the .asc worked

wget https://linux.dropbox.com/fedora/rpm-public-key.asc
gpg --import rpm-public-key.asc
1 Like

[lars@lars-pc ~]$ wget https://linux.dropbox.com/fedora/rpm-public-key.asc
–2020-08-19 16:26:26-- https://linux.dropbox.com/fedora/rpm-public-key.asc
Läste in CA-certifikatet ”/etc/ssl/certs/ca-certificates.crt”
Slår upp linux.dropbox.com (linux.dropbox.com)…,,, …
Ansluter till linux.dropbox.com (linux.dropbox.com)||:443… ansluten.
HTTP-begäran skickad, väntar på svar… 200 OK
Längd: 975 [application/octet-stream]
Sparar till: “rpm-public-key.asc”

rpm-public-key.asc 100%[=======================>] 975 --.-KB/s om 0s

2020-08-19 16:26:27 (6,28 MB/s) - “rpm-public-key.asc” sparades [975/975]

[lars@lars-pc ~]$ gpg --import rpm-public-key.asc
gpg: nyckel FC918B335044912E: publika nyckeln “Dropbox Automatic Signing Key linux@dropbox.com” importerades
gpg: Totalt antal behandlade enheter: 1
gpg: importerade: 1
[lars@lars-pc ~]$

Is it now possible to start over with “pamac build dropbox”??

Yes, you can retry now

-> Skapar .PKGINFO fil…
-> Skapar .BUILDINFO fil…
-> Genererar .MTREE-fil…
-> Komprimerar paket…
==> Lämnar fakeroot miljö.
==> Kompilering klar: dropbox 102.4.431-1 (ons 19 aug 2020 16:38:10)
==> Städar upp…

Kontrollerar nyckelring… [1/1]
Kontrollerar integritet… [1/1]
Laddar paketfiler… [1/1]
Kontrollerar konflikter… [1/1]
Kontrollerar tillgängligt diskutrymme… [1/1]
Installerar dropbox (102.4.431-1)… [1/1]
Kör transaktionsefterarbeten…
Reloading system manager configuration… [1/3]
Arming ConditionNeedsUpdate… [2/3]
Updating the desktop file MIME type cache… [3/3]
Överföring lyckades.
[lars@lars-pc ~]$

Translation of the above says that everything went OK, the istall has succeeded!
I am enormously impressed - thank you!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.