Driver for Archer T3U no more in AUR repo

Hi Community

Please, how to install the driver for TP-Link Archer T3U on my HP dv7/Manjaro-Kde 4.19

Thanks at lot

philline00 - Basic User

Hello @Philline00 :wink:

More information please:

inxi -Nazy

Could be probably this driver:

pamac build rtl8822bu-dkms-git

Also keep sure the kernel-headers of your kernel are installed.

[philline0@philline0-hplx ~]$ pamac install rtl8822bu-dkms-git
Erreur: impossible de trouver la cible : rtl8822bu-dkms-git
translated : target not found
[philline0@philline0-hplx ~]$ inxi Nazy
Error 22: Unsupported option: Nazy

Sorry, typo @Philline00

Corrected:

Maybe you have to enable AUR in pamac-manager…

Check if the headers are installed:

pamac list --installed | egrep "linux[0-9]{2,3}-headers"

1/dkms installed from basic repo …
2/tried again to build rtl 8822bu…
==> Unable to install module rtl8822bu/20180723 for kernel 4.19.160-1-MANJARO: Missing kernel headers.
3/ ```
pamac list --installed | egrep “linux[0-9]{2,3}-headers”
No answer …

Thats because no headers are installed.

Check with

uname -r

which kernel you are running.

Then if for example you are running kernel 4.19, then install:

pamac install linux419-headers

side note: you need to install kernel headers for all the kernels installed; not only for the one running

DKMS: install completed.
Exécution des crochets de post-transaction…
Arming ConditionNeedsUpdate… [1/2]
Install DKMS modules [2/2]
==> dkms install --no-depmod -m rtl8822bu -v 20180723 -k 4.19.160-1-MANJARO
==> depmod 4.19.160-1-MANJARO
Transaction terminée avec succès.
[philline0@philline0-hplx ~]$

TP-link is well running … Thanks a lot.
Thanks because its running and more because you learn me … with patience.
Sometime I was in panics … you taken time.thanks again.
Happy evening

1 Like

Lolix, Thanks for your reply.

TP-link is running from 4 minutes ago…
I’m happy.
I shall it replay on my tower … 8 cores FX 8350 - MSI 990 XFA. GPU GEf1660ventus.
Best evening.

In fact, I need TP-Link because I never be able to run my native Net card RT3090 of the HP Laptop.
I think i never have found the right driver.
If you can help me to retrieve it …

Network:
Device-1: Ralink RT3090 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard
driver: rt2800pci v: 2.3.0 port: 4000 bus ID: 02:00.0 chip ID: 1814:3090
IF: wlo1 state: down mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: 2000 bus ID: 03:00.0
chip ID: 10ec:8168
IF: enp3s0 state: down mac:
Device-3: TP-Link Archer T3U [Realtek RTL8812BU] type: USB driver: rtl88x2bu
bus ID: 1-1.2:6 chip ID: 2357:012d serial:
IF: wlp0s26u1u2 state: down mac:
Device-4: Ralink Motorola BC4 Bluetooth 3.0+HS Adapter type: USB
driver: btusb bus ID: 1-1.3:4 chip ID: 148f:1000
Device-5: Guillemot Hercules HWNUp-150 802.11n Wireless N Pico [Realtek
RTL8188CUS]
type: USB driver: rtl8192cu bus ID: 2-1.1:3 chip ID: 06f8:e033
serial:
IF: wlp0s29u1u1 state: up mac:
[philline0@philline0-hplx ~]$

From what i see in

modinfo rt2800pci

there is only one parameter:

nohwcrypt:Disable hardware encryption. (bool)

Could be possible, that there are issues with the hardware encryption on some cards. This parameter will disable hardware encryption and enable software encryption.

Create and open a file:

sudo nano /etc/modprobe.d/rt2800pci.conf

and put this into it:

options rt2800pci nohwcrypt=1

Save it with CTRL+S and close it with CTRL+X

Then reboot your laptop.

Also let me say, that this driver is working out-of-the-box. That means it is baked into the kernel. Newer kernel, have newer versions of this driver and therefore probably a better support the chipset of your card. A kernel upgrade could solve this issue.

https://wiki.manjaro.org/index.php/Manjaro_Kernels

1/ found in my distro
/etc/modprobe.d
please
2/ how create nano /etc /modprobe.d/ i will be able to modify a file under kate …

sudo kate /etc/modprobe.d/rt2800pci.conf

I done … without sudo for kate …
but
dont found any nano under etc …but modprob.d with the your options now is directly under
/etc/modprob.d/ files
file1:blacklist rtl8xxxu.conf
file 2 rt2800pci.conf with one line, “options rt2800pci nohwcrypt=1”
Card detected …; wifi inactive.

inxi
Network: Device-1: Ralink RT3090 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard driver: rt2800pci v: 2.3.0 port: 4000
bus ID: 02:00.0 chip ID: 1814:3090
IF: wlo1 state: down mac: 46:c5:4e:b1:80:1b
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
port: 2000 bus ID: 03:00.0 chip ID: 10ec:8168
IF: enp3s0 state: down mac: 64:31:50:55:d3:09
Device-3: Ralink Motorola BC4 Bluetooth 3.0+HS Adapter type: USB driver: btusb bus ID: 1-1.3:4 chip ID: 148f:1000
Device-4: Guillemot Hercules HWNUp-150 802.11n Wireless N Pico [Realtek RTL8188CUS] type: USB driver: rtl8192cu
bus ID: 2-1.1:3 chip ID: 06f8:e033 serial: 00e04c000001
IF: wlp0s29u1u1 state: up mac: 00:08:d3:96:89:f4
IP v4: 192.168.1.19/24 type: dynamic noprefixroute scope: global broadcast: 192.168.1.255
IP v6: 2a01:cb14:8614:7300:fb6e:8c21:392f:c451/64 type: dynamic noprefixroute scope: global
IP v6: fe80::eb6d:55b8:4a01:16a8/64 type: noprefixroute scope: link
WAN IP: 92.171.218.102
Sensors: System Temperatures: cpu: 56.0 C mobo: N/A gpu: radeon temp: 61.5 C
Fan Speeds (RPM): N/A

Please … I shall leave you … Christmas time is from now …
Ill come back one next day
Best evening as you want
philline00 :cup_with_straw:

nano is the editor. install it: pamac install nano

I see you have a second wifi device:

Really sure it is not active?

LANG=C nmcli

Merry Christmas :christmas_tree:

Wifi activated trough a TP-Link Archer dongle …
I keep out Hercules dongle.

[philline0@philline0-hplx ~]$ inxi -nazi
Network: Device-1: Ralink RT3090 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard driver: rt2800pci v: 2.3.0 port: 4000
bus ID: 02:00.0 chip ID: 1814:3090
IF: wlo1 state: down mac:
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 v: kernel
port: 2000 bus ID: 03:00.0 chip ID: 10ec:8168
IF: enp3s0 state: down mac:
Device-3: Ralink Motorola BC4 Bluetooth 3.0+HS Adapter type: USB driver: btusb bus ID: 1-1.3:4 chip ID: 148f:1000
Device-4: TP-Link Archer T3U [Realtek RTL8812BU] type: USB driver: rtl88x2bu bus ID: 2-1.1:3 chip ID: 2357:012d
serial:
IF: wlp0s29u1u1 state: up mac:
IP v4: type: dynamic noprefixroute scope: global broadcast:
IP v6: type: dynamic noprefixroute scope: global
IP v6: type: noprefixroute scope: link
WAN IP:
[philline0@philline0-hplx ~]$

[philline0@philline0-hplx ~]$ LANG=C nmcli
wlp0s29u1u1: connected to Livebox-93E0
“TP-Link Archer T3U”
wifi (rtl88x2bu), D0:37:45:4B:08:26, hw, mtu 1500
ip4 default, ip6 default
inet4 192.168.1.20/24
route4 0.0.0.0/0
route4 192.168.1.0/24
inet6 2a01:cb14:8614:7300:fb6e:8c21:392f:c451/64
inet6 fe80::eb6d:55b8:4a01:16a8/64
route6 2a01:cb14:8614:7300::/64
route6 ::/0
route6 fe80::/64
route6 ff00::/8

wlo1: disconnected
“Ralink RT3090 1T/1R”
1 connection available
wifi (rt2800pci), CA:D6:08:59:5A:35, hw, mtu 1500

p2p-dev-wlp0s29u1u1: disconnected
“p2p-dev-wlp0s29u1u1”
wifi-p2p, hw

enp3s0: unavailable
“Realtek RTL8111/8168/8411”
ethernet (r8169), 64:31:50:55:D3:09, hw, mtu 1500

lo: unmanaged
“lo”
loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
servers: 192.168.1.1
domains: home
interface: wlp0s29u1u1

    servers: 2a01:cb14:8614:7300:6eba:b8ff:febe:93e0 fe80::6eba:b8ff:febe:93e0
    domains: home
    interface: wlp0s29u1u1

Use “nmcli device show” to get complete information about known devices and
“nmcli connection show” to get an overview on active connection profiles.

Consult nmcli(1) and nmcli-examples(7) manual pages for complete usage details.
lines 1-44

So wifi dongle is active.

But your internal wifi card is also available. You should be able to connect with it.

Unplug the wifi dongle and start nmtui in a terminal. That should work at least. nmtui is a easy terminal gui for the NetworkManager. Maybe there is an issue with the KDE NetworkManager?

After trying … dongle unplugged
I translate the frame of nmtui answer after selection of the right livebox and setting the well code: "Activation rejected - wifi-network not found "

It seems Wifi card is detected but wifi network is not found ??? the situation get no change from I mounted MJO-KDE first time. I tried 2 years ago to reinstall W7 where i come from … but no more results. and I forgotten W7 definitively …

@Philline00 That is really strange… could send a journal log?

journalctl -b0 -u NetworkManager --no-hostname | curl -F'file=@-' https://0x0.st

Please post the link here.

[philline0@philline0-hplx ~]$ journalctl -b0 -u NetworkManager --no-hostname | curl -F’file=@-’ https://0x0.st
https://0x0.st/iC5E.txt

???