Downgrading a package and its dependencies from the pacman cache

After a full-system upgrade, my Pipewire sound stopped working properly (it seems like the server dies every now and then and I have to go into pavucontrol and “turn it off and on again”). I tried downgrading it to the older version that’s in my cache, but of course it requires its dependencies to be downgraded as well. I successfully managed to downgrade some using this command from the Arch wiki page on downgrading:

pacman -U file:///var/cache/pacman/pkg/package-old_version.pkg.tar.type

but others throw an error because downgrading them would break the dependency to the currently-installed version of pipewire - which I want to downgrade anyway!

So, how can I simultaneously downgrade a package and all of its dependencies in sync, assuming that all the older versions are still in my cache, without getting into issues with breaking version dependencies?

Downgrading packages isn’t recommended as you know but I use the downgrade command /package. It will list all available versions and let you choose the one you want

This is generally not possible.

pacman -U /var/cache/pacman/pkg/old-package.tar.zst --overwrite="*"

Most likely, this will break your system, and then you get to keep all the pieces, because that’s a partial-upgrade scenario, and Manjaro does not support that.


The audio issue sounds similar to issues reported by other PipeWire and PulseAudio users after latest updates to stable branch

List them all in a single command. Alternatively you can use -d flag, but double check that you actually list whole bundle of packages that depend on eachother.

Yes I figured this would be a wider issue, it was just a good opportunity to learn what the recommended way was for rolling back a specific package and its dependencies without running into dependency hell.

Updating to v6.0 kernel, as is recommended in those posts, broke my system on boot sequence and it’s now getting stuck on the black screen with a single underscore.

I reverted back to v5.15 for now as I need my computer to be operational and do not have the time to troubleshoot yet. This is a <2yo laptop from a mainstream manufacturer, so it’s probably not a matter of old or incompatible hardware.

I’ve managed to downgrade Pipewire and its dependencies by listing all the packages together as @zbe mentioned, with the addition that I had to add a link to the correct version of libcamera in the Arch package archive because, for some strange reason, it wasn’t in my cache.

It was the full upgrade that broke my system (sound not working), and following the recommended advice in forum threads of people with a similar problem and upgrading to kernel v6.0 broke it even worse (stuck on black screen during boot sequence) - the partial upgrade is the only thing that worked in this case.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.