Double click to open

Trying to open my shortcut to Steam on my desktop and I realize I can’t open it. I kept trying to double click as always but could do nothing but select it. So I try to search for an answer online and find under system settings/ workspace behavior/ general behavior there’s supposed to be an option for double click to open or single click to open but my only options are clicking files and folders 1. opens them or 2. selects them… why is there no option to double click?

Hi @inertiacreep,

Here is a screenshot of my mouse settings, I also use double-click to open. Maybe this helps you:

Your option 2 allows for double clicking to open (single click to select).

I was going to add a screenshot but @Mirdarthos beat me to it.

thanks… i really don’t know why it wasn’t working before

Well, as far as I know, no-one’s dead, so it’s all good!

ok no… there’s something wrong. I have to do this every time I restart my PC… can click icons on my desktop 100 times and they won’t open until I go into system settings and apply “opens them” and then back and apply “selects them”

I removed the solution, then.

But yeah, I must agree, something feels a bit…off…as if any personalisations (I’m talking about Firefox specifically) does not persist after a reboot. Up until now I thought it was Firefox, but it seems it’s wider.

I’ll open a new thread about it.

I’m am currently experience the exact same issue. Any desktop icon I try to execute with a double click. If I try to do this in dolphin in desktop it works. Very strange as the problem seems intermittent. Really looking for a fix.