Dolphin search not working as I expect


It’s a bit strange why search function isn’t working out of the box as expected. My system is very fresh, installed less then two weeks.

I have one Had Disk (NTFS) mounted in the /home/“user”/HDD-DATA-2T
The same is happening in a different Hard Disk (EXT4)

and as you can see in the image, there is a file called: SAC Tigre.txt

If i try to find this file from Dolphin search from that folder, the result is 0 using the expression Tigre . But if I open Kfind and so it open a separate window, this app is able to find the results as I was expecting from Dolphin.

If I try to find the same file from Home folder, so Dolphin is able to show results as the Kfind.

Check if you have enabled file searching in System Settings. You may also have corrupted Baloo database, so rebuild it with:

balooctl disable
balooctl purge
balooctl enable

Hello Tomek,

As you can see in the System Settings, the search option is enabled. and and did nothing tha could corrupt balooctl, so this kind of situation is something were I see Linux has a lot do be improved compared to windows. Things are supposed to work after a fresh install.

Once Kfind was able to find the file, probably the index is working fine while the issue is probably linked to Dolphin, or they use different index?

I suppose balooctl is the index system, right?

No, baloo is only good if it’s restricted to /home and preferably avoiding stuff like /cache and /var directories…

I once decided to give it a go, adding my T4 (to index my media files) and it was a nightmare. Baloo is a good local search ONLY.

I agree with the OP. I put kfind in my Dolphin toolbar and never use Dolphin search… it’s rubbish.

ROFL ok, we’re both complete idiots.
TBH I just found out myself… pay close attention now.

It works very well - results appear quickly as I type, if I backspace the 2 and type 1, then all files starting wallhaven-1 appear.

Pay attention to the toolbar under the search…
Search is ‘filename’ and then ‘From Here’, not ‘Your Files’ right? :stuck_out_tongue: because it’s not in Your Files (meaning /Home), it’s on a HDD plugged in.

An interesting test for BALOO (which is different) is to use Krunner.

Here I opened two panes, one is in my /home the other in /mnt/T4
So there was a file on T4, baloo can’t see it, but starting to type the name of a file in /home (NOT hidden or in a hidden location) then it comes up in krunner.

This is even more weird.

The HHD plugged in is under Home folder, and in the search option it is selected “from here” so it should be able to search from that folder, so it means inside the HDD. I understand that from here means deeper you go in the folder structure it will search from that point and below but not upper. Probably like find function from terminal you indicate “from here” so this function will search for files or directories from that point and below but not upper.

But as you suggested, changing the option “from here” to “your files” the results work, see attached image.

It’s quite confusing if not a bug, KDE needs to improved this thing for sure.

For local files, use krunner…

Yeah, the good part of Linux is that users sometimes have more then one way to do something.

Using Krunner or Kfind allow me to find what I’m looking for, but don’t fix the issue with Dolphin.

Maybe a mate with more technical knowledge then me could report this for KDE.

There isn’t an issue, I don’t think your ‘Device’ is in the home folder, maybe it’s mounted as /user/run (temporary mount) and as such is not included in the ‘home’ category for indexing.
We wouldn’t want baloo trying to index everything plugged in.

Checking from two different places, the system indicated me that the “device” is plugged in the Home folder structure, see the images.

device: /dev/sde1

Image from KDE Patition manager

Image from Dolphin Folder properties

If it’s not an issue, the Dolphin should show a warning to the user indicating that the folder or device it is trying to search needs a different configuration or different application.

But using Dolphin as any file manager like Windows Explorer, and receiving 0 objects found from a search, looks like issue mainly because the system is pretty fresh, so it’s installed with all default options as planned by programmers.

Open Dolphin
Press ctrl+F to get search
type *jpg

You’ll see it is searching ‘YOUR FILES’ and not ‘FROM HERE’. All files located are in /home.

Now I can go to T4 (where I know I have a media folder with nested media folders). Trying to find 8 out of 10 cats, I press 8…
I get a listing of folders (/mnt/T3/T3-Server/TV/8 Out Of 10 Cats…)

‘Your files’ starts in /home and ‘search from here’ for specific locations… Okay.

So why is ‘Your FIles’ not including /home/HDD - I don’t know. My ‘File Search’ is set to include /home/ben - did you check yours?

If you want it included in Baloo search, then I’d include the path there… though I did this before and deleted it (system slowed down and spent too much time scanning once I extended it past the native SSD home installation).

I wouldn’t advise trying to index an NTFS disk.

Ty Ben,

Yeah, my search option includes Home/lordsansui so it should include everything under it.

Besides Dolphin is not working as I aspect, I’m going to let things with standard system configuration as defined by designer/programmer, It might be changed in future form KDE or Manjaro team, don’t know.

Going to use Kfind/krunner and search only from “top” home folder, those options are working properly.

This is the reason I use /mnt to be honest, I assumed anything plugged in under /home/ben would be included - and it was a headache when my 4TB media disk started getting indexed in the past, also once when I decided to add ‘hidden’ folders to the indexing - that was really crazy with many millions of files being indexed and never finishing… (with a Plex server running amongst other super spammy stuff).

I have the same problem that @lordsansui, with a similar usage scenario (HDD mounted under /run/media/user/labelofhdd, but with soft link from home directory /home/user/Cloud that point to that mount).
But curiosly, before the last Manjaro update, the search through baloo in Dolphin and selecting from top of the folder worked ok.
Now, only works if I do the search in Dolphin selecting the HDD mount point as the search source (from top), but if I access to /home/user/Cloud and lauch the search, it returns 0 results.
It seems like baloo (or Dolphin) doesnt want to cross the links :wink:

1 Like

I was about to create a new topic about this but I’ll just add to this thread.

Dolphin search has never worked for me, in fact it doesn’t work period. It seems I’m not alone in this.

I’ll report this bug eventually to kde.

If it’s about the search crashes, that’s already known. And the fix is coming.

Crashes? No crashes. The search in dolphin simply has never worked for me and continues to not work. Kfind works just fine on the other hand.

Well this is how it works for me - what have you done to break it? It uses baloo search, and is not intended to search for hidden stuff… though if that’s not what you want, also IN DOLPHIN there’s a ‘more search options’ arrow which can search via kfind. Both are ‘Dolphin Search’ tools.

What’s the bug? You really should try to offer more lucid information.

You should realise that baloo is not intended to cover mounted or hidden files… many people complain that it’s ‘broken’ because it can’t find stuff mounted…

If you edit search to include such folders, it’ll work - but it leads to rather heavy indexing (which is why kfind is preferable for searching instead of extending the range of baloo).

@Ben Here you go.

Here are my search results:

I initiated the search via Ctrl+f. I’ve used Manjaro for 3 years or so now and the search from within dolphin has never worked for me. Kfind has always worked.

What am I doing wrong?