Dolphin root operations in 5.24.2 KDE frameworks 5.91.0

I was under the impression that in the latest version of Plasma if I try to create/modify files or folders in locations owned by root, that I will be prompted for a password. I just tried making a folder in /etc as well as dropping a text file into it. This was supposed to be included in KDE frameworks 5.91, but as far as I can tell, this doesn’t work. Am I missing something, or is it not yet implemented?

You need to install kde-servicemenus-rootactions, and then you can perform root actions in Dolphin, only still not directly.

Note: As of writing this post, this feature is currently in only Neon Unstable Edition and openSUSE Krypton due to its nature and require more testing before being pushed as stable.


You can do that for any version of Dolphin. It’s actually one of the first things I do after installing the OS and landing on the desktop.

@jackson I also install Nemo so I can run it from Konsole as root. Easier to launch it, drag a copy of the file I want to modify to the desktop, modify it, double and triple check that it’s exactly as it should be, then rename the original in Nemo and drag the modified copy from the desktop back to it’s original location in Nemo. If you do this use it only when necessary and take great pains to make sure the modifications you make are exactly what you want.

I have that already, but that’s not what I’m talking about. From the article in the post below yours it states “Once you try to modify or access any resources or files via Dolphin that you do not have access to, Dolphin will prompt you for an administrator password via KIO.” Launching dolphin with root actions causes me some weirdness, like for example spectacle becomes and remains root as well.

According to this, and other articles, these features have been released in kde frameworks 5.91, which is what I am running.

The article also says… :arrow_down:

Right, and now that time has passed, I am updated to the version of KDE frameworks that includes it.

1 Like

Also according to this article :stuck_out_tongue_winking_eye:

Update: According to KDE developer Nate Graham, the root file operations feature has been reverted as it needs to be “re-done with an eye towards more technical correctness.” For now, this feature appears to only be available in the KDE neon Unstable distribution!


It’s not version-specific. It is only active in Neon Unstable and openSUSE Tumbleweed. It has not been enabled yet in the stable branches of any other distributions.


lol, my fault :sweat_smile:

1 Like

Too bad it is not jet available, nice feature.

1 Like

That’s still being worked on:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.