[Dolphin] Issue with a certain USB stick not showing

i have 2 USB sticks;both formatted on Windows/Fat32 and both have the same files on them.
when i plug one of them it is recognized by the system and i can see it in Dolphin and browse it’s content.
the other one,when i plug it,nothing happens.
i tried browsing around,finding commands i should run like lsblk and lsusb and sudo fdisk -l;
in all of them i can see the USB stick but not sure what i should do next.
i enabled automatic mounting of removable media in system settings and i can see my USB there,but it’s greyed out and i can’t check the boxes next to it.

You could provide the output of those to help others help you better…



sudo fdisk -l
Disk /dev/nvme0n1: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: KINGSTON RBUSNS8154P3512GJ              
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 0D0E2910-3578-F84B-B18D-599922988E95

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1      4096     618495    614400   300M EFI System
/dev/nvme0n1p2    618496  981751960 981133465 467.8G Linux filesystem
/dev/nvme0n1p3 981751961 1000206899  18454939   8.8G Linux swap

Disk /dev/sda: 28.64 GiB, 30752000000 bytes, 60062500 sectors
Disk model: Ultra USB 3.0   
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x5337a090

Device     Boot Start      End  Sectors  Size Id Type
/dev/sda1  *     2048 60061695 60059648 28.6G  c W95 FAT32 (LBA)

sda           8:0    1  28.6G  0 disk 
└─sda1        8:1    1  28.6G  0 part 
nvme0n1     259:0    0 476.9G  0 disk 
├─nvme0n1p1 259:1    0   300M  0 part /boot/efi
├─nvme0n1p2 259:2    0 467.8G  0 part /run/timeshift/backup
└─nvme0n1p3 259:3    0   8.8G  0 part [SWAP]
Bus 002 Device 005: ID 0781:5591 SanDisk Corp. Ultra Flair
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 1532:001c Razer USA, Ltd RZ01-0036 Optical Gaming Mouse [Abyssus]
Bus 001 Device 002: ID 2a7a:0d03  U
Bus 001 Device 005: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)
Bus 001 Device 004: ID 13d3:56a2 IMC Networks USB2.0 HD UVC WebCam
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Plus is that output for the USB-Stick that is not showing up?

that’s just a cheap USB external keyboard;it’s called the same in windows.(U)

If you are able to attach both USB-Sticks at same time and provide the total output of the command below it could help:

  • sudo lsblk --fs

It will help in showing where it is mounted + filesystem etc.
You would also need to describe which one is showing and which one is not showing ofcourse :wink:

“Whatever” is the one that is working.
sudo lsblk --fs

NAME        FSTYPE FSVER LABEL    UUID                                 FSAVAIL FSUSE% MOUNTPOINT
└─sda1      vfat   FAT32 RECOVERY BE9A-6531                                           
└─sdb1      vfat   FAT32 WHATEVER E65D-BCCF                                           
├─nvme0n1p1 vfat   FAT32          D0E1-4B93                             299.1M     0% /boot/efi
├─nvme0n1p2 ext4   1.0            a445c87d-e6a9-47fd-9601-614f3b3e7781  404.2G     7% /run/timeshift/backup
└─nvme0n1p3 swap   1              29e42246-1548-46dd-91f5-17d1f76c7bfd                [SWAP]

That didn’t help much as they are both not mounted…uhmmm what can i suggest more…

the one that’s usually working(“whatever”)probably shows it’s unmounted since i didn’t try to browse through it’s files before running the command;just plugged it in.

i don’t know if it’s normal that Timeshift is over there;i just created a snapshot today and then unsuccessfully tried to browse my snapshots through Timeshift UI, but Dolphin would not open(as described here : Cannot browse Timeshift snapshots)
but rebooted and now Timeshift is not showing when running the same command,but the USB is still not working.

Are you able to mount the “non showing” USB-Stick via terminal and browse it’s contents at all?

sudo systemd-mount /dev/disk/by-uuid/BE9A-6531 /mnt
sudo ls -la /mnt
sudo systemctl stop mnt.mount

First command mounts that stick under /mnt (asuming i got the right one)
Second lists the contents of it.
Third unmounts and removes the unit from systemd again.

yes,i could see the folders and files in that key.
that’s what it looked like:(i replaced the last row that shows folders/files name with ***)

total 3035560
drwxr-xr-x  9 root root      16384 Jan  1  1970  .
drwxr-xr-x 18 root root       4096 Dec 18 08:10  ..
drwxr-xr-x  6 root root      16384 Dec 22 16:07  ***
drwxr-xr-x 24 root root      16384 Dec 10 18:46 ***
-rwxr-xr-x  1 root root 3107067904 Dec  9 16:38  ***
drwxr-xr-x  5 root root      16384 Dec 22 16:00  ***
drwxr-xr-x  4 root root      16384 Dec 22 16:03  ***
-rwxr-xr-x  1 root root     100275 Dec 10 03:27  ***
-rwxr-xr-x  1 root root    1075728 Sep 10 18:00 ***
drwxr-xr-x  4 root root      16384 Dec 10 18:41  ***
drwxr-xr-x  2 root root      16384 Dec 22 15:57 'System Volume Information'
drwxr-xr-x  3 root root      16384 Dec 22 16:03  ***

i don’t know what the first two are: 1970? . and …
and also ‘System Volume Information’.

Well very weird problem you have (for me)…
(I adjusted the title and category for better exposure)

The single dot is the /mnt directory itself.
The double dot is the directory above that eg /
The System Volume Information’ is something that M$ created, it does that normally on NTFS IIRC.

1 Like