Dolphin File Manager to access Synology Database

I seem to be able to “see” that I have shared smb files on my Synology Nas, because I can get to it via the “Remote” under places, however, when I click on it, I get the message:
The file or folder smb://diskstationii.local/ does not exist.
( my synology NAS is called “DiskStationII”.)
Please note:

  1. I have made sure that my Linux user id is a valid user with access on the Synology NAS.
  2. Using Nemo file manager, I can just click on the DiskStationII icon, and get all shared files.
  3. I have edited the filename, and still get that message.

Thanks in advance.

The error message is error message due to the local system not having avahi-daemon enabled and active.

Please acknowledge that accessing a samba share is not always straightforward.

Depending on your Synoloigy conifiguration you may need to add local smb.conf allkowing NT1 as minimum protocol

Check your system log file in both in Linux system and Synology NAS to any warning and issue for related information to SMB file sharing.

Having found it in a post somewhere, I have had avahi-daemon enabled.
No difference -still not found.

I will add NT1 as the minimum protocol to smb.local. Can you please tell me where this file is?

I cannot know what explicitly will work for you so please read [root tip] [How To] Basic Samba Setup and Troubleshooting

I have made changes server side - but doing so requires skills - not recommended for a casual user.

The file should exist as /etc/samba/smb.conf - please not it is allowed to be empty.

Do not ever use NT1 if you can use SMB2 or better. It is exploited by ransomware.

Synology DSM5 and newer has options for specifying Samba protocol version

Screenshot showing the samba setup page on DSM5

Screenshot showing dolphin accessing nas.local (avaihi)

Screenshot showing pcmanfm-qt accessing nas.local using network:///

This is the avahi-daemon default activation

 $ systemctl list-unit-files | grep avahi
avahi-daemon.service                                                      enabled         disabled
avahi-dnsconfd.service                                                    disabled        disabled
avahi-daemon.socket                                                       enabled         disabled

Rereading your initial topic - Dolphin is the dominant Plasma file manager and Nemo is the Cinnamon equivalent.

If you are using Cinnamon then configuration which are naturally present in a Plasma enviroment may not present with the Cinnamon system.

Usually Linux apps can be added into any Linux environment but there is no guarantee the app will function as expected.