Docking station issues

Hey guys,

PLZ help :slight_smile:

I seem to have some trouble with my Lenovo dockingstation.
I am using the W540 Thinkpad with the following specs:

Operating System: Manjaro Linux
KDE Plasma Version: 5.19.4
KDE Frameworks Version: 5.73.0
Qt Version: 5.15.0
Kernel Version: 5.7.15-1-MANJARO
OS Type: 64-bit

Processors: 8 × Intel® Core™ i7-4800MQ CPU @ 2.70GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4600

I do also have a NVIDIA graphic-card on board but it isnt showing up on the about page. I would like to make use of it of course → NVIDIA quadro k1100m.
Its showing in the hardware configurations but not on the about page.

I had to make several installs because I had futile attempts of encrypting my drive using the manjaro architect and on my very first install the dockingstation worked without any problems. I have no idea why it doesn’t now.
Also I would like to ad that the keyboard, the mouse and the sound hooks up perfectly its just the Displays making the problems. so because of the first install I know that it isn’t a hardware problem.
When I connect my Display with a regular cable, it is behaving as expected without trouble.

I would appreciate any help very much because I would love to stay on this distro, I just fell in love with it but I really DO want to use my dockingstations.

-greetings-

If you installed the appropriate video-hybrid-intel-nvidia-.... configuration the Manjaro Settings Manager, then you can run applications using prime-run <program>.

What exactly is the problem with the docking station? Connected displays are not recognized?

Hey, thanks for your reply :slight_smile:

I am sorry to say but I don’t understand this. What should I have installed? I did try to install the graphic drivers if that’s what you mean, is there a way I can check if it did work maybe in the terminal? (I’m sorry if this is what you have been telling me)

Yes that’s right, I connect my device with the dockingstation and everything (mouse, keyboard, speaker, usb-devices, …) is connected and recognized, except the display.

I do own two dockingstations (one for my desk and one for my TV) and its the same problem on both. If I do connect the displays with a cable it does work though.

cheers

Please post the output of inxi -Fazy and mhwd -li.

$ inxi -Fazy
System:
Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64
root=UUID=96197d22-38ae-4c28-9aa9-c6524b7e8040 rw
resume=UUID=99721703-11e6-4ea0-95f2-38b90e2256d2 udev.log_priority=3
Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Machine:
Type: Laptop System: LENOVO product: 20BHS0L000 v: ThinkPad W540
serial: Chassis: type: 10 serial:
Mobo: LENOVO model: 20BHS0L000 serial: UEFI: LENOVO
v: GNET90WW (2.38 ) date: 03/25/2019
Battery:
ID-1: BAT0 charge: 89.4 Wh condition: 89.4/99.5 Wh (90%) volts: 12.3/10.8
model: SANYO 45N1779 type: Li-ion serial: status: Full
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M510
serial: charge: 55% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Info: Quad Core model: Intel Core i7-4800MQ bits: 64 type: MT MCP
arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28
L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
bogomips: 43112
Speed: 2694 MHz min/max: 800/3700 MHz Core speeds (MHz): 1: 2686 2: 2694
3: 2694 4: 2701 5: 2694 6: 2694 7: 2694 8: 2695
Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0416
Device-2: NVIDIA GK107GLM [Quadro K1100M] driver: N/A
alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 chip ID: 10de:0ff6
Device-3: Lite-On Integrated Camera type: USB driver: uvcvideo
bus ID: 2-12:5 chip ID: 04ca:7035
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: intel
display ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
s-diag: 582mm (22.9")
OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
v: 4.5 Mesa 20.2.3 compat-v: 3.0 direct render: Yes
Audio:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:03.0
chip ID: 8086:0c0c
Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20
Device-3: NVIDIA GK107 HDMI Audio driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:0e1b
Sound Server: ALSA v: k5.9.11-3-MANJARO
Network:
Device-1: Intel Ethernet I217-LM vendor: Lenovo driver: e1000e v: kernel
port: 5080 bus ID: 00:19.0 chip ID: 8086:153a
IF: enp0s25 state: down mac:
Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel port: efa0
bus ID: 03:00.0 chip ID: 8086:08b2
IF: wlp3s0 state: up mac:
IF-ID-1: nordlynx state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives:
Local Storage: total: 931.52 GiB used: 214.28 GiB (23.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda vendor: Intenso model: SSD Sata III size: 465.76 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial:
rev: 6A scheme: GPT
ID-2: /dev/sdb vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial:
rev: 023 scheme: GPT
Partition:
ID-1: / raw size: 448.39 GiB size: 440.35 GiB (98.21%)
used: 214.28 GiB (48.7%) fs: ext4 dev: /dev/sda2
Swap:
Kernel: swappiness: 60 (default) cache pressure: 100 (default)
ID-1: swap-1 type: partition size: 17.07 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/sda3
Sensors:
System Temperatures: cpu: 51.0 C mobo: 0.0 C
Fan Speeds (RPM): cpu: 2175
Info:
Processes: 257 Uptime: 6h 17m Memory: 15.52 GiB used: 4.96 GiB (31.9%)
Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1439 lib: 376
Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

$ mhwd -li

Installed PCI configs:


NAME   |   VERSION   |  FREEDRIVER   |   TYPE

video-hybrid-intel-nvidia-390xx-bumblebee | 2020.10.04 | false | PCI



This is made without using the dockingstation or an external display because I am not at home right now.

I spoke too soon about prime-run, unfortunately your GPU is not supported by the earliest nvidia driver which supports PRIME render offload, so you need to use bumblebee. If everything is configured correctly, you can do optirun <program> to run an application using the nvidia gpu. As for the docking station, you could start sudo dmesg -w, and connect the display, and then see if it prints anything.

cool, thanks for the tip =)

no luck

One thing I can imagine is that the docking station’s display output is handled by the nvidia gpu. In that case, this is the relevant part of the Arch wiki. But first you should confirm that bumblebee works: optirun glxgears.

I just failed to use it with the vlc-player it is giving me all kinds of errors. It said I should go threw the “vlc-wrapper” but it didn’t work.

This worked (but just with sudo) without giving me any errors, so do we know that bumblebee worked because of using the optirun command? Or could it have been run threw the Intel chip anyways? Also is 60FPS a good performance?

Running optirun glxinfo -B will tell you which gpu is used.

name of display: :0
display: :0 screen: 0
direct rendering: Yes
Memory info (GL_NVX_gpu_memory_info):
Dedicated video memory: 2048 MB
Total available memory: 2048 MB
Currently available dedicated video memory: 1982 MB
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro K1100M/PCIe/SSE2
OpenGL core profile version string: 4.6.0 NVIDIA 390.132
OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6.0 NVIDIA 390.132
OpenGL shading language version string: 4.60 NVIDIA
OpenGL context flags: (none)
OpenGL profile mask: (none)

looks good am I right? :star_struck:

It looks good. Does this only work with sudo as well? What’s the error if you try to run it normally?

1 Like

Yes it does only work with sudo. Here the error it gives me without sudo:

$ optirun glxinfo -B
[45970.185926] [ERROR]You’ve no permission to communicate with the Bumblebee daemon. Try adding yourself to the ‘bumblebee’ group
[45970.186003] [ERROR]Could not connect to bumblebee daemon - is it running?

Then instead of using sudo, I suggest you add your user to the bumblebee group: sudo usermod -a -G bumblebee $(whoami), then log out and log in. Then you could try simply running intel-virtual-output -f and see if the external display is now recognized.

1 Like

It didn’t work for me, how am a supposed to put my username in the “$(whoami)” part? Let’s say the name is “orange”

Sorry if this annoys you :confused: I tryed it in any way that made sense to me, no succes.

I did try running this as sudo and nothing really happened.

Also why isnt it possible to optirun vlc?

greetings and thanks for effort so far, appreciate it very much.

What do you mean? You don’t have to modify that command at all. The shell will substitute the $(whoami) part with the output of the whoami command, which conveniently gives your username.

Ok thats awesome. Thanks a lot for your effort :slight_smile: this gives me hope in dark times.

So did you succeed in adding your user to the bumblebee group?

What is the error?

yes it did, thank you a lot.

I’m not sure it makes sense after all, did you try it at one point?

I don’t use bumblebee. If optirun vlc doesn’t work for you, please post the error you get. And what about intel-virtual-output? Any success starting it (without sudo)?