DKMS Error On Update

Hi,
I noticed this error after doing a system update:

(12/25) Install DKMS modules
==> dkms install --no-depmod rtl8821cu/5.4.1141ef3ff12 -k 5.15.28-1-MANJARO
Deprecated feature: REMAKE_INITRD
==> depmod 5.15.28-1-MANJARO
==> ERROR: Missing 5.16.14-1-MANJARO kernel modules tree for module rtl8821cu/5.4.1141ef3ff12.
==> ERROR: Missing 5.15.27-1-rt35-MANJARO kernel modules tree for module rtl8821cu/5.4.1141ef3ff12.

I’m worried that if I reboot now my wifi adapter will stop working as rtl8821cu is the driver for it.

Hi @MK-ARCH-LINUX,

If you have more than one kernel installed, you can always boot back into a working one. But it doesn’t look as if you’re kernel headers are installed. To install them for all installed kernels, run:

pamac install $(pamac list --quiet --installed | grep "^linux[0-9]*[-rt]*$" | awk '{print $1"-headers"}' ORS=' ')

And then, just make sure the rtl8821cu is installed:

pamac build rtl8821cu-dkms-git

Hope this helps!

1 Like

Yeah, I’m always having this problem after an update. I’m always doing this: Wifi Not Working After Update - #16 by omano

I thought DKMS should do this for me automatically.

You have to make sure the headers are installed, both for your current kernel, as well as for any new kernel you possibly install.

4 posts were split to a new topic: Dkms error on updating my system