Display Settings blank not showing display settings

Display settings are not showing, the window opens but the options aren’t there.

Hi friends!

Go to Settings - Display Settings:

I’ve tried changing and reinstalling drivers. Deleted all /etc/X11/xorg.conf files including xorg.conf.d folder.

One thing to note is that I’ve always used compiz until recent nvidia driver changes forced me to switch back to xfwm4. With compiz the settings were showing correctly.

Also note I don’t have physical access to the computer. It is physicaly plugged into an hdmi tv, but I login via nomachine. I have another computer with very similar settings (same os, updates and mostly same software) which is plugged into the same tv and display options are showing correctly on the other machine. The only difference is the other computer has intel graphics instead of nvidia and compiz is still working there. I have not tested the other machine without compiz as I do not want to break anything lol.

System repository stable with all updates installed.

 ██████████████████  ████████     x@x
 ██████████████████  ████████     OS: Manjaro 20.2.1 Nibia
 ██████████████████  ████████     Kernel: x86_64 Linux 4.19.173-1-MANJARO
 ██████████████████  ████████     Uptime: 11m
 ████████            ████████     Packages: 1535
 ████████  ████████  ████████     Shell: bash 5.1.0
 ████████  ████████  ████████     Resolution: 1920x1080
 ████████  ████████  ████████     DE: Xfce4
 ████████  ████████  ████████     WM: Xfwm4
 ████████  ████████  ████████     WM Theme: Adapta-Maia
 ████████  ████████  ████████     GTK Theme: Adapta-Maia [GTK2]
 ████████  ████████  ████████     Icon Theme: Papirus-Maia
 ████████  ████████  ████████     Font: Noto Sans 9
 ████████  ████████  ████████     Disk: 2.7T / 12T (23%)
                                  CPU: Intel Core i7 920 @ 8x 2.668GHz
                                  GPU: NVC3
                                  RAM: 5936MiB / 24094MiB
  Type: Desktop System: DELL product: Studio XPS 435T/9000 v: 00 
  serial: <superuser required> 
  Mobo: DELL model: 0X501H v: A02 serial: <superuser required> BIOS: DELL 
  v: A14 date: 10/26/2009 
  Info: Quad Core model: Intel Core i7 920 bits: 64 type: MT MCP 
  L2 cache: 8 MiB 
  Speed: 1596 MHz min/max: 1600/2668 MHz Core speeds (MHz): 1: 1596 2: 1596 
  3: 1596 4: 1596 5: 1596 6: 1596 7: 1596 8: 1596 
  Device-1: NVIDIA GF106 [GeForce GTS 450] driver: nouveau v: kernel 
  Display: x11 server: X.Org 1.20.10 driver: loaded: nouveau 
  unloaded: modesetting s-res: 1920x1080 
  OpenGL: renderer: NVC3 v: 4.3 Mesa 20.3.4 

Any help much appreciated!

1 Like

I still don’t know what to do there. All of my other Manjaro computers are working as expected, but this one single machine is acting weird. It doesn’t make any sense that the display settings windows would be the only windows on the entire machine that I can find which is doing this.

Have you tried logging in as another user and trying it there?
(Warning: I’m on KDE, so can only help you up to a certain level)


Wow, what a great idea. I always suggest this to people using windows but never considered it a possible solution on for Linux… Turns out everything is showing correctly for the other User, but now I have a second user account that I can’t delete… lol

I have a lot of custom settings on this user account and really don’t want to change users. But this will def. help me figure out what’s going on… Thanks a million @Fabby

1 Like

So it looks like created the new user account fixed the problem. Now I can see the display window!! I guess the settings got re-created with the new user… Not sure how it worked, but it worked so I’m not going to worry about it!!! Thanks again bud!

1 Like

Some troubleshooting tips work on all OSes all OSes and this is one: System Error or Profile Error.

Yes, you got lucky!

Have you tried? Worst case scenario: create another user that you cannot delete…


1 Like

LOL, I’ll have to try that!!!

I created the test user in Manjaro Settings Manager, logged into the test account, logged out and back into main account. Checked Display settings, JOY… then went back to Settings Manager and tried to delete the test account and got an error… Reminds me of that song, one thing, leads to anoooother…

I’m hoping it will allow me to delete after a reboot, but either way I’m just happy to have the display settings back! :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.