Disk usage confusion


i am very confused about disk usage! when i right click->properties on my manjaro partition it says 75,5GB / 114,7GB free. however filelight show only 16,3GB of data on there.

the recycle bin (currently empty) has 11,5GB “free space”, im not sure what thats supposed to mean exactly. i thought it might “reserve” space, but adding 11,5GB + 16,3GB is not even 30GB and dolphin somehow says that 39,2GB (114,7-75,5) is used.

if someone could explain whats going on here i would be very thankful!


im using BTRFS btw

I think with btrfs you need to ask the filesystem directly e.g.

btrfs device usage /

A little more info is provided when run with sudo

1 Like

i just read a little about BRTFS, wow i didnt expect it to be so different from other file systems. i kinda understand now why the numbers in dolphin/filelight dont make sense, but i still dont know how i managed to fill so much space already

so this means i have 36GB of data and BRTFS uses 65GB to store it right now?

Using hardlinks or snapshots?

Did you configure Timeshift to automatically take snapshots upon system updates?

just launched timeshift for the first time. i knew about the snapshot feature but i did not mess with it so far. timeshift seems to be active and lists 4 snapshots, including one half an hour ago!

i dont know what hardlinks are … i basically chose BRTFS in installer and did not change anything about the filesystem manually.

Snapshots can hold onto space with each batch of system updates.

Think of the “deleted” packages and files still consuming space (by way of the snapshots), even though the live filesystem is not using them.

However, a discrepancy of 30 GB does seem like a bit much…

well i installed and uninstalled a lot of things!

is it safe to delete all snapshots and deactivate timeshift?

my tmp folder was filled with 20GB+ lol. i deleted that already, but maybe its still saved in the old snapshots?

:flushed: :warning:

I don’t use BTRFS, but I had assumed that the default layout during installation puts tmp in its own subvolume and specifically excludes it from snapshots?

That’s up to you.

Personally, I have switched to creating Timeshift snapshots manually, and keep one “fairly recent” shapshot at all times, just in case an update breaks something. At least I can revert and keep using my system until a fix is discovered (or try the update again.)

Because I do it manually, I also manually delete older snapshots so that I always have “one fairly recent” snapshot in Timeshift. (I’m using XFS, not BTRFS.)

So it’s all down to personal preference.

yeah some program installations didnt work and i tried several times so that seemed to bloat the tmp quite a lot.

i mean “safe” in the way that my system wont be affected by it. ofc im aware that i cant reset the system if i delete the snapshots.

Deleting snapshots won’t affect the live system. :+1:

Just don’t try to get creative with btrfs commands, and stick to using Timeshift’s GUI to delete older snapshots. The reason I mention this is because there’s a risk of accidentally typing in the wrong command or parameter in the terminal, and you end up destroying invaluable data on the live filesystem.

i deleted the snapshots, that freed some space but only around 2GB

sudo btrfs fi show still says 33,74GB are used while filelights shows 16,4GB data :neutral_face:

AFAIK, /tmp folder is using tmpfs by default, not Btrfs.
Check findmnt --types tmpfs | grep /tmp
The output:

/tmp             tmpfs  tmpfs  rw,nosuid,nodev,nr_inodes=1048576,inode64
1 Like

tmpfs tmpfs rw,noatime,inode64

BTRFS allocated 65GB for 33GB data?

maybe because i installed and uninstalled so many things …is brtfs balance a good idea (safe)?

also 4GB meta data, isnt that a bit much?

btw thank you all for your help! :slight_smile:

yes, you can run btrfs balance start / after deleting many things and snapshots.

1 Like

You have two same metadata 2x 2GB.
I have two same metadata 2x 3GB
The size of the metadata depends on Btrfs calculating the size of your data.

sounds like it was necessary!

this looks a lot better :slight_smile:

but i still wonder how i have 33,8GB! no pictures/movies/music/etc on the SSD, just a month old manjaro. and not that many programs actually, i just tried many but uninstalled most.

so i followed this guide - Instructions to clean up Arch Linux (Manjaro) · GitHub - to clean up as much as i can

→ 82,8GB / 114,7GB free

so still around 32GB usage while filelight shows 15,3GB. thats twice as much and i have no clue what/where that data is!

Open KDE Partition Manager to see how big is the usage?

Check again:
sudo btrfs filesystem usage /

kde partition manager says 30GB is used


Both are about the same. But you said " filelight shows 15,3GB"

Something is wrong with calculation of filelight