Disk checking on boot time - silenced?

On every boot, after BIOS post, disk checking text is shown before boot logo.

Aesthetically, it would be better not to be visible by default, in case operation
goes with no problems and no disk issues are found. It just not fit in a nice booting
graphical sequence of KDE Plasma.

If Manjaro team disagree, is there a way for me to silence (quiet) this message
on boot for myself, and how do I do it?

(I don’t want to skip disk check, just silence this message, as I don’t see a reason
it should be shown if everything is OK, just in case of errors)
Cheers :slight_smile:

Edit /etc/default/grub and look for the line… :arrow_down:

GRUB_CMDLINE_LINUX_DEFAULT="list-of-options-here"

Add the word quiet to the options behind that “=”, save the file and then run… :arrow_down:

sudo grub-update

You may be instered in Silent Boot
I have this on my /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash apparmor=1 loglevel=0 rd.udev.log_priority=0"

after that do a

sudo update-grub 

With this,my screen doesn’t show any text unless something fails (like a service) or I press ESC manually to see all the text.

Additionally I have a plymouth so I don’t have a black screen,I have a boot animation like the Windows XP :stuck_out_tongue:

Than you very much. Is there any other downside of doing this this other way?

Plymouth is a little tricky to set up ─ you have to modify /etc/mkinitcpio.conf and rebuild your initramfs, and you have to disable your normal display manager service and enable the Plymouth-specific one ─ the Arch Wiki holds the instructions ─ but you don’t need Plymouth for a quiet boot. Simply adding the word quiet to the kernel options in /etc/default/grub and running update-grub will suffice.

GRUB_CMDLINE_LINUX_DEFAULT=“quiet apparmor=1 security=apparmor udev.log_priority=3”

is my options now. So there is already quiet argument passed, and message still appears

Those arguments are default after Manjaro install, I have not altered anything there. Somehow
checking disk bypasses (ignores) this quiet argument and keeps informing me that /dev/sda1 is clean…

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

This is entire file.

What script exactly calls this disk checking on boot, anyway? Maybe I could edit that script and pass some arguments to fsck not to be verbose if possible…

Modify udev.log_priority=3 to rd.udev.log_priority=0 and add to the end loglevel=0 so should looks like

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor rd.udev.log_priority=0 `loglevel=0"

do a sudo update-grub and now it shouldn’t show anything at boot.

Ok, I’ll try it now…

Does not solve… message still appears :smiley:

Updated grub is now like this, but does not solve…

GRUB_DEFAULT=saved
GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor rd.udev.log_priority=0 loglevel=0"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment this option to enable os-prober execution in the grub-mkconfig command
GRUB_DISABLE_OS_PROBER=false

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically. We use 'fsck' by default, which
# needs 'rw' as boot parameter, to avoid delay in boot-time. 'fsck' needs to be
# removed from 'mkinitcpio.conf' to make 'systemd-fsck' work.
# See also Arch-Wiki: https://wiki.archlinux.org/index.php/Fsck#Boot_time_checking
#GRUB_ROOT_FS_RO=true

If there is no solution just to remove this message, how do I turn off disk checking entirely on boot?

My important data is on cloud anyway, so I don’t really need my disk checked on every boot.

Thats looks alright,did you type in the terminal

sudo update-grub

?,I have no idea why is not working then.

That would be fsck I think

eSecureData Inc..

Yes, I did update grub after editing config file. I don’t know why fsck is not quiet if that argument is passed.

" Update: If your OS uses SystemD, the fsck check is unskippable during boot .

Unskippable? :smiley: Come on, this is Linux…

Wait,I realize you don’t have splash argument,try add that

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash apparmor=1 security=apparmor rd.udev.log_priority=0 `loglevel=0"

Ok, I’ll try…

Still no luck, message appears on boot and on shutdown every time… :frowning:
(btw, you have that ’ infront of loglevel, I removed, it’s typo?)

Yes is a typo sorry about that.

No idea then,I found in the arch wiki that you can indeed disable it

https://wiki.archlinux.org/title/Fsck#Mechanism

Looks like with fsck.mode=skip in the grub,but i’m not sure about that.